summaryrefslogtreecommitdiffstats
path: root/abs/extra/libshout
diff options
context:
space:
mode:
authorCecil <knoppmyth@gmail.com>2011-02-11 07:20:31 (GMT)
committerCecil <knoppmyth@gmail.com>2011-02-11 07:20:31 (GMT)
commit11a0df24bc4720c97e187a986924647b9ae2f911 (patch)
tree13a6a7b8deab6997a40732499902724d77b9c152 /abs/extra/libshout
parent35411fbced50b13f3ad35e056c8e28c01a161064 (diff)
downloadlinhes_pkgbuild-11a0df24bc4720c97e187a986924647b9ae2f911.zip
linhes_pkgbuild-11a0df24bc4720c97e187a986924647b9ae2f911.tar.gz
linhes_pkgbuild-11a0df24bc4720c97e187a986924647b9ae2f911.tar.bz2
libshout:initial inclusion
Diffstat (limited to 'abs/extra/libshout')
-rw-r--r--abs/extra/libshout/PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/abs/extra/libshout/PKGBUILD b/abs/extra/libshout/PKGBUILD
new file mode 100644
index 0000000..8c03bbc
--- /dev/null
+++ b/abs/extra/libshout/PKGBUILD
@@ -0,0 +1,23 @@
+# $Id: PKGBUILD 37200 2009-05-01 03:37:50Z eric $
+# Maintainer: Giovanni Scafora <giovanni@archlinux.org>
+# Contributor: arjan <arjan@archlinux.org>
+# Contributor: Jason Chu <jchu@xentac.net>
+
+pkgname=libshout
+pkgver=2.2.2
+pkgrel=3
+pkgdesc="Library for accessing a shoutcast/icecast server"
+arch=('i686' 'x86_64')
+depends=('libvorbis' 'libtheora' 'speex')
+url="http://www.icecast.org/"
+options=('!libtool' 'force')
+license=('LGPL')
+source=(http://downloads.xiph.org/releases/${pkgname}/${pkgname}-${pkgver}.tar.gz)
+md5sums=('4f75fc9901c724b712c371c9a1e782d3')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var || return 1
+ make LDFLAGS+=-lspeex || return 1
+ make DESTDIR="${pkgdir}" install || return 1
+}