summaryrefslogtreecommitdiffstats
path: root/abs/extra/libupnp
diff options
context:
space:
mode:
authorMichael Hanson <hansonorders@verizon.net>2011-07-05 23:42:34 (GMT)
committerMichael Hanson <hansonorders@verizon.net>2011-07-05 23:42:34 (GMT)
commit14b8d762bcd1bc41b386ef36aa410f85cf7cfb5d (patch)
treec2f0b3d4f835d57406bb950d3dff293956e7f316 /abs/extra/libupnp
parent234b8034cc19925deab37f6f6a39e44ff04b576c (diff)
downloadlinhes_pkgbuild-14b8d762bcd1bc41b386ef36aa410f85cf7cfb5d.zip
linhes_pkgbuild-14b8d762bcd1bc41b386ef36aa410f85cf7cfb5d.tar.gz
linhes_pkgbuild-14b8d762bcd1bc41b386ef36aa410f85cf7cfb5d.tar.bz2
libupnp: add as dep of amule
Diffstat (limited to 'abs/extra/libupnp')
-rw-r--r--abs/extra/libupnp/PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/abs/extra/libupnp/PKGBUILD b/abs/extra/libupnp/PKGBUILD
new file mode 100644
index 0000000..39cfef7
--- /dev/null
+++ b/abs/extra/libupnp/PKGBUILD
@@ -0,0 +1,31 @@
+# $Id$
+# Maintainer: Giovanni Scafora <giovanni@archlinux.org>
+# Contributor: kastor <kastor@fobos.org.ar>
+
+pkgname=libupnp
+pkgver=1.6.13
+pkgrel=1
+pkgdesc="Portable Open Source UPnP Development Kit"
+arch=('i686' 'x86_64')
+url="http://pupnp.sourceforge.net/"
+license=('BSD')
+depends=('glibc')
+makedepends=('pkgconfig')
+options=('!libtool')
+source=("http://downloads.sourceforge.net/sourceforge/pupnp/${pkgname}-${pkgver}.tar.bz2")
+md5sums=('71476b1781ad179bfc9bead640be5f54')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ make DESTDIR=${pkgdir} install
+ install -Dm644 LICENSE ${pkgdir}/usr/share/licenses/custom/${pkgname}/LICENSE
+}
+