summaryrefslogtreecommitdiffstats
path: root/abs/extra/libupnp
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2014-11-20 19:54:41 (GMT)
committerBritney Fransen <brfransen@gmail.com>2014-11-20 19:54:41 (GMT)
commitd70d6be043cb50a9a8ed3154013083475ea64af1 (patch)
treeb66862db1f7c34501ece1d618c3a1ac05c57533d /abs/extra/libupnp
parent7955f87d5071c8214df29b4773291bc2fb40e5a9 (diff)
downloadlinhes_pkgbuild-d70d6be043cb50a9a8ed3154013083475ea64af1.zip
linhes_pkgbuild-d70d6be043cb50a9a8ed3154013083475ea64af1.tar.gz
linhes_pkgbuild-d70d6be043cb50a9a8ed3154013083475ea64af1.tar.bz2
libupnp: initial inclusion. dep of mpd. refs #980
Diffstat (limited to 'abs/extra/libupnp')
-rw-r--r--abs/extra/libupnp/PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/abs/extra/libupnp/PKGBUILD b/abs/extra/libupnp/PKGBUILD
new file mode 100644
index 0000000..1df79d3
--- /dev/null
+++ b/abs/extra/libupnp/PKGBUILD
@@ -0,0 +1,29 @@
+# $Id$
+# Maintainer: Giovanni Scafora <giovanni@archlinux.org>
+# Contributor: kastor <kastor@fobos.org.ar>
+
+pkgname=libupnp
+pkgver=1.6.19
+pkgrel=1
+pkgdesc="Portable Open Source UPnP Development Kit"
+arch=('i686' 'x86_64')
+url="http://pupnp.sourceforge.net/"
+license=('BSD')
+depends=('glibc')
+makedepends=('pkgconfig')
+source=("http://downloads.sourceforge.net/sourceforge/pupnp/${pkgname}-${pkgver}.tar.bz2")
+md5sums=('ee16e5d33a3ea7506f38d71facc057dd')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ make DESTDIR=${pkgdir} install
+ install -Dm644 LICENSE ${pkgdir}/usr/share/licenses/custom/${pkgname}/LICENSE
+}