summaryrefslogtreecommitdiffstats
path: root/abs/extra/libutempter
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2014-12-09 19:45:06 (GMT)
committerBritney Fransen <brfransen@gmail.com>2014-12-09 19:45:06 (GMT)
commit38bd7f02552b7a5aeb19cf20b67fae7ac3c0c358 (patch)
treed571cc67f60d8d3333b343ebc4d389aa5ab20dd4 /abs/extra/libutempter
parentcb367bc15666bb6a1976f6a17cc6004089a2dde2 (diff)
downloadlinhes_pkgbuild-38bd7f02552b7a5aeb19cf20b67fae7ac3c0c358.zip
linhes_pkgbuild-38bd7f02552b7a5aeb19cf20b67fae7ac3c0c358.tar.gz
linhes_pkgbuild-38bd7f02552b7a5aeb19cf20b67fae7ac3c0c358.tar.bz2
libutempter: initial inclusion. dep of xterm
Diffstat (limited to 'abs/extra/libutempter')
-rw-r--r--abs/extra/libutempter/PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/abs/extra/libutempter/PKGBUILD b/abs/extra/libutempter/PKGBUILD
new file mode 100644
index 0000000..bbc27d9
--- /dev/null
+++ b/abs/extra/libutempter/PKGBUILD
@@ -0,0 +1,26 @@
+# $Id: $
+# Maintainer: Jan de Groot <jgc@archlinux.org>
+
+pkgname=libutempter
+pkgver=1.1.6
+pkgrel=2
+pkgdesc="Interface for terminal emulators such as screen and xterm to record user sessions to utmp and wtmp files"
+arch=('i686' 'x86_64')
+url="ftp://ftp.altlinux.org/pub/people/ldv/utempter"
+license=('LGPL')
+depends=('glibc')
+source=(ftp://ftp.altlinux.org/pub/people/ldv/utempter/$pkgname-$pkgver.tar.bz2)
+md5sums=('b43827806923903aba2bc7cd3a2d45b7')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ RPM_OPT_FLAGS="$CFLAGS" make
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+ chown root:utmp "$pkgdir/usr/lib/utempter/utempter"
+ chmod 2755 "$pkgdir/usr/lib/utempter/utempter"
+}