summaryrefslogtreecommitdiffstats
path: root/abs/extra/libva
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-08-07 19:59:44 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-08-07 19:59:44 (GMT)
commit4f5c96fc0454e71815943b514561019568ebe489 (patch)
tree1b9c4f0ca287aa09378e4e97f7ce0c6619c4f16a /abs/extra/libva
parente0767e2dfc10b18022d8ee997b42878b084e1395 (diff)
downloadlinhes_pkgbuild-4f5c96fc0454e71815943b514561019568ebe489.zip
linhes_pkgbuild-4f5c96fc0454e71815943b514561019568ebe489.tar.gz
linhes_pkgbuild-4f5c96fc0454e71815943b514561019568ebe489.tar.bz2
libva 1.0.16
Diffstat (limited to 'abs/extra/libva')
-rw-r--r--abs/extra/libva/PKGBUILD25
-rw-r--r--abs/extra/libva/libva.install5
2 files changed, 18 insertions, 12 deletions
diff --git a/abs/extra/libva/PKGBUILD b/abs/extra/libva/PKGBUILD
index 18c2971..5840a77 100644
--- a/abs/extra/libva/PKGBUILD
+++ b/abs/extra/libva/PKGBUILD
@@ -1,32 +1,33 @@
-# $Id$
+# $Id: PKGBUILD 161866 2012-06-16 00:18:39Z ibiru $
# Maintainer : Ionut Biru <ibiru@archlinux.org>
+
pkgname=libva
-pkgver=1.0.14
+pkgver=1.0.16
pkgrel=1
pkgdesc="Video Acceleration (VA) API for Linux"
arch=('i686' 'x86_64')
url="http://freedesktop.org/wiki/Software/vaapi"
license=('MIT')
-depends=('libgl' 'libdrm>=2.4.23' 'libxfixes')
+depends=('libegl' 'libgl' 'libdrm' 'libxfixes')
makedepends=('mesa')
-optdepends=('vdpau-video: VDPAU backend for VA API')
+optdepends=('vdpau-video: vdpau back-end for nvidia'
+ 'libva-driver-intel: back-end for intel cards')
options=('!libtool')
+install=libva.install
source=(http://cgit.freedesktop.org/libva/snapshot/${pkgname}-${pkgver}.tar.bz2)
-md5sums=('9a7eba239bffa3b40d7a49e3bb4fb6fb')
build() {
- cd ${srcdir}/${pkgname}-${pkgver}
+ cd "$pkgname-$pkgver"
./autogen.sh
- ./configure --prefix=/usr \
- --enable-i965-driver \
- --enable-glx
+ ./configure --prefix=/usr
make
}
package() {
- cd ${srcdir}/${pkgname}-${pkgver}
- make DESTDIR="${pkgdir}" install
- install -m644 -D COPYING ${pkgdir}/usr/share/licenses/${pkgname}/COPYING
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+ install -m644 -D COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
}
# vim:set ts=2 sw=2 et:
+md5sums=('49d74e1e4f8a4937af7a62d457f61106')
diff --git a/abs/extra/libva/libva.install b/abs/extra/libva/libva.install
new file mode 100644
index 0000000..4d8b8e2
--- /dev/null
+++ b/abs/extra/libva/libva.install
@@ -0,0 +1,5 @@
+post_upgrade() {
+ if [ "$(vercmp $2 1.0.15-1)" -lt 0 ]; then
+ echo 'Starting with libva version 1.0.15, the intel back-end is now in libva-driver-intel.'
+ fi
+}