summaryrefslogtreecommitdiffstats
path: root/abs/extra/libva
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2018-03-21 20:42:23 (GMT)
committerBritney Fransen <brfransen@gmail.com>2018-03-21 20:42:23 (GMT)
commit7fb1a88facfc7f36f1d2731f3e772065689526d8 (patch)
treebe0e88eb39ce299485eedf7078703445ddc678de /abs/extra/libva
parent96f619beddc8dbdd1f704f3b10b8aca598747b4c (diff)
downloadlinhes_pkgbuild-7fb1a88facfc7f36f1d2731f3e772065689526d8.zip
linhes_pkgbuild-7fb1a88facfc7f36f1d2731f3e772065689526d8.tar.gz
linhes_pkgbuild-7fb1a88facfc7f36f1d2731f3e772065689526d8.tar.bz2
libva: update to 2.1.0
Diffstat (limited to 'abs/extra/libva')
-rw-r--r--abs/extra/libva/PKGBUILD33
-rw-r--r--abs/extra/libva/not-finding-wl-drm-interface-with-libglvnd.patch48
2 files changed, 68 insertions, 13 deletions
diff --git a/abs/extra/libva/PKGBUILD b/abs/extra/libva/PKGBUILD
index 2d6d0e1..b8037c6 100644
--- a/abs/extra/libva/PKGBUILD
+++ b/abs/extra/libva/PKGBUILD
@@ -1,29 +1,36 @@
# $Id$
-# Maintainer: Ionut Biru <ibiru@archlinux.org>
-# Maintainer: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
+# Maintainer: Maxime Gauduin <alucryd@archlonux.org>
+# Contributor: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
+# Contributor: Ionut Biru <ibiru@archlinux.org>
pkgname=libva
-pkgver=1.7.3
+pkgver=2.1.0
pkgrel=1
pkgdesc='Video Acceleration (VA) API for Linux'
-arch=('i686' 'x86_64')
-url='http://freedesktop.org/wiki/Software/vaapi'
+arch=('x86_64')
+url='https://01.org/linuxmedia/vaapi'
license=('MIT')
-depends=('libgl' 'libdrm' 'libxfixes')
+depends=('glibc' 'libdrm' 'libgl' 'libx11' 'libxext' 'libxfixes' 'wayland')
makedepends=('mesa')
optdepends=('libva-vdpau-driver: backend for Nvidia and AMD cards'
'libva-intel-driver: backend for Intel cards')
-source=(https://freedesktop.org/software/vaapi/releases/$pkgname/$pkgname-$pkgver.tar.bz2)
-sha1sums=('18e46f3d5a0e971eb0ec9fe14bc021e69eb13fb8')
+provides=('libva-drm.so' 'libva-glx.so' 'libva-wayland.so' 'libva-x11.so' 'libva.so')
+source=("https://github.com/01org/libva/releases/download/${pkgver}/libva-${pkgver}.tar.bz2")
+sha256sums=('f3fa953a11d3210c3a4ee79031abdbe0863d5ce13d9b3f93f315f1eec60a4b0f')
build() {
- cd $pkgname-$pkgver
- ./configure --prefix=/usr
+ cd libva-${pkgver}
+
+ ./configure \
+ --prefix='/usr'
make
}
package() {
- cd $pkgname-$pkgver
- make DESTDIR="$pkgdir" install
- install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
+ cd libva-${pkgver}
+
+ make DESTDIR="${pkgdir}" install
+ install -Dm 644 COPYING -t "${pkgdir}"/usr/share/licenses/libva
}
+
+# vim: ts=2 sw=2 et:
diff --git a/abs/extra/libva/not-finding-wl-drm-interface-with-libglvnd.patch b/abs/extra/libva/not-finding-wl-drm-interface-with-libglvnd.patch
new file mode 100644
index 0000000..4041e6c
--- /dev/null
+++ b/abs/extra/libva/not-finding-wl-drm-interface-with-libglvnd.patch
@@ -0,0 +1,48 @@
+From b832b37c6a6f7ff69a4ea4656007827a1b7e67e8 Mon Sep 17 00:00:00 2001
+From: Hans de Goede <hdegoede@redhat.com>
+Date: Wed, 15 Feb 2017 15:18:44 +0100
+Subject: [PATCH] Wayland-drm: Fix not finding wl_drm_interface on systems with
+ libglvnd
+
+We do not want just any libEGL.so.1 we want mesa's libEGL.so.1 as that
+is the only way which defines the wl_drm_interface symbol we need,
+one systems with libglvnd libEGL.so.1 is a dispatcher library provided
+by libglvnd and the actual mesa libEGL we want is named libEGL_mesa.so.0
+so try that first.
+
+Signed-off-by: Hans de Goede <hdegoede@redhat.com>
+---
+ va/wayland/va_wayland_drm.c | 12 +++++++++---
+ 1 file changed, 9 insertions(+), 3 deletions(-)
+
+diff --git a/va/wayland/va_wayland_drm.c b/va/wayland/va_wayland_drm.c
+index 958ea85..2ff19f5 100644
+--- a/va/wayland/va_wayland_drm.c
++++ b/va/wayland/va_wayland_drm.c
+@@ -38,7 +38,10 @@
+ #include "wayland-drm-client-protocol.h"
+
+ /* XXX: Wayland/DRM support currently lives in Mesa libEGL.so.* library */
+-#define LIBWAYLAND_DRM_NAME "libEGL.so.1"
++/* First try the soname of a glvnd enabled mesa build */
++#define LIBWAYLAND_DRM_NAME "libEGL_mesa.so.0"
++/* Then fallback to plain libEGL.so.1 (which might not be mesa) */
++#define LIBWAYLAND_DRM_NAME_FALLBACK "libEGL.so.1"
+
+ typedef struct va_wayland_drm_context {
+ struct va_wayland_context base;
+@@ -207,8 +210,11 @@ va_wayland_drm_create(VADisplayContextP pDisplayContext)
+ vtable->has_prime_sharing = 0;
+
+ wl_drm_ctx->handle = dlopen(LIBWAYLAND_DRM_NAME, RTLD_LAZY|RTLD_LOCAL);
+- if (!wl_drm_ctx->handle)
+- return false;
++ if (!wl_drm_ctx->handle) {
++ wl_drm_ctx->handle = dlopen(LIBWAYLAND_DRM_NAME_FALLBACK, RTLD_LAZY|RTLD_LOCAL);
++ if (!wl_drm_ctx->handle)
++ return false;
++ }
+
+ wl_drm_ctx->drm_interface =
+ dlsym(wl_drm_ctx->handle, "wl_drm_interface");
+