summaryrefslogtreecommitdiffstats
path: root/abs/extra/libvoikko
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2018-04-12 19:59:32 (GMT)
committerBritney Fransen <brfransen@gmail.com>2018-04-12 19:59:32 (GMT)
commitd8668bd9ff95980667299f3c3279fdff0aaa00fc (patch)
tree0ca3771a9d3f5208368ca8eeafc9a9e078b7556b /abs/extra/libvoikko
parent3b518810aac48a9d50a867154c65c1dc04ee72fc (diff)
downloadlinhes_pkgbuild-d8668bd9ff95980667299f3c3279fdff0aaa00fc.zip
linhes_pkgbuild-d8668bd9ff95980667299f3c3279fdff0aaa00fc.tar.gz
linhes_pkgbuild-d8668bd9ff95980667299f3c3279fdff0aaa00fc.tar.bz2
libvoikko: dep of enchant
Diffstat (limited to 'abs/extra/libvoikko')
-rw-r--r--abs/extra/libvoikko/PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/abs/extra/libvoikko/PKGBUILD b/abs/extra/libvoikko/PKGBUILD
new file mode 100644
index 0000000..b1686f1
--- /dev/null
+++ b/abs/extra/libvoikko/PKGBUILD
@@ -0,0 +1,34 @@
+# $Id$
+# Maintainer:
+# Contributor: Jesse Jaara <gmail.com: jesse.jaara>
+# Contributor: Jussi Timperi <gmail.com: jussi.timperi>
+
+pkgname=libvoikko
+pkgver=4.1.1
+pkgrel=1
+pkgdesc="A spelling and grammar checker, hyphenator and collection of related linguistic data for Finnish language"
+arch=(x86_64)
+url="http://voikko.sourceforge.net"
+license=(GPL2)
+depends=(gcc-libs)
+makedepends=(python)
+source=(http://www.puimula.org/voikko-sources/libvoikko/$pkgname-$pkgver.tar.gz)
+sha512sums=('eb8e32dc50e2baa4184a2030537c6fe86054053a75b543d38c7bbc0faf1fbea51020ccfd03d5de94b1d78a811a58eabefc7e87c3eae55f7b7b51409bd1dd8665')
+
+build() {
+ cd $pkgname-$pkgver
+
+# Workaround encoding error
+ export LANG=en_US.UTF-8
+ ./configure --prefix=/usr --enable-hfst=false --with-dictionary-path=/usr/share/voikko
+ make
+}
+
+package() {
+ cd $pkgname-$pkgver
+
+ make DESTDIR="$pkgdir" install
+ mkdir -p "$pkgdir"/usr/lib/python3.6/site-packages
+ cp python/libvoikko.py "$pkgdir"/usr/lib/python3.6/site-packages/libvoikko.py
+}
+