summaryrefslogtreecommitdiffstats
path: root/abs/extra/libvpx
diff options
context:
space:
mode:
authorMichael Hanson <hansonorders@verizon.net>2010-11-10 03:42:27 (GMT)
committerMichael Hanson <hansonorders@verizon.net>2010-11-10 03:42:27 (GMT)
commitc0855beab90c8a331865e860618581d357ea66c5 (patch)
tree1312309ed98e24ee3376ac31cf4cfab06adf4c1f /abs/extra/libvpx
parent5a310ff24dccb8ffe42fed07b77f83a2032864eb (diff)
downloadlinhes_pkgbuild-c0855beab90c8a331865e860618581d357ea66c5.zip
linhes_pkgbuild-c0855beab90c8a331865e860618581d357ea66c5.tar.gz
linhes_pkgbuild-c0855beab90c8a331865e860618581d357ea66c5.tar.bz2
libvpx: initial include for ffmpeg
Diffstat (limited to 'abs/extra/libvpx')
-rw-r--r--abs/extra/libvpx/PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/abs/extra/libvpx/PKGBUILD b/abs/extra/libvpx/PKGBUILD
new file mode 100644
index 0000000..1f00831
--- /dev/null
+++ b/abs/extra/libvpx/PKGBUILD
@@ -0,0 +1,28 @@
+# $Id: PKGBUILD 97641 2010-10-31 21:07:06Z ibiru $
+# Maintainer: Ionut Biru <ibiru@archlinux.org>
+pkgname=libvpx
+pkgver=0.9.5
+pkgrel=1
+pkgdesc="The VP8 Codec SDK"
+arch=('i686' 'x86_64')
+url="http://www.webmproject.org/"
+license=('BSD')
+depends=('glibc')
+makedepends=('yasm')
+source=(http://webm.googlecode.com/files/${pkgname}-v${pkgver}.tar.bz2)
+sha1sums=('223965ff16737251afb3377c0800d1f8b5f84379')
+
+build() {
+ cd "${srcdir}/${pkgname}-v${pkgver}"
+ ./configure --enable-vp8 \
+ --enable-runtime-cpu-detect \
+ --enable-shared \
+ --enable-postproc \
+ --enable-pic \
+ --disable-install-docs \
+ --disable-install-srcs
+ make
+ make DIST_DIR="$pkgdir/usr" install
+ install -D -m 0644 LICENSE "$pkgdir/usr/share/licenses/${pkgname}/LICENSE"
+}
+