summaryrefslogtreecommitdiffstats
path: root/abs/extra/libwebkit
diff options
context:
space:
mode:
authorCecil <knoppmyth@gmail.com>2010-12-28 18:05:44 (GMT)
committerCecil <knoppmyth@gmail.com>2010-12-28 18:05:44 (GMT)
commit0ddd714e3fc2207088b35390ecd86062946df555 (patch)
tree7b9a6e70c9d8b6a66e2d583c5e666170f5eb04af /abs/extra/libwebkit
parenta23c7142f0acb22ce3893d737db5f99a6c95c834 (diff)
downloadlinhes_pkgbuild-0ddd714e3fc2207088b35390ecd86062946df555.zip
linhes_pkgbuild-0ddd714e3fc2207088b35390ecd86062946df555.tar.gz
linhes_pkgbuild-0ddd714e3fc2207088b35390ecd86062946df555.tar.bz2
libwebkit:initial inclusion.
Diffstat (limited to 'abs/extra/libwebkit')
-rw-r--r--abs/extra/libwebkit/PKGBUILD36
-rw-r--r--abs/extra/libwebkit/introspection.patch22
2 files changed, 58 insertions, 0 deletions
diff --git a/abs/extra/libwebkit/PKGBUILD b/abs/extra/libwebkit/PKGBUILD
new file mode 100644
index 0000000..1c7705b
--- /dev/null
+++ b/abs/extra/libwebkit/PKGBUILD
@@ -0,0 +1,36 @@
+# $Id: PKGBUILD 95079 2010-10-14 18:34:57Z andyrtr $
+# Maintainer: Andreas Radke <andyrtr@archlinux.org>
+
+pkgname=libwebkit
+pkgver=1.2.5
+pkgrel=1
+pkgdesc="an opensource web content engine, derived from KHTML and KJS from KDE"
+arch=('i686' 'x86_64')
+url="http://webkitgtk.org/"
+license=('custom')
+depends=('libxt' 'libxslt' 'sqlite3' 'gtk2' 'icu>=4.4' 'gstreamer0.10-base' 'libsoup' 'enchant')
+makedepends=('gperf' 'gtk-doc' 'gobject-introspection')
+provides=('webkitgtk-svn')
+conflicts=('webkitgtk-svn')
+replaces=('webkitgtk-svn')
+options=('!libtool') # '!makeflags')
+source=(http://webkitgtk.org/webkit-${pkgver}.tar.gz
+ introspection.patch)
+md5sums=('09f04985665b9abf6f0d9956f86a6a31'
+ 'e7e83312618cb30cc9a1567a21cd0e06')
+
+build() {
+ cd "${srcdir}/webkit-${pkgver}"
+ patch -Np0 -i "${srcdir}/introspection.patch"
+ ./configure --prefix=/usr \
+ --enable-video --enable-introspection \
+ --with-font-backend=freetype --enable-gtk-doc \
+ --enable-jit --with-unicode-backend=icu
+ make
+}
+
+package() {
+ cd "${srcdir}/webkit-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+ install -Dm644 WebKit/LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
diff --git a/abs/extra/libwebkit/introspection.patch b/abs/extra/libwebkit/introspection.patch
new file mode 100644
index 0000000..f12e9e6
--- /dev/null
+++ b/abs/extra/libwebkit/introspection.patch
@@ -0,0 +1,22 @@
+--- WebKit/gtk/JSCore-1.0.gir 2010-09-29 14:54:07.000000000 +0200
++++ WebKit/gtk/JSCore-1.0.gir 2010-09-29 15:57:06.000000000 +0200
+@@ -1,12 +1,14 @@
+ <?xml version="1.0"?>
+-<repository version="1.0"
++<repository version="1.2"
+ xmlns="http://www.gtk.org/introspection/core/1.0"
+ xmlns:c="http://www.gtk.org/introspection/c/1.0">
+ <namespace name="JSCore" version="1.0" shared-library="webkit-1.0">
+- <alias name="GlobalContextRef"
+- target="none"
+- c:type="JSGlobalContextRef"/>
+- <alias name="ObjectRef" target="none" c:type="JSObjectRef"/>
++ <alias name="GlobalContextRef" target="none">
++ <type name="JSGlobalContextRef" c:type="JSGlobalContextRef"/>
++ </alias>
++ <alias name="ObjectRef" target="none">
++ <type name="JSObjectRef" c:type="JSObjectRef"/>
++ </alias>
+ <function name="EvaluateScript" c:identifier="JSEvaluateScript">
+ <return-value transfer-ownership="none">
+ <type name="none" c:type="void"/>