summaryrefslogtreecommitdiffstats
path: root/abs/extra/libxkbcommon
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2014-12-01 17:56:15 (GMT)
committerBritney Fransen <brfransen@gmail.com>2014-12-01 17:56:15 (GMT)
commit5620424ea329f1a4bbee6e28ca398df0f67b45c3 (patch)
tree13d0609bbd55966e92ef10fcf7d13e532799c6f4 /abs/extra/libxkbcommon
parent6a758837acb210003de46f984f1ddf804f9ea077 (diff)
downloadlinhes_pkgbuild-5620424ea329f1a4bbee6e28ca398df0f67b45c3.zip
linhes_pkgbuild-5620424ea329f1a4bbee6e28ca398df0f67b45c3.tar.gz
linhes_pkgbuild-5620424ea329f1a4bbee6e28ca398df0f67b45c3.tar.bz2
libxkbcommon: initial commit. dep of gtk3
Diffstat (limited to 'abs/extra/libxkbcommon')
-rw-r--r--abs/extra/libxkbcommon/PKGBUILD54
1 files changed, 54 insertions, 0 deletions
diff --git a/abs/extra/libxkbcommon/PKGBUILD b/abs/extra/libxkbcommon/PKGBUILD
new file mode 100644
index 0000000..1b3a42c
--- /dev/null
+++ b/abs/extra/libxkbcommon/PKGBUILD
@@ -0,0 +1,54 @@
+# $Id$
+# Maintainer: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
+# Contributor: Daniel Micay <danielmicay@gmail.com>
+# Contributor: Mladen Pejakovic <pejakm@gmail.com>
+
+pkgbase=libxkbcommon
+pkgname=(libxkbcommon libxkbcommon-x11)
+pkgver=0.5.0
+pkgrel=1
+pkgdesc="Keyboard handling library using XKB data"
+arch=(i686 x86_64)
+url="http://xkbcommon.org/"
+license=(custom)
+depends=(xkeyboard-config glibc)
+checkdepends=(xorg-server-xvfb libgl)
+makedepends=(libxcb doxygen xorg-util-macros)
+source=("http://xkbcommon.org/download/$pkgname-$pkgver.tar.xz")
+md5sums=('2e1faeafcc609c30af3a561a91e84158')
+
+prepare() {
+ mkdir -p x11/usr/{include/xkbcommon,lib/pkgconfig}
+}
+
+build() {
+ cd $pkgbase-$pkgver
+ ./configure --prefix=/usr --disable-static
+ make
+}
+
+check() {
+ cd $pkgbase-$pkgver
+ xvfb-run -a make -k check
+}
+
+package_libxkbcommon() {
+ cd $pkgbase-$pkgver
+ make DESTDIR="$pkgdir" install
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/libxkbcommon/LICENSE"
+
+### Split libxkbcommon-x11
+
+ mv "$pkgdir"/usr/lib/*x11* "$srcdir/x11/usr/lib"
+ mv "$pkgdir"/usr/lib/pkgconfig/*x11* "$srcdir/x11/usr/lib/pkgconfig"
+ mv "$pkgdir"/usr/include/xkbcommon/*x11* "$srcdir/x11/usr/include/xkbcommon"
+}
+
+package_libxkbcommon-x11() {
+ pkgdesc="Keyboard handling library using XKB data for X11 XCB clients"
+ depends=(libxkbcommon libxcb)
+
+ mv x11/* "$pkgdir"
+
+ install -Dm644 $pkgbase-$pkgver/COPYING "$pkgdir/usr/share/licenses/libxkbcommon-x11/LICENSE"
+}