summaryrefslogtreecommitdiffstats
path: root/abs/extra/libzip
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2014-12-08 15:32:09 (GMT)
committerBritney Fransen <brfransen@gmail.com>2014-12-08 15:32:09 (GMT)
commit00e3d220f590f378e0ac4dba20c683eae8d656cb (patch)
treec07f746a5959abacbc244a19813a5a9ec895b69e /abs/extra/libzip
parent6ea53c73dfdb044e19e5cf593f8cb72754ba70c3 (diff)
downloadlinhes_pkgbuild-00e3d220f590f378e0ac4dba20c683eae8d656cb.zip
linhes_pkgbuild-00e3d220f590f378e0ac4dba20c683eae8d656cb.tar.gz
linhes_pkgbuild-00e3d220f590f378e0ac4dba20c683eae8d656cb.tar.bz2
libzip: update to 0.11.2
Diffstat (limited to 'abs/extra/libzip')
-rw-r--r--abs/extra/libzip/PKGBUILD21
1 files changed, 10 insertions, 11 deletions
diff --git a/abs/extra/libzip/PKGBUILD b/abs/extra/libzip/PKGBUILD
index b95a3a4..5ff63dd 100644
--- a/abs/extra/libzip/PKGBUILD
+++ b/abs/extra/libzip/PKGBUILD
@@ -1,32 +1,31 @@
-# $Id: PKGBUILD 154546 2012-03-30 00:01:03Z eric $
+# $Id$
# Maintainer: Andrea Scarpino <andrea@archlinux.org>
# Contributor: Tobias Powalowski <tpowa@archlinux.org>
pkgname=libzip
-pkgver=0.10.1
+pkgver=0.11.2
pkgrel=1
pkgdesc="A C library for reading, creating, and modifying zip archives"
url="http://www.nih.at/libzip/index.html"
license=('BSD')
arch=('i686' 'x86_64')
depends=('zlib')
-options=('!libtool')
-source=("http://www.nih.at/${pkgname}/${pkgname}-${pkgver}.tar.bz2"
- 'fix-headers.patch')
-md5sums=('d3e933ae049204badccf605f20aaecde'
- '249395bd3a426c4c4e993e9d4753e1dd')
+source=("http://www.nih.at/${pkgname}/${pkgname}-${pkgver}.tar.xz")
+md5sums=('44c99b67dca34707b5728e5f8434fe91')
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd ${pkgname}-${pkgver}
- patch -p1 -i "${srcdir}/fix-headers.patch"
- autoreconf -i
./configure --prefix=/usr
make
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd ${pkgname}-${pkgver}
+
make DESTDIR="${pkgdir}" install
+
+ # preserve old header path for compatibility
+ ln -s /usr/lib/libzip/include/zipconf.h "${pkgdir}/usr/include/zipconf.h"
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}