summaryrefslogtreecommitdiffstats
path: root/abs/extra/libzip
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-08-15 15:47:52 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-08-15 15:47:52 (GMT)
commit82bd3af1ac492cb8a5218127774994a5fdb40d0e (patch)
tree1114ab9743c9bad4da4cefe35bcb9ffe2e9182c2 /abs/extra/libzip
parent440baa856ce8af1c042b7fb559ff84e4cfa01d0b (diff)
downloadlinhes_pkgbuild-82bd3af1ac492cb8a5218127774994a5fdb40d0e.zip
linhes_pkgbuild-82bd3af1ac492cb8a5218127774994a5fdb40d0e.tar.gz
linhes_pkgbuild-82bd3af1ac492cb8a5218127774994a5fdb40d0e.tar.bz2
libzip: 0.10.1
-new
Diffstat (limited to 'abs/extra/libzip')
-rw-r--r--abs/extra/libzip/PKGBUILD32
-rw-r--r--abs/extra/libzip/fix-headers.patch15
2 files changed, 47 insertions, 0 deletions
diff --git a/abs/extra/libzip/PKGBUILD b/abs/extra/libzip/PKGBUILD
new file mode 100644
index 0000000..b95a3a4
--- /dev/null
+++ b/abs/extra/libzip/PKGBUILD
@@ -0,0 +1,32 @@
+# $Id: PKGBUILD 154546 2012-03-30 00:01:03Z eric $
+# Maintainer: Andrea Scarpino <andrea@archlinux.org>
+# Contributor: Tobias Powalowski <tpowa@archlinux.org>
+
+pkgname=libzip
+pkgver=0.10.1
+pkgrel=1
+pkgdesc="A C library for reading, creating, and modifying zip archives"
+url="http://www.nih.at/libzip/index.html"
+license=('BSD')
+arch=('i686' 'x86_64')
+depends=('zlib')
+options=('!libtool')
+source=("http://www.nih.at/${pkgname}/${pkgname}-${pkgver}.tar.bz2"
+ 'fix-headers.patch')
+md5sums=('d3e933ae049204badccf605f20aaecde'
+ '249395bd3a426c4c4e993e9d4753e1dd')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ patch -p1 -i "${srcdir}/fix-headers.patch"
+ autoreconf -i
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
diff --git a/abs/extra/libzip/fix-headers.patch b/abs/extra/libzip/fix-headers.patch
new file mode 100644
index 0000000..7591710
--- /dev/null
+++ b/abs/extra/libzip/fix-headers.patch
@@ -0,0 +1,15 @@
+diff -urN libzip-0.10rc1.old/lib/Makefile.am libzip-0.10rc1/lib/Makefile.am
+--- libzip-0.10rc1.old/lib/Makefile.am 2011-03-05 01:07:33.921722002 +0100
++++ libzip-0.10rc1/lib/Makefile.am 2011-03-05 20:29:30.349388003 +0100
+@@ -2,8 +2,9 @@
+
+ lib_LTLIBRARIES = libzip.la
+ noinst_HEADERS = zipint.h
+-include_HEADERS = zip.h
+-libinclude_HEADERS = zipconf.h
++include_HEADERS = \
++ zip.h \
++ zipconf.h
+
+ # also update CMakeLists.txt when changing version
+ libzip_la_LDFLAGS=-no-undefined -version-info 2:0