summaryrefslogtreecommitdiffstats
path: root/abs/extra/lua/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-08-15 15:48:22 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-08-15 15:48:22 (GMT)
commit04c6817ff11a99c1d89dca7cc4dcd9aa3210271d (patch)
tree043162e4bdbdd4b09dcc315f4e325de356bed297 /abs/extra/lua/PKGBUILD
parent82bd3af1ac492cb8a5218127774994a5fdb40d0e (diff)
downloadlinhes_pkgbuild-04c6817ff11a99c1d89dca7cc4dcd9aa3210271d.zip
linhes_pkgbuild-04c6817ff11a99c1d89dca7cc4dcd9aa3210271d.tar.gz
linhes_pkgbuild-04c6817ff11a99c1d89dca7cc4dcd9aa3210271d.tar.bz2
lua: 5.1.5
-readding lua to extra was previously in extra/community
Diffstat (limited to 'abs/extra/lua/PKGBUILD')
-rw-r--r--abs/extra/lua/PKGBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/abs/extra/lua/PKGBUILD b/abs/extra/lua/PKGBUILD
new file mode 100644
index 0000000..9ed38d8
--- /dev/null
+++ b/abs/extra/lua/PKGBUILD
@@ -0,0 +1,42 @@
+# $Id: PKGBUILD 156332 2012-04-17 10:35:09Z bluewind $
+# Maintainer: Juergen Hoetzel <juergen@archlinux.org>
+# Contributor: Damir Perisa <damir.perisa@bluewin.ch>
+
+pkgname=lua
+pkgver=5.1.5
+pkgrel=2
+pkgdesc="A powerful light-weight programming language designed for extending applications"
+arch=('i686' 'x86_64')
+url="http://www.lua.org/"
+depends=('readline')
+license=('MIT')
+options=('!makeflags' '!emptydirs')
+source=(http://www.lua.org/ftp/${pkgname}-${pkgver}.tar.gz
+ lua-arch.patch lua-5.1-cflags.diff)
+md5sums=('2e115fe26e435e33b0d5c022e4490567'
+ 'fa25feb70ef9fec975b1c20da5098b3c'
+ '249582bf1fd861ccf492d2c35a9fe732')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ patch -p1 -i "${srcdir}/lua-arch.patch"
+ patch -p1 -i "${srcdir}/lua-5.1-cflags.diff"
+ export CFLAGS="$CFLAGS -fPIC"
+
+ make INSTALL_DATA="cp -d" TO_LIB="liblua.a liblua.so liblua.so.5.1" \
+ INSTALL_TOP="${pkgdir}/usr" INSTALL_MAN="${pkgdir}/usr/share/man/man1" \
+ linux
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make INSTALL_DATA="cp -d" TO_LIB="liblua.a liblua.so liblua.so.5.1 liblua.so.$pkgver" \
+ INSTALL_TOP="${pkgdir}/usr" INSTALL_MAN="${pkgdir}/usr/share/man/man1" \
+ install
+ install -D -m644 etc/lua.pc "${pkgdir}/usr/lib/pkgconfig/lua.pc"
+ install -D -m644 COPYRIGHT "${pkgdir}/usr/share/licenses/${pkgname}/COPYRIGHT"
+
+ # Install the documentation
+ install -d "${pkgdir}/usr/share/doc/lua"
+ install -m644 doc/*.{gif,png,css,html} "${pkgdir}/usr/share/doc/lua"
+}