summaryrefslogtreecommitdiffstats
path: root/abs/extra/lua51
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2018-04-24 21:37:03 (GMT)
committerBritney Fransen <brfransen@gmail.com>2018-04-24 21:37:03 (GMT)
commit9e8e6724778e13107c64a3c38978773b4f98ef10 (patch)
treea6b110fe47b44d943b188af84d5592d797c6ca9e /abs/extra/lua51
parentee95a0d61b703dde0a0b0615d44683dea38d4e27 (diff)
downloadlinhes_pkgbuild-9e8e6724778e13107c64a3c38978773b4f98ef10.zip
linhes_pkgbuild-9e8e6724778e13107c64a3c38978773b4f98ef10.tar.gz
linhes_pkgbuild-9e8e6724778e13107c64a3c38978773b4f98ef10.tar.bz2
lua51: rebuild
Diffstat (limited to 'abs/extra/lua51')
-rw-r--r--abs/extra/lua51/PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/abs/extra/lua51/PKGBUILD b/abs/extra/lua51/PKGBUILD
index 39ac19c..1f802e8 100644
--- a/abs/extra/lua51/PKGBUILD
+++ b/abs/extra/lua51/PKGBUILD
@@ -5,9 +5,9 @@
pkgname=lua51
pkgver=5.1.5
-pkgrel=4
+pkgrel=6
pkgdesc='Powerful lightweight programming language designed for extending applications'
-arch=('i686' 'x86_64')
+arch=('x86_64')
url='http://www.lua.org/'
depends=('readline')
license=('MIT')
@@ -23,15 +23,15 @@ prepare() {
cd lua-$pkgver
patch -p1 -i ../lua-arch.patch
patch -p1 -i ../lua-5.1-cflags.diff
+
+ sed -e 's:llua:llua5.1:' -e 's:/include:/include/lua5.1:' -i etc/lua.pc
+ sed -r -e '/^LUA_(SO|A|T)=/ s/lua/lua5.1/' -e '/^LUAC_T=/ s/luac/luac5.1/' -i src/Makefile
}
build() {
cd lua-$pkgver
[[ $CARCH == x86_64 ]] && export CFLAGS="$CFLAGS -fPIC"
- sed -e 's:llua:llua5.1:' -e 's:/include:/include/lua5.1:' -i etc/lua.pc
- sed -r -e '/^LUA_(SO|A|T)=/ s/lua/lua5.1/' -e '/^LUAC_T=/ s/luac/luac5.1/' \
- -i src/Makefile
make MYCFLAGS="$CFLAGS" MYLDFLAGS="$LDFLAGS" linux
}
@@ -47,8 +47,8 @@ package() {
INSTALL_MAN="$pkgdir"/usr/share/man/man1 \
install
- install -Dm644 etc/lua.pc "$pkgdir"/usr/lib/pkgconfig/lua5.1.pc
- install -d "$pkgdir/usr/share/doc/$pkgname"
+ install -Dm644 etc/lua.pc "$pkgdir"/usr/lib/pkgconfig/$pkgname.pc
+ install -d "$pkgdir"/usr/share/doc/$pkgname
install -m644 doc/*.{gif,png,css,html} "$pkgdir"/usr/share/doc/$pkgname
install -Dm644 COPYRIGHT "$pkgdir"/usr/share/licenses/$pkgname/COPYRIGHT