summaryrefslogtreecommitdiffstats
path: root/abs/extra/m17n-lib
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-12-07 15:03:21 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-12-07 15:03:21 (GMT)
commit04d51a2dda374d5af31cebe06ba7d0f9b4c1b974 (patch)
tree6a338b24f8433008fd8b9b14371ca2f3e4b8a92d /abs/extra/m17n-lib
parent7ddd7405fd1097967e25ae63f62a95ab64d4f873 (diff)
downloadlinhes_pkgbuild-04d51a2dda374d5af31cebe06ba7d0f9b4c1b974.zip
linhes_pkgbuild-04d51a2dda374d5af31cebe06ba7d0f9b4c1b974.tar.gz
linhes_pkgbuild-04d51a2dda374d5af31cebe06ba7d0f9b4c1b974.tar.bz2
emacs: 24.2
required by emacs: libotf mn17n
Diffstat (limited to 'abs/extra/m17n-lib')
-rw-r--r--abs/extra/m17n-lib/PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/abs/extra/m17n-lib/PKGBUILD b/abs/extra/m17n-lib/PKGBUILD
new file mode 100644
index 0000000..c2e8511
--- /dev/null
+++ b/abs/extra/m17n-lib/PKGBUILD
@@ -0,0 +1,27 @@
+# $Id: PKGBUILD 172459 2012-12-03 05:46:31Z bisson $
+# Maintainer: Gaetan Bisson <bisson@archlinux.org>
+# Contributor: Camille Moncelier <pix@devlife.org>
+
+pkgname=m17n-lib
+pkgver=1.6.4
+pkgrel=1
+pkgdesc='Multilingual text processing library (runtimes)'
+url='http://www.nongnu.org/m17n/'
+arch=('i686' 'x86_64')
+license=('GPL')
+depends=('libxft' 'm17n-db' 'fribidi' 'libxml2' 'gd' 'libotf')
+optdepends=('anthy: to use the anthy input method')
+options=('!makeflags' '!libtool' '!emptydirs')
+source=("http://download.savannah.gnu.org/releases/m17n/${pkgname}-${pkgver}.tar.gz")
+sha1sums=('83f2fc4facfd70a580bb95d9381eac7472d85171')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure --prefix=/usr --enable-static=no
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+}