summaryrefslogtreecommitdiffstats
path: root/abs/extra/mc/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-11-26 14:58:55 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-11-26 14:58:55 (GMT)
commit33d9f1c5366b091e6dc1ac66b3e8da6c022a050f (patch)
tree5aa7b08168c7338c2c03832954309a1834a52e6f /abs/extra/mc/PKGBUILD
parent35848eb77301fe20bc9808caade9d2f3a0e966ba (diff)
downloadlinhes_pkgbuild-33d9f1c5366b091e6dc1ac66b3e8da6c022a050f.zip
linhes_pkgbuild-33d9f1c5366b091e6dc1ac66b3e8da6c022a050f.tar.gz
linhes_pkgbuild-33d9f1c5366b091e6dc1ac66b3e8da6c022a050f.tar.bz2
mc: 4.8.6
Diffstat (limited to 'abs/extra/mc/PKGBUILD')
-rw-r--r--abs/extra/mc/PKGBUILD78
1 files changed, 45 insertions, 33 deletions
diff --git a/abs/extra/mc/PKGBUILD b/abs/extra/mc/PKGBUILD
index 889a421..240ff16 100644
--- a/abs/extra/mc/PKGBUILD
+++ b/abs/extra/mc/PKGBUILD
@@ -1,52 +1,64 @@
-# $Id: PKGBUILD 90427 2010-09-11 16:25:31Z pierre $
-# Contributer: dorphell <dorphell@archlinux.org>
-# Committer: Judd Vinet <jvinet@zeroflux.org>
-# Contributor: Lucien Immink <l.immink@student.fnt.hvu.nl>
-# Maintainer: Daniel J Griffiths <ghost1227@archlinux.us>
+# $Id: PKGBUILD 78273 2012-10-17 10:28:14Z allan $
+# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
+# Maintainer: schuay <jakob.gruber@gmail.com>
pkgname=mc
-pkgver=4.7.4
-pkgrel=1
-pkgdesc="A filemanager/shell that emulates Norton Commander"
+pkgver=4.8.6
+pkgrel=2
+pkgdesc="Midnight Commander is a text based filemanager/shell that emulates Norton Commander"
arch=('i686' 'x86_64')
url="http://www.ibiblio.org/mc/"
license=('GPL')
-depends=('e2fsprogs' 'glib2' 'pcre' 'gpm>=1.20.4' 'slang')
+depends=('e2fsprogs' 'glib2' 'pcre' 'gpm' 'slang')
makedepends=('libxt' 'libx11')
-optdepends=('p7zip: support for 7zip archives')
-provides=('mcedit-pkgbuild-syntax')
-conflicts=('mc-utf8')
-replaces=('mc-utf8')
+optdepends=(
+ 'cabextract: ucab extfs'
+ 'cdparanoia: audio extfs'
+ 'cdrkit: iso9660 extfs'
+ 'gawk: hp48+ extfs'
+ 'aspell: spelling corrections'
+ 'cvs: CVS support'
+ 'mtools: a+ extfs'
+ 'perl: needed by several extfs scripts'
+ 'python2-boto: s3+ extfs'
+ 'python2-pytz: s3+ extfs'
+ 'smb: VFS support'
+ 'unace: uace extfs'
+ 'unarj: uarj extfs'
+ 'unrar: urar extfs'
+ 'zip: uzip extfs'
+ 'libssh2: support for sftp'
+ 'p7zip: support for 7zip archives')
options=('!emptydirs' '!makeflags')
+backup=('etc/mc/edit.indent.rc'
+ 'etc/mc/filehighlight.ini'
+ 'etc/mc/mcedit.menu'
+ 'etc/mc/mc.ext'
+ 'etc/mc/mc.keymap'
+ 'etc/mc/mc.menu'
+ 'etc/mc/sfs.ini')
source=("http://www.midnight-commander.org/downloads/${pkgname}-${pkgver}.tar.bz2")
-md5sums=('ae07f873b91e8a2e4a3b081f1adedd2e')
build() {
- cd ${srcdir}/${pkgname}-${pkgver}
+ cd "${srcdir}/${pkgname}-${pkgver}"
- ./configure \
- --prefix=/usr --sysconfdir=/etc --mandir=/usr/share/man \
- --enable-background --enable-charset --enable-largefile \
- --with-edit --with-gpm-mouse --with-mmap --with-samba \
- --with-screen=slang --with-subshell --with-vfs --with-x \
- --without-debug --without-gnome --without-included-gettext \
- --libexecdir=/usr/lib
+ ./configure --prefix=/usr --sysconfdir=/etc --enable-vfs-smb \
+ --with-x --libexecdir=/usr/lib
- make
+ make
}
package() {
- cd ${srcdir}/${pkgname}-${pkgver}
+ cd "${srcdir}/${pkgname}-${pkgver}"
- make DESTDIR=${pkgdir} install
+ make DESTDIR="${pkgdir}" install
- # Fix FS#15177
- sed 's|op_has_zipinfo = 0|op_has_zipinfo = 1|' \
- -i ${pkgdir}/usr/lib/mc/extfs.d/uzip
+ # Fix FS#15177
+ sed 's|op_has_zipinfo = 0|op_has_zipinfo = 1|' \
+ -i "${pkgdir}/usr/lib/mc/extfs.d/uzip"
- # Fix FS#18312
- rm ${pkgdir}/usr/lib/mc/extfs.d/u7z
-
- sed 's#/usr/bin/env python#/usr/bin/python2#' \
- -i ${pkgdir}/usr/lib/mc/extfs.d/s3+
+ sed 's#/usr/bin/env python#/usr/bin/python2#' \
+ -i "${pkgdir}/usr/lib/mc/extfs.d/s3+"
}
+
+md5sums=('323706aa5e77698bed7b0b6faa7c1530')