summaryrefslogtreecommitdiffstats
path: root/abs/extra/memtest86+
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-08-07 20:03:01 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-08-07 20:03:01 (GMT)
commit2591f707fcbaf4e9ed30d9ca2c9d193784b38395 (patch)
tree0ff97a65a35f9686263954265e7b1f18fe405b89 /abs/extra/memtest86+
parenta6df6a7a090a9cc23eb7abb40fd729ab73f7b908 (diff)
downloadlinhes_pkgbuild-2591f707fcbaf4e9ed30d9ca2c9d193784b38395.zip
linhes_pkgbuild-2591f707fcbaf4e9ed30d9ca2c9d193784b38395.tar.gz
linhes_pkgbuild-2591f707fcbaf4e9ed30d9ca2c9d193784b38395.tar.bz2
memtest86 4.20
-new
Diffstat (limited to 'abs/extra/memtest86+')
-rw-r--r--abs/extra/memtest86+/PKGBUILD17
-rw-r--r--abs/extra/memtest86+/memtest86+.install23
2 files changed, 40 insertions, 0 deletions
diff --git a/abs/extra/memtest86+/PKGBUILD b/abs/extra/memtest86+/PKGBUILD
new file mode 100644
index 0000000..36e4d68
--- /dev/null
+++ b/abs/extra/memtest86+/PKGBUILD
@@ -0,0 +1,17 @@
+# $Id: PKGBUILD 149463 2012-02-08 05:56:40Z eric $
+# Maintainer: Eric BĂ©langer <eric@archlinux.org>
+
+pkgname=memtest86+
+pkgver=4.20
+pkgrel=2
+pkgdesc="An advanced memory diagnostic tool"
+arch=('any')
+url="http://www.memtest.org"
+license=('GPL2')
+install=memtest86+.install
+source=(http://www.memtest.org/download/${pkgver}/${pkgname}-${pkgver}.bin.gz)
+sha1sums=('5a91dc1c9e3457456f314e6c99f579210624fafc')
+
+package() {
+ install -D -m644 "${srcdir}/${pkgname}-${pkgver}.bin" "${pkgdir}/boot/memtest86+/memtest.bin"
+}
diff --git a/abs/extra/memtest86+/memtest86+.install b/abs/extra/memtest86+/memtest86+.install
new file mode 100644
index 0000000..40b5f20
--- /dev/null
+++ b/abs/extra/memtest86+/memtest86+.install
@@ -0,0 +1,23 @@
+post_install() {
+cat << EOF
+For using memtest86+, please modify your bootloaders.
+
+If /boot is on root partitions:
+==> GRUB: add this to /boot/grub/menu.lst
+title Memtest86+ [/boot/memtest86+/memtest.bin]
+kernel (hd?,?)/boot/memtest86+/memtest.bin
+
+==> Lilo: add this to lilo.conf
+image = /boot/memtest86+/memtest.bin
+label = "Memtest86+"
+
+If /boot is on a separate partition, then just use /memtest86+/memtest.bin
+without the /boot prefix.
+EOF
+}
+
+post_remove() {
+cat << EOF
+Please remove your additions from your bootloaders.
+EOF
+}