summaryrefslogtreecommitdiffstats
path: root/abs/extra/mono
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-08-07 20:35:00 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-08-07 20:35:00 (GMT)
commit979f24729c40b572184bcbee3c991ca8c90361b3 (patch)
treea566ab5570b67f8c92d48a80fd850873da40f671 /abs/extra/mono
parentf16cfd1ae9779de3fa7f36d0e10502c789f01f2f (diff)
downloadlinhes_pkgbuild-979f24729c40b572184bcbee3c991ca8c90361b3.zip
linhes_pkgbuild-979f24729c40b572184bcbee3c991ca8c90361b3.tar.gz
linhes_pkgbuild-979f24729c40b572184bcbee3c991ca8c90361b3.tar.bz2
mono 2.10.8
Diffstat (limited to 'abs/extra/mono')
-rw-r--r--abs/extra/mono/PKGBUILD19
-rw-r--r--abs/extra/mono/__changelog2
2 files changed, 14 insertions, 7 deletions
diff --git a/abs/extra/mono/PKGBUILD b/abs/extra/mono/PKGBUILD
index bd9bf3b..9a83fc9 100644
--- a/abs/extra/mono/PKGBUILD
+++ b/abs/extra/mono/PKGBUILD
@@ -1,22 +1,22 @@
-# $Id: PKGBUILD 95334 2010-10-18 17:54:25Z daniel $
+# $Id: PKGBUILD 145729 2011-12-29 13:13:45Z daniel $
# Maintainer: Daniel Isenmann <daniel@archlinux.org>
# Contributor: Brice Carpentier <brice@dlfp.org>
pkgname=mono
-pkgver=2.8
+pkgver=2.10.8
pkgrel=1
pkgdesc="Free implementation of the .NET platform including runtime and compiler"
arch=(i686 x86_64)
license=('GPL' 'LGPL2' 'MPL' 'custom:MITX11')
url="http://www.mono-project.com/"
-depends=('zlib' 'libgdiplus>=2.8' 'sh')
+depends=('zlib' 'libgdiplus>=2.10' 'sh')
makedepends=('pkgconfig')
options=('!libtool' '!makeflags')
provides=('monodoc')
conflicts=('monodoc')
-source=(http://ftp.novell.com/pub/mono/sources/${pkgname}/${pkgname}-${pkgver}.tar.bz2
+source=(http://download.mono-project.com/sources/${pkgname}/${pkgname}-${pkgver}.tar.gz
mono.rc.d)
-md5sums=('30b1180e20e5110d3fb36147137014a0'
+md5sums=('411a2d9bcfc37a61eb9aedba88b40533'
'8315e46c6a6e9625502521fc0ad1a322')
build() {
@@ -25,12 +25,21 @@ build() {
./configure --prefix=/usr --sysconfdir=/etc \
--with-libgdiplus=installed
make || return 1
+
+ # build jay
+ cd ${srcdir}/${pkgname}-${pkgver}/mcs/jay
+ make || return 1
}
package() {
cd ${srcdir}/${pkgname}-${pkgver}
make DESTDIR=${pkgdir} install || return 1
+ # install jay
+ cd ${srcdir}/${pkgname}-${pkgver}/mcs/jay
+ make DESTDIR=${pkgdir} prefix=/usr INSTALL=../../install-sh install
+ cd ${srcdir}/${pkgname}-${pkgver}
+
# install daemons and pathes
mkdir -p ${pkgdir}/etc/rc.d
install -m755 ${srcdir}/mono.rc.d ${pkgdir}/etc/rc.d/mono
diff --git a/abs/extra/mono/__changelog b/abs/extra/mono/__changelog
deleted file mode 100644
index 8ed76c2..0000000
--- a/abs/extra/mono/__changelog
+++ /dev/null
@@ -1,2 +0,0 @@
-add bison as a make depends
-update to 2.8