summaryrefslogtreecommitdiffstats
path: root/abs/extra/mpd
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2016-06-08 16:04:47 (GMT)
committerBritney Fransen <brfransen@gmail.com>2016-06-08 16:04:47 (GMT)
commit74807f5f416c4dd58b6c85b3df17b769413cced5 (patch)
tree164810816f332dfc2e2865bfcbc22808c6563820 /abs/extra/mpd
parent9aa0daac20448a178a9e5583e5fc81cc1e9ba4f1 (diff)
downloadlinhes_pkgbuild-74807f5f416c4dd58b6c85b3df17b769413cced5.zip
linhes_pkgbuild-74807f5f416c4dd58b6c85b3df17b769413cced5.tar.gz
linhes_pkgbuild-74807f5f416c4dd58b6c85b3df17b769413cced5.tar.bz2
mpd: update to 0.19.15. closes #1002
Diffstat (limited to 'abs/extra/mpd')
-rw-r--r--abs/extra/mpd/PKGBUILD18
1 files changed, 13 insertions, 5 deletions
diff --git a/abs/extra/mpd/PKGBUILD b/abs/extra/mpd/PKGBUILD
index bb73322..ce19a60 100644
--- a/abs/extra/mpd/PKGBUILD
+++ b/abs/extra/mpd/PKGBUILD
@@ -6,32 +6,40 @@
# Contributor: Ben <ben@benmazer.net>
pkgname=mpd
-pkgver=0.19.9
-pkgrel=3
+pkgver=0.19.15
+pkgrel=2
pkgdesc='Flexible, powerful, server-side application for playing music'
url='http://www.musicpd.org/'
license=('GPL')
arch=('i686' 'x86_64')
depends=('libao' 'ffmpeg' 'libmodplug' 'audiofile' 'libshout' 'libmad' 'curl' 'faad2'
'sqlite' 'libmms' 'wavpack' 'avahi' 'libid3tag' 'yajl' 'libmpdclient'
- 'icu' 'libupnp' 'libnfs')
+ 'icu' 'libupnp' 'libnfs' 'libsamplerate' 'libsoxr' 'smbclient' 'libcdio-paranoia')
makedepends=('boost' 'doxygen')
validpgpkeys=('0392335A78083894A4301C43236E8A58C6DB4512')
source=("http://www.musicpd.org/download/${pkgname}/${pkgver%.*}/${pkgname}-${pkgver}.tar.xz"{,.sig}
'tmpfiles.d'
'conf')
-sha1sums=('6683bee5f132eda318c5a61ec14b2df8d9164d60' 'SKIP'
+sha1sums=('5c32aff6ea3f031de5802a39a222efd7e4b1bafd' 'SKIP'
'f4d5922abb69abb739542d8e93f4dfd748acdad7'
'291fd5cda9f0845834a553017327c4586bd853f6')
backup=('etc/mpd.conf')
install=install
+prepare() {
+ # Temporary; see FS#48372
+ install -d "${srcdir}"/pkg-config
+ ln -s /usr/lib/pkgconfig/libsystemd.pc "${srcdir}"/pkg-config/libsystemd-daemon.pc
+}
+
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
+ export PKG_CONFIG_PATH="${srcdir}"/pkg-config
./configure \
--prefix=/usr \
--sysconfdir=/etc \
+ --enable-cdio-paranoia \
--enable-libmpdclient \
--disable-jack \
--enable-soundcloud \
@@ -47,7 +55,7 @@ package() {
make DESTDIR="${pkgdir}" install
install -Dm644 ../conf "${pkgdir}"/etc/mpd.conf
install -Dm644 ../tmpfiles.d "${pkgdir}"/usr/lib/tmpfiles.d/mpd.conf
- install -d -g 45 -o 45 "${pkgdir}"/var/lib/mpd/playlists
+ install -d -g 45 -o 45 "${pkgdir}"/var/lib/mpd{,/playlists}
install -Dm644 "${pkgdir}"/usr/lib/systemd/{system,user}/mpd.service
sed '/\[Service\]/a User=mpd' -i "${pkgdir}"/usr/lib/systemd/system/mpd.service