summaryrefslogtreecommitdiffstats
path: root/abs/extra/mpdecimal
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2018-02-13 20:14:03 (GMT)
committerBritney Fransen <brfransen@gmail.com>2018-02-13 20:14:03 (GMT)
commit2b5732b5f5b488089708e5f7694b73a252fad37a (patch)
tree80c9f09bc5e4cf2af8299d0501daec4578e2fec6 /abs/extra/mpdecimal
parent99386916bbaf4d29bc546ae0a24fed284f655a46 (diff)
downloadlinhes_pkgbuild-2b5732b5f5b488089708e5f7694b73a252fad37a.zip
linhes_pkgbuild-2b5732b5f5b488089708e5f7694b73a252fad37a.tar.gz
linhes_pkgbuild-2b5732b5f5b488089708e5f7694b73a252fad37a.tar.bz2
mpdecimal: 2.4.2
Diffstat (limited to 'abs/extra/mpdecimal')
-rw-r--r--abs/extra/mpdecimal/PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/abs/extra/mpdecimal/PKGBUILD b/abs/extra/mpdecimal/PKGBUILD
new file mode 100644
index 0000000..44fe617
--- /dev/null
+++ b/abs/extra/mpdecimal/PKGBUILD
@@ -0,0 +1,27 @@
+# $Id$
+# Maintainer: Felix Yan <felixonmars@archlinux.org>
+
+pkgname=mpdecimal
+pkgver=2.4.2
+pkgrel=1
+pkgdesc="Package for correctly-rounded arbitrary precision decimal floating point arithmetic"
+arch=('x86_64')
+url="http://www.bytereef.org/mpdecimal/index.html"
+license=('custom')
+depends=('glibc')
+source=("http://www.bytereef.org/software/$pkgname/releases/$pkgname-$pkgver.tar.gz")
+sha512sums=('eb18ad53b81b93c469db4d915bbb3fae21b36ad82a88e01fef3a6946ac5f50b54376e259a5ecbe23836f1efd59d226b942ecdee87eaba7f9e75cdcaaa9499ef7')
+
+build() {
+ cd $pkgname-$pkgver
+
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd $pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
+
+ install -Dm644 LICENSE.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE.txt
+}