summaryrefslogtreecommitdiffstats
path: root/abs/extra/mupen64plus
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-11-26 15:37:03 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-11-26 15:37:03 (GMT)
commit86db73e152eda2dbf6e6fe77fbe9c2cf2c38a099 (patch)
tree9f6d9ff4e5b4bce63bf992427e95d894eb330fcc /abs/extra/mupen64plus
parent8f4b980d44029e8077490fc259facafb45473ea6 (diff)
downloadlinhes_pkgbuild-86db73e152eda2dbf6e6fe77fbe9c2cf2c38a099.zip
linhes_pkgbuild-86db73e152eda2dbf6e6fe77fbe9c2cf2c38a099.tar.gz
linhes_pkgbuild-86db73e152eda2dbf6e6fe77fbe9c2cf2c38a099.tar.bz2
mupen64plus: new package, intended to replace the svn version
Diffstat (limited to 'abs/extra/mupen64plus')
-rw-r--r--abs/extra/mupen64plus/PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/abs/extra/mupen64plus/PKGBUILD b/abs/extra/mupen64plus/PKGBUILD
new file mode 100644
index 0000000..c7835c0
--- /dev/null
+++ b/abs/extra/mupen64plus/PKGBUILD
@@ -0,0 +1,33 @@
+# $Id: PKGBUILD 78487 2012-10-19 16:17:59Z jelle $
+# Maintainer: Sven-Hendrik Haase <sh@lutzhaase.com>
+# Contributor: Thomas Dziedzic < gostrc at gmail >
+# Contributor: Laurent Carlier <lordheavym@gmail.com>
+# Contributor: Allan McRae <allan@archlinux.org>
+# Contributor: Zephyr
+
+pkgname=mupen64plus
+pkgver=1.99.5
+pkgrel=3
+pkgdesc='Nintendo64 Emulator'
+arch=('i686' 'x86_64')
+url='http://code.google.com/p/mupen64plus/'
+license=('GPL')
+depends=('glu' 'libgl' 'libsamplerate' 'libpng' 'sdl' 'freetype2')
+makedepends=('mesa')
+source=("http://mupen64plus.googlecode.com/files/mupen64plus-bundle-src-${pkgver}.tar.gz")
+md5sums=('93772a6d6fc6a63353462deae8a6db71')
+
+build() {
+ cd mupen64plus-bundle-src-${pkgver}
+
+ sh m64p_build.sh
+}
+
+package() {
+ cd mupen64plus-bundle-src-$pkgver
+
+ # set LDCONFIG since we are using fakeroot and scripts run root commands by checking the uid
+ ./m64p_install.sh DESTDIR="$pkgdir" PREFIX='/usr' MANDIR='/usr/share/man/man6' LDCONFIG='true'
+}
+
+# vim: ts=2:sw=2:et