summaryrefslogtreecommitdiffstats
path: root/abs/extra/mupen64plus
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2014-12-19 17:26:55 (GMT)
committerBritney Fransen <brfransen@gmail.com>2014-12-19 17:26:55 (GMT)
commitbbc308c7b5c3a2328898b7c484217d6d0df50309 (patch)
tree479436742778336a75feacf202564350f80781db /abs/extra/mupen64plus
parent889ea4b744b2df176c4c03dfc660cb7511f95124 (diff)
downloadlinhes_pkgbuild-bbc308c7b5c3a2328898b7c484217d6d0df50309.zip
linhes_pkgbuild-bbc308c7b5c3a2328898b7c484217d6d0df50309.tar.gz
linhes_pkgbuild-bbc308c7b5c3a2328898b7c484217d6d0df50309.tar.bz2
mupen64plus: update to 2.0
Diffstat (limited to 'abs/extra/mupen64plus')
-rw-r--r--abs/extra/mupen64plus/PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/abs/extra/mupen64plus/PKGBUILD b/abs/extra/mupen64plus/PKGBUILD
new file mode 100644
index 0000000..2ab8b1f
--- /dev/null
+++ b/abs/extra/mupen64plus/PKGBUILD
@@ -0,0 +1,33 @@
+# $Id$
+# Maintainer: Sven-Hendrik Haase <sh@lutzhaase.com>
+# Contributor: Thomas Dziedzic < gostrc at gmail >
+# Contributor: Laurent Carlier <lordheavym@gmail.com>
+# Contributor: Allan McRae <allan@archlinux.org>
+# Contributor: Zephyr
+
+pkgname=mupen64plus
+pkgver=2.0
+pkgrel=4
+pkgdesc='Nintendo64 Emulator'
+arch=('i686' 'x86_64')
+url='http://code.google.com/p/mupen64plus/'
+license=('GPL')
+depends=('glu' 'libsamplerate' 'libpng' 'sdl' 'freetype2' 'boost-libs')
+makedepends=('mesa' 'boost')
+source=("http://mupen64plus.googlecode.com/files/mupen64plus-bundle-src-${pkgver}.tar.gz")
+md5sums=('f855b4233faa9616b780c364fc4a9a9a')
+
+build() {
+ cd mupen64plus-bundle-src-${pkgver}
+
+ sh m64p_build.sh
+}
+
+package() {
+ cd mupen64plus-bundle-src-$pkgver
+
+ # set LDCONFIG since we are using fakeroot and scripts run root commands by checking the uid
+ ./m64p_install.sh DESTDIR="$pkgdir" PREFIX='/usr' MANDIR='/usr/share/man' LDCONFIG='true'
+}
+
+# vim: ts=2:sw=2:et