summaryrefslogtreecommitdiffstats
path: root/abs/extra/mythexport/PKGBUILD
diff options
context:
space:
mode:
authorMichael Hanson <hansonorders@verizon.net>2011-08-03 22:49:59 (GMT)
committerMichael Hanson <hansonorders@verizon.net>2011-08-03 22:49:59 (GMT)
commit7d8a4f93e15f61418ea89666b57063111700dc7e (patch)
tree55fe8306be37492af59453f3e26bc142a416ebf1 /abs/extra/mythexport/PKGBUILD
parentedb5eaa42980f66e1c660d570d645d661c9072a4 (diff)
downloadlinhes_pkgbuild-7d8a4f93e15f61418ea89666b57063111700dc7e.zip
linhes_pkgbuild-7d8a4f93e15f61418ea89666b57063111700dc7e.tar.gz
linhes_pkgbuild-7d8a4f93e15f61418ea89666b57063111700dc7e.tar.bz2
mythexport: Upgrade to 2.2.3 -- needs testing
Diffstat (limited to 'abs/extra/mythexport/PKGBUILD')
-rw-r--r--abs/extra/mythexport/PKGBUILD38
1 files changed, 31 insertions, 7 deletions
diff --git a/abs/extra/mythexport/PKGBUILD b/abs/extra/mythexport/PKGBUILD
index 3cd04f3..6fd3000 100644
--- a/abs/extra/mythexport/PKGBUILD
+++ b/abs/extra/mythexport/PKGBUILD
@@ -2,16 +2,40 @@
# Maintainer: Cecil Watson<knoppmyth@gmail.com>
pkgname=mythexport
-pkgver=2.0.71
-pkgrel=5
-pkgdesc="Script to export recordings for portable devices."
+pkgver=2.2.3
+pkgrel=1
+pkgdesc="Export MythTV recording to portable media players"
arch=('i686' 'x86_64')
license=('GPL3')
-depends=('atomicparsley' 'perl-config-simple' 'perl-net-upnp' 'perl-proc-daemon' 'perl-proc-pid-file')
-url="http://linhes.org/"
-source=(ftp://ftp.knoppmyth.net/R6/sources/mythexport.tar.bz2)
+depends=('atomicparsley' 'perl-config-simple' 'perl-net-upnp'
+ 'perl-proc-daemon' 'perl-proc-pid-file')
+optdepends=('lighttpd: For web based interaction')
+url="http://www.ubuntuupdates.org/mythexport"
+source=(https://launchpad.net/ubuntu/natty/+source/${pkgname}/${pkgver}-0ubuntu1/+files/${pkgname}_${pkgver}.orig.tar.gz
+ mythexport.lighttpd.include)
install=mythexport.install
build() {
- cp -a mythexport/* $startdir/pkg
+
+ /bin/true
+
+}
+
+package() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ cp -a ./usr ${pkgdir}/ || return 1
+
+ # Install lighttpd include file
+ install -D -m644 ${srcdir}/mythexport.lighttpd.include ${pkgdir}/etc/mythexport/mythexport.lighttpd.include
+
+ # Compress man pages
+ gzip -9 *.1
+ install -D -m644 mythexport.1.gz ${pkgdir}/usr/share/man/man1/mythexport.1.gz || return 1
+ install -D -m644 mythimport.1.gz ${pkgdir}/usr/share/man/man1/mythimport.1.gz || return 1
+
+ # Standard GPL3 license text already in distro
+ rm -f ${pkgdir}/COPYING
+
}
+md5sums=('a780c00536a4680ce7d79057658971c8'
+ 'b08404255abcc99a35e9c1ab8e0dec57')