summaryrefslogtreecommitdiffstats
path: root/abs/extra/mythexport
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2011-08-03 23:33:45 (GMT)
committerJames Meyer <james.meyer@operamail.com>2011-08-03 23:33:45 (GMT)
commit5003a9ce7a704794e298153fbaafccbfe534919f (patch)
tree65ae295b7bf5e9ec25f451fb16f4f7f9d781ca1c /abs/extra/mythexport
parent02797173a65f18a0309e12699c7020eb015704cb (diff)
parent2ba0826ab4c85aa4caf1613cfdb77123935a16b4 (diff)
downloadlinhes_pkgbuild-5003a9ce7a704794e298153fbaafccbfe534919f.zip
linhes_pkgbuild-5003a9ce7a704794e298153fbaafccbfe534919f.tar.gz
linhes_pkgbuild-5003a9ce7a704794e298153fbaafccbfe534919f.tar.bz2
Merge branch 'testing' of ssh://jams@linhes.org/mount/repository/linhes_pkgbuild into testing
Diffstat (limited to 'abs/extra/mythexport')
-rw-r--r--abs/extra/mythexport/PKGBUILD38
-rw-r--r--abs/extra/mythexport/mythexport.install65
-rw-r--r--abs/extra/mythexport/mythexport.lighttpd.include3
3 files changed, 99 insertions, 7 deletions
diff --git a/abs/extra/mythexport/PKGBUILD b/abs/extra/mythexport/PKGBUILD
index 3cd04f3..6fd3000 100644
--- a/abs/extra/mythexport/PKGBUILD
+++ b/abs/extra/mythexport/PKGBUILD
@@ -2,16 +2,40 @@
# Maintainer: Cecil Watson<knoppmyth@gmail.com>
pkgname=mythexport
-pkgver=2.0.71
-pkgrel=5
-pkgdesc="Script to export recordings for portable devices."
+pkgver=2.2.3
+pkgrel=1
+pkgdesc="Export MythTV recording to portable media players"
arch=('i686' 'x86_64')
license=('GPL3')
-depends=('atomicparsley' 'perl-config-simple' 'perl-net-upnp' 'perl-proc-daemon' 'perl-proc-pid-file')
-url="http://linhes.org/"
-source=(ftp://ftp.knoppmyth.net/R6/sources/mythexport.tar.bz2)
+depends=('atomicparsley' 'perl-config-simple' 'perl-net-upnp'
+ 'perl-proc-daemon' 'perl-proc-pid-file')
+optdepends=('lighttpd: For web based interaction')
+url="http://www.ubuntuupdates.org/mythexport"
+source=(https://launchpad.net/ubuntu/natty/+source/${pkgname}/${pkgver}-0ubuntu1/+files/${pkgname}_${pkgver}.orig.tar.gz
+ mythexport.lighttpd.include)
install=mythexport.install
build() {
- cp -a mythexport/* $startdir/pkg
+
+ /bin/true
+
+}
+
+package() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ cp -a ./usr ${pkgdir}/ || return 1
+
+ # Install lighttpd include file
+ install -D -m644 ${srcdir}/mythexport.lighttpd.include ${pkgdir}/etc/mythexport/mythexport.lighttpd.include
+
+ # Compress man pages
+ gzip -9 *.1
+ install -D -m644 mythexport.1.gz ${pkgdir}/usr/share/man/man1/mythexport.1.gz || return 1
+ install -D -m644 mythimport.1.gz ${pkgdir}/usr/share/man/man1/mythimport.1.gz || return 1
+
+ # Standard GPL3 license text already in distro
+ rm -f ${pkgdir}/COPYING
+
}
+md5sums=('a780c00536a4680ce7d79057658971c8'
+ 'b08404255abcc99a35e9c1ab8e0dec57')
diff --git a/abs/extra/mythexport/mythexport.install b/abs/extra/mythexport/mythexport.install
index edd60f5..a6a2085 100644
--- a/abs/extra/mythexport/mythexport.install
+++ b/abs/extra/mythexport/mythexport.install
@@ -3,8 +3,73 @@ post_install() {
mysql -u root mythconverg < /usr/share/mythtv/mythexport.sql
ln -s /usr/share/mythtv/mythexport /data/srv/httpd/htdocs/
ln -s /myth/archive /usr/share/mythtv/mythexport/video
+
+ COUNT=`grep -c "include \"/etc/mythexport/mythexport.lighttpd.include\"" /etc/lighttpd/conf.include`
+
+ if [ $COUNT == 0 ] ; then
+ echo "==> Adding mythexport.lighttpd.include to conf.include"
+ echo "include \"/etc/mythexport/mythexport.lighttpd.include\"" >> \
+ /etc/lighttpd/conf.include
+ fi
+
+ echo ""
+ echo "==> Forcing a re-read of lighttpd's configuration file."
+ echo ""
+ /sbin/sv hup /service/lighttpd
+
+ echo ""
+ echo "==> Add the mythexport service to start the mythexport daemon"
+ echo "==> $ sudo add_service.sh mythexport"
+ echo ""
+
+ echo ""
+ echo "==> For move information on setup and configuration:"
+ echo "==> http://www.linhes.org/bugs/projects/linhes/wiki/HOWTO_Setup_MythExport_for_iPod"
+ echo ""
+
+}
+
+post_upgrade() {
+
+ COUNT=`grep -c "include \"/etc/mythexport/mythexport.lighttpd.include\"" /etc/lighttpd/conf.include`
+
+ if [ $COUNT == 0 ] ; then
+ echo "==> Adding mythexport.lighttpd.include to conf.include"
+ echo "include \"/etc/mythexport/mythexport.lighttpd.include\"" >> \
+ /etc/lighttpd/conf.include
+ fi
+
+ echo ""
+ echo "==> Forcing a re-read of lighttpd's configuration file."
+ echo ""
+ /sbin/sv hup /service/lighttpd
+
}
+pre_remove() {
+
+ remove_service.sh mythexport
+
+}
+
+post_remove() {
+
+ COUNT=`grep -c "include \"/etc/mythexport/mythexport.lighttpd.include\"" /etc/lighttpd/conf.include`
+
+ if [ $COUNT -gt 0 ] ; then
+ echo "==> Removing mythexport.lighttpd.include from conf.include"
+ sed -e 's#include \"/etc/mythexport/mythexport.lighttpd.include\"##' -i \
+ /etc/lighttpd/conf.include
+ fi
+
+ echo ""
+ echo "==> Forcing re-read of lighttpd's configuration file."
+ echo ""
+ /sbin/sv hup /service/lighttpd
+}
+
+
+
op=$1
shift
$op $*
diff --git a/abs/extra/mythexport/mythexport.lighttpd.include b/abs/extra/mythexport/mythexport.lighttpd.include
new file mode 100644
index 0000000..b846507
--- /dev/null
+++ b/abs/extra/mythexport/mythexport.lighttpd.include
@@ -0,0 +1,3 @@
+$HTTP["url"] =~ "/mythexport/" {
+ cgi.assign = ( ".cgi" => "/usr/bin/perl" )
+ }