summaryrefslogtreecommitdiffstats
path: root/abs/extra/mythnuv2mkv
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2010-08-30 22:26:00 (GMT)
committerJames Meyer <james.meyer@operamail.com>2010-08-30 22:26:00 (GMT)
commit1f175a7b07b9553ce98d0546ac04dbb925ec0bc9 (patch)
treec969070115611a8a75f23d468aa5e0cf86a08121 /abs/extra/mythnuv2mkv
parentc4bd4457b5d640e1c8f5afbca7cd54c53691e5fc (diff)
downloadlinhes_pkgbuild-1f175a7b07b9553ce98d0546ac04dbb925ec0bc9.zip
linhes_pkgbuild-1f175a7b07b9553ce98d0546ac04dbb925ec0bc9.tar.gz
linhes_pkgbuild-1f175a7b07b9553ce98d0546ac04dbb925ec0bc9.tar.bz2
RESYNC EXTRA:
synced extra-testing -> extra repo Signed-off-by: James Meyer <james.meyer@operamail.com>
Diffstat (limited to 'abs/extra/mythnuv2mkv')
-rw-r--r--abs/extra/mythnuv2mkv/PKGBUILD6
-rw-r--r--abs/extra/mythnuv2mkv/mythnuv2mkv.patch36
2 files changed, 39 insertions, 3 deletions
diff --git a/abs/extra/mythnuv2mkv/PKGBUILD b/abs/extra/mythnuv2mkv/PKGBUILD
index 9a61d9a..5df33a7 100644
--- a/abs/extra/mythnuv2mkv/PKGBUILD
+++ b/abs/extra/mythnuv2mkv/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=mythnuv2mkv
-pkgver=1.53
+pkgver=1.60
pkgrel=1
conflicts=()
pkgdesc="Converts MythTV nuv or mpg files to mkv, mp4 or avi files. It can be run as a MythTV User Job or at command line to convert MythTV recordings or stand alone files."
@@ -8,9 +8,9 @@ arch=('i686')
license=('GPL')
source=(http://web.aanet.com.au/~auric/files2/V${pkgver}/mythnuv2mkv.sh)
-install=''
build() {
+ patch -p0 <$startdir/mythnuv2mkv.patch || return 1
mkdir -p $startdir/pkg/usr/bin
install -m 0755 mythnuv2mkv.sh $startdir/pkg/usr/bin/mythnuv2mkv.sh
}
-
+md5sums=('19a5c8bed9bd7d6a86d35e96afa4b3bb')
diff --git a/abs/extra/mythnuv2mkv/mythnuv2mkv.patch b/abs/extra/mythnuv2mkv/mythnuv2mkv.patch
new file mode 100644
index 0000000..5ca20ae
--- /dev/null
+++ b/abs/extra/mythnuv2mkv/mythnuv2mkv.patch
@@ -0,0 +1,36 @@
+--- mythnuv2mkv.sh.orig 2010-04-21 01:41:11.000000000 +0000
++++ mythnuv2mkv.sh 2010-04-21 01:43:04.000000000 +0000
+@@ -7,19 +7,19 @@
+ #
+ ######### Vars you may want to set for your environment ######################################################
+ # Default aspect for Myth Recording mpg files. It will try to work it out but if it can't will use this.
+-readonly DEFAULTMPEG2ASPECT="NA" # 4:3 or 16:9
++readonly DEFAULTMPEG2ASPECT="16:9" # 4:3 or 16:9
+ # Log directory
+-readonly LOGBASEDIR="/var/tmp" # Don't use a directory with spaces in it's name
++readonly LOGBASEDIR="/tmp" # Don't use a directory with spaces in it's name
+ # Number of errors reported by mplayer allowed in the transcoded file
+ readonly MPLAYER_ERROR_COUNT="8"
+ # Path to your mysql.txt file
+ readonly MYSQLTXT=""
+ # What to separate Title SeasonEpisode SubTitle with
+-readonly SEP=","
++readonly SEP="_"
+ # Chapter marks every X minutes
+-CHAPTERDURATION=0
++CHAPTERDURATION=5
+ # Crop input
+-CROP="ON" # ON | OFF, can also change with --crop argument
++CROP="OFF" # ON | OFF, can also change with --crop argument
+ CROPSIZE=8
+ # Delete recording after successful transcode. Only for transcode out of MythRecording. (Actually just sets to high priority autoexpire.)
+ DELETEREC="OFF" # ON | OFF, can also change with --deleterec argument
+@@ -29,7 +29,7 @@
+ DEBLOCK="OFF" # ON | OFF, can also change with --deblock argument
+ # Include deinterlace filter.
+ # SOURCENAME is ON for that source. Can have multiple. e.g. DEINTERLACE="Cabel,FTA1"
+-DEINTERLACE="ON" # ON | OFF | SOURCENAME,SOURCENAME can also change with --deinterlace argument.
++DEINTERLACE="OFF" # ON | OFF | SOURCENAME,SOURCENAME can also change with --deinterlace argument.
+ # Include inverse Telecine filter (Experimental. Can someone from NTSC/ATSC land try this?).
+ # invtelecine filter is never added if deinterlace has been added.
+ INVTELECINE="OFF" # ON | OFF, can also change with --invtelecine argument.