summaryrefslogtreecommitdiffstats
path: root/abs/extra/net-snmp
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2014-08-16 17:52:03 (GMT)
committerJames Meyer <james.meyer@operamail.com>2014-08-16 17:59:20 (GMT)
commit1a7155936ea17b6f1b1ffd31aaed8a34371a0e9f (patch)
tree31a06edaf6243f3cfaf88b66227493103e5b4077 /abs/extra/net-snmp
parent98884293d83a99ca10e7d745f8fb73714b3bd8fc (diff)
downloadlinhes_pkgbuild-1a7155936ea17b6f1b1ffd31aaed8a34371a0e9f.zip
linhes_pkgbuild-1a7155936ea17b6f1b1ffd31aaed8a34371a0e9f.tar.gz
linhes_pkgbuild-1a7155936ea17b6f1b1ffd31aaed8a34371a0e9f.tar.bz2
net-snmp 5.7.2
refs #961
Diffstat (limited to 'abs/extra/net-snmp')
-rw-r--r--abs/extra/net-snmp/PKGBUILD46
-rw-r--r--abs/extra/net-snmp/snmpd.confd5
-rw-r--r--abs/extra/net-snmp/snmpd.rc39
-rw-r--r--abs/extra/net-snmp/snmpd.service12
-rw-r--r--abs/extra/net-snmp/snmptrapd.service12
5 files changed, 47 insertions, 67 deletions
diff --git a/abs/extra/net-snmp/PKGBUILD b/abs/extra/net-snmp/PKGBUILD
index d70068f..4e003ed 100644
--- a/abs/extra/net-snmp/PKGBUILD
+++ b/abs/extra/net-snmp/PKGBUILD
@@ -1,40 +1,39 @@
-# $Id: PKGBUILD 160499 2012-06-02 10:26:47Z bluewind $
-# Maintainer:
+# $Id: PKGBUILD 198340 2013-10-30 14:16:21Z allan $
+# Maintainer:
# Contributor: Dale Blount <dale@archlinux.org>
pkgname=net-snmp
-pkgver=5.7.1
-pkgrel=3
+pkgver=5.7.2
+pkgrel=8
pkgdesc="A suite of applications used to implement SNMP v1, SNMP v2c and SNMP v3 using both IPv4 and IPv6"
arch=('i686' 'x86_64')
url="http://www.net-snmp.org/"
license=('BSD')
depends=('openssl' 'libnl' 'pciutils')
-makedepends=('python2-distribute')
-optdepends=('perl-term-readkey: for snmpcheck application'
+makedepends=('python2-setuptools')
+optdepends=('perl-term-readkey: for snmpcheck application'
'perl-tk: for snmpcheck and tkmib applications'
'python2: for the python modules')
-provides=('ucd-snmp')
-backup=('etc/conf.d/snmpd')
-options=('!libtool' '!makeflags' '!emptydirs')
+options=('!emptydirs' '!makeflags')
source=(http://downloads.sourceforge.net/${pkgname}/${pkgname}-${pkgver}.tar.gz{,.asc}
- snmpd.confd snmpd.rc libnl32.patch)
-sha1sums=('ddb82ce1112ef0642869d3c8d7c7e585f151849a'
- '2bdc2839ce09d7daa608cd54687fa8beb47ed907'
- 'cf811da9e57bbca34d8e2a3c358bb3bfc0c2b33b'
- '90600c0141eed10d6e3ca3ccc97ad8dda15c2112'
+ snmpd.service snmptrapd.service libnl32.patch)
+sha1sums=('c493027907f32400648244d81117a126aecd27ee'
+ 'SKIP'
+ '84e32c54d32e6b608747054e04a3ddfe6d6638cc'
+ '0244e91c7baa0abebfb5c0560e8ce04c966c5992'
'74a9848b95f63378eb1753fc309d2b74de5afb0f')
-build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
-
- # http://sourceforge.net/tracker/index.php?func=detail&aid=3250304&group_id=12694&atid=112694
+prepare() {
+ cd ${pkgname}-${pkgver}
+# http://sourceforge.net/tracker/index.php?func=detail&aid=3250304&group_id=12694&atid=112694
patch -Np1 -i "$srcdir/libnl32.patch"
autoreconf -f -i
+}
- sed -i -e "s:\(install --basedir=\$\$dir\):\1 --root='${pkgdir}':" Makefile.in
+build() {
+ cd ${pkgname}-${pkgver}
PYTHONPROG=/usr/bin/python2 ./configure --prefix=/usr \
- --sysconfdir=/etc \
+ --sysconfdir=/etc --sbindir=/usr/bin \
--mandir=/usr/share/man \
--enable-ucd-snmp-compatibility \
--enable-ipv6 \
@@ -50,9 +49,10 @@ build() {
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd ${pkgname}-${pkgver}
+ sed -i -e "s:install --basedir=\$\$dir:install --basedir=\$\$dir --root=${pkgdir}:" Makefile
make DESTDIR="${pkgdir}" INSTALL_PREFIX="${pkgdir}" INSTALLDIRS=vendor install
- install -D -m755 "${srcdir}/snmpd.rc" "${pkgdir}/etc/rc.d/snmpd"
- install -D -m644 "${srcdir}/snmpd.confd" "${pkgdir}/etc/conf.d/snmpd"
+ install -D -m644 "${srcdir}/snmpd.service" "${pkgdir}/usr/lib/systemd/system/snmpd.service"
+ install -D -m644 "${srcdir}/snmptrapd.service" "${pkgdir}/usr/lib/systemd/system/snmptrapd.service"
install -D -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
diff --git a/abs/extra/net-snmp/snmpd.confd b/abs/extra/net-snmp/snmpd.confd
deleted file mode 100644
index 926b09b..0000000
--- a/abs/extra/net-snmp/snmpd.confd
+++ /dev/null
@@ -1,5 +0,0 @@
-#
-# Parameters to be passed to snmpd
-#
-SNMPD_ARGS=""
-
diff --git a/abs/extra/net-snmp/snmpd.rc b/abs/extra/net-snmp/snmpd.rc
deleted file mode 100644
index b00c09f..0000000
--- a/abs/extra/net-snmp/snmpd.rc
+++ /dev/null
@@ -1,39 +0,0 @@
-#!/bin/bash
-
-. /etc/rc.conf
-. /etc/rc.d/functions
-. /etc/conf.d/snmpd
-
-PID=`pidof -o %PPID /usr/sbin/snmpd`
-case "$1" in
- start)
- stat_busy "Starting Net-SNMP"
- [ -z "$PID" ] && /usr/sbin/snmpd $SNMPD_ARGS
- if [ $? -gt 0 ]; then
- stat_fail
- else
- echo $PID > /var/run/snmpd.pid
- add_daemon snmpd
- stat_done
- fi
- ;;
- stop)
- stat_busy "Stopping Net-SNMP"
- [ ! -z "$PID" ] && kill $PID &> /dev/null
- if [ $? -gt 0 ]; then
- stat_fail
- else
- rm /var/run/snmpd.pid
- rm_daemon snmpd
- stat_done
- fi
- ;;
- restart)
- $0 stop
- sleep 2
- $0 start
- ;;
- *)
- echo "usage: $0 {start|stop|restart}"
-esac
-exit 0
diff --git a/abs/extra/net-snmp/snmpd.service b/abs/extra/net-snmp/snmpd.service
new file mode 100644
index 0000000..e9f713c
--- /dev/null
+++ b/abs/extra/net-snmp/snmpd.service
@@ -0,0 +1,12 @@
+[Unit]
+Description=Simple Network Management Protocol (SNMP) Daemon
+After=syslog.target network.target
+
+[Service]
+Type=forking
+PIDFile=/run/snmpd.pid
+ExecStart=/usr/bin/snmpd -p /run/snmpd.pid
+ExecReload=/bin/kill -HUP $MAINPID
+
+[Install]
+WantedBy=multi-user.target
diff --git a/abs/extra/net-snmp/snmptrapd.service b/abs/extra/net-snmp/snmptrapd.service
new file mode 100644
index 0000000..50eee7a
--- /dev/null
+++ b/abs/extra/net-snmp/snmptrapd.service
@@ -0,0 +1,12 @@
+[Unit]
+Description=Simple Network Management Protocol (SNMP) TRAP Daemon
+After=syslog.target network.target
+
+[Service]
+Type=forking
+PIDFile=/run/snmptrapd.pid
+ExecStart=/usr/bin/snmptrapd -p /run/snmptrapd.pid
+ExecReload=/bin/kill -HUP $MAINPID
+
+[Install]
+WantedBy=multi-user.target