summaryrefslogtreecommitdiffstats
path: root/abs/extra/nss
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-08-22 00:12:06 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-08-22 00:12:06 (GMT)
commit32d3a049ce06d371ccf4c8b95c9be1f87fe4d413 (patch)
tree8fd66b2dabd0c6a8d343746d73c401e82a2aa4d6 /abs/extra/nss
parente87ea98c721ac7e41fc90351f67e0d07f6d44335 (diff)
downloadlinhes_pkgbuild-32d3a049ce06d371ccf4c8b95c9be1f87fe4d413.zip
linhes_pkgbuild-32d3a049ce06d371ccf4c8b95c9be1f87fe4d413.tar.gz
linhes_pkgbuild-32d3a049ce06d371ccf4c8b95c9be1f87fe4d413.tar.bz2
nss: 3.13.5
Diffstat (limited to 'abs/extra/nss')
-rw-r--r--abs/extra/nss/PKGBUILD48
-rw-r--r--abs/extra/nss/add_spi+cacert_ca_certs.patch19
2 files changed, 41 insertions, 26 deletions
diff --git a/abs/extra/nss/PKGBUILD b/abs/extra/nss/PKGBUILD
index 998cd1c..77bc6ef 100644
--- a/abs/extra/nss/PKGBUILD
+++ b/abs/extra/nss/PKGBUILD
@@ -1,58 +1,66 @@
-# $Id: PKGBUILD 91903 2010-09-28 12:13:33Z jgc $
+# $Id: PKGBUILD 162023 2012-06-18 22:10:13Z ibiru $
# Maintainer: Jan de Groot <jgc@archlinux.org>
+
pkgname=nss
-pkgver=3.12.8
+pkgver=3.13.5
pkgrel=1
pkgdesc="Mozilla Network Security Services"
arch=(i686 x86_64)
url="http://www.mozilla.org/projects/security/pki/nss/"
license=('MPL' 'GPL')
-_nsprver=4.8.6
-depends=("nspr>=${_nsprver}" 'sqlite3>=3.6.17' 'zlib')
+_nsprver=4.9.1
+depends=("nspr>=${_nsprver}" 'sqlite' 'zlib' 'sh')
makedepends=('perl')
-replaces=('nss-nspr')
+options=('!strip')
source=(ftp://ftp.mozilla.org/pub/security/nss/releases/NSS_${pkgver//./_}_RTM/src/${pkgname}-${pkgver}.tar.gz
nss-no-rpath.patch
nss.pc.in
nss-config.in
add_spi+cacert_ca_certs.patch
ssl-renegotiate-transitional.patch)
-options=('!strip')
-md5sums=('40bf1bb0c7567827d3768d1fc6081100'
- 'e5c97db0c884d5f4cfda21e562dc9bba'
- 'c547b030c57fe1ed8b77c73bf52b3ded'
- '46bee81908f1e5b26d6a7a2e14c64d9f'
- '7f39c19b1dfd62d7db7d8bf19f156fed'
- 'd83c7b61abb7e9f8f7bcd157183d1ade')
+sha1sums=('22cfe2cbccc93189699e6eed283eca288b45f6cb'
+ 'c8fcdb153af9d39689243119adb475905a657284'
+ 'aa5b2c0aa38d3c1066d511336cf28d1333e3aebd'
+ 'cb744cc3e56b604e4754bc3c7d9f25bb9a0a136c'
+ '3d89f29e321d7df7269b7ae6d219654543feaa6a'
+ '8a964a744ba098711b80c0d279a2993524e8eb92')
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- # Adds the SPI Inc. and CAcert.org CA certificates - patch from Debian
- patch -Np1 -i "${srcdir}/add_spi+cacert_ca_certs.patch"
+ cd "${srcdir}/${pkgname}-${pkgver}/mozilla"
+ # Adds the SPI Inc. and CAcert.org CA certificates - patch from Debian, modified to apply on certdata.txt only
+ patch -Np2 -i "${srcdir}/add_spi+cacert_ca_certs.patch"
# Adds transitional SSL renegotiate support - patch from Debian
- patch -Np1 -i "${srcdir}/ssl-renegotiate-transitional.patch"
+ patch -Np2 -i "${srcdir}/ssl-renegotiate-transitional.patch"
# Removes rpath
- patch -Np0 -i "${srcdir}/nss-no-rpath.patch"
+ patch -Np2 -i "${srcdir}/nss-no-rpath.patch"
- cd mozilla/security/nss/lib/ckfw/builtins
+ # Respect LDFLAGS
+ sed -e 's/\$(MKSHLIB) -o/\$(MKSHLIB) \$(LDFLAGS) -o/g' \
+ -i security/coreconf/rules.mk
+
+ # Generate certdata.c from certdata.txt
+ cd security/nss/lib/ckfw/builtins
make generate
cd "${srcdir}/${pkgname}-${pkgver}"
- unset CFLAGS
- unset CXXFLAGS
export BUILD_OPT=1
export PKG_CONFIG_ALLOW_SYSTEM_LIBS=1
export PKG_CONFIG_ALLOW_SYSTEM_CFLAGS=1
export NSS_USE_SYSTEM_SQLITE=1
+ export NSS_ENABLE_ECC=1
export NSPR_INCLUDE_DIR=`pkg-config --cflags-only-I nspr | sed 's/-I//'`
export NSPR_LIB_DIR=`pkg-config --libs-only-L nspr | sed 's/-L.//'`
+ export XCFLAGS="${CFLAGS}"
[ "$CARCH" = "x86_64" ] && export USE_64=1
make -j 1 -C mozilla/security/coreconf
make -j 1 -C mozilla/security/dbm
make -j 1 -C mozilla/security/nss
+}
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
install -m755 -d "${pkgdir}/usr/lib/pkgconfig"
install -m755 -d "${pkgdir}/usr/bin"
install -m755 -d "${pkgdir}/usr/include/nss"
diff --git a/abs/extra/nss/add_spi+cacert_ca_certs.patch b/abs/extra/nss/add_spi+cacert_ca_certs.patch
index 1cc7c18..bf7e2ca 100644
--- a/abs/extra/nss/add_spi+cacert_ca_certs.patch
+++ b/abs/extra/nss/add_spi+cacert_ca_certs.patch
@@ -1,10 +1,17 @@
---- a/mozilla/security/nss/lib/ckfw/builtins/certdata.txt
-+++ b/mozilla/security/nss/lib/ckfw/builtins/certdata.txt
-@@ -20926,3 +20926,558 @@ CKA_TRUST_SERVER_AUTH CK_TRUST CKT_NETSCAPE_TRUSTED_DELEGATOR
- CKA_TRUST_EMAIL_PROTECTION CK_TRUST CKT_NETSCAPE_TRUSTED_DELEGATOR
- CKA_TRUST_CODE_SIGNING CK_TRUST CKT_NETSCAPE_TRUSTED_DELEGATOR
+## 95_add_spi+cacert_ca_certs.patch by martin f. krafft <madduck@debian.org>
+##
+## All lines beginning with `## DP:' are a description of the patch.
+## DP: Adds the SPI Inc. and CAcert.org CA certificates
+
+Index: nss/mozilla/security/nss/lib/ckfw/builtins/certdata.txt
+===================================================================
+--- nss.orig/mozilla/security/nss/lib/ckfw/builtins/certdata.txt 2012-02-24 09:32:14.000000000 +0100
++++ nss/mozilla/security/nss/lib/ckfw/builtins/certdata.txt 2012-02-24 09:35:07.577861466 +0100
+@@ -23475,3 +23475,558 @@
+ CKA_TRUST_EMAIL_PROTECTION CK_TRUST CKT_NSS_NOT_TRUSTED
+ CKA_TRUST_CODE_SIGNING CK_TRUST CKT_NSS_NOT_TRUSTED
CKA_TRUST_STEP_UP_APPROVED CK_BBOOL CK_FALSE
-+
++
+#
+# Certificate "CAcert.org Class 1 Root CA"
+#