summaryrefslogtreecommitdiffstats
path: root/abs/extra/numlockx/PKGBUILD
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2010-09-05 06:13:57 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2010-09-05 06:13:57 (GMT)
commitb172f79fadb565ecfbcec9508f9377d8618a4f4c (patch)
treebf8823b07e3313c3afa000a9b31e4f9a735cb818 /abs/extra/numlockx/PKGBUILD
parentf9d54ab7c3853208484e304bc6cf40ab0f79d400 (diff)
parent5e7027c6194237ca1dc5fcbb3648483a970fb500 (diff)
downloadlinhes_pkgbuild-b172f79fadb565ecfbcec9508f9377d8618a4f4c.zip
linhes_pkgbuild-b172f79fadb565ecfbcec9508f9377d8618a4f4c.tar.gz
linhes_pkgbuild-b172f79fadb565ecfbcec9508f9377d8618a4f4c.tar.bz2
Merge branch 'HEAD' of ssh://cesman@knoppmyth.net/mount/repository/LinHES-PKGBUILD
Diffstat (limited to 'abs/extra/numlockx/PKGBUILD')
-rw-r--r--abs/extra/numlockx/PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/abs/extra/numlockx/PKGBUILD b/abs/extra/numlockx/PKGBUILD
new file mode 100644
index 0000000..172cceb
--- /dev/null
+++ b/abs/extra/numlockx/PKGBUILD
@@ -0,0 +1,26 @@
+# $Id: PKGBUILD 19225 2008-11-17 22:12:15Z thayer $
+# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
+# Contributor: Travis Willard <travisw@wmpub.ca>
+# Maintainer: Thayer Williams <thayer@archlinux.org>
+
+pkgname=numlockx
+pkgver=1.1
+pkgrel=4
+pkgdesc="Turns on the numlock key in X11"
+arch=('i686' 'x86_64')
+license=('MIT')
+url="http://ktown.kde.org/~seli/numlockx/"
+depends=('libxtst')
+source=(http://ktown.kde.org/~seli/$pkgname/$pkgname-$pkgver.tar.gz)
+md5sums=('127d9dfbbbe6dbec62cc78db340f913c')
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+ ./configure --prefix=/usr x_includes=/usr/include/X11 \
+ x_libraries=/usr/lib || return 1
+ make || return 1
+ make prefix=$pkgdir/usr install || return 1
+
+ # Install the custom MIT license
+ install -D LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE || return 1
+}