summaryrefslogtreecommitdiffstats
path: root/abs/extra/ocaml-ctypes
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2016-01-29 21:29:43 (GMT)
committerBritney Fransen <brfransen@gmail.com>2016-01-29 21:29:43 (GMT)
commitcf6a437dee04ab2f95f195239a91f7df5452fa5c (patch)
tree9f7fb9428de63d3b1f19c2a6acf1772b30872cf8 /abs/extra/ocaml-ctypes
parentb5fe68872dcf57f226f514dacada690c7471202a (diff)
downloadlinhes_pkgbuild-cf6a437dee04ab2f95f195239a91f7df5452fa5c.zip
linhes_pkgbuild-cf6a437dee04ab2f95f195239a91f7df5452fa5c.tar.gz
linhes_pkgbuild-cf6a437dee04ab2f95f195239a91f7df5452fa5c.tar.bz2
ocaml-ctypes: initial inclusion. dep of llvm
Diffstat (limited to 'abs/extra/ocaml-ctypes')
-rw-r--r--abs/extra/ocaml-ctypes/PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/abs/extra/ocaml-ctypes/PKGBUILD b/abs/extra/ocaml-ctypes/PKGBUILD
new file mode 100644
index 0000000..3d0922c
--- /dev/null
+++ b/abs/extra/ocaml-ctypes/PKGBUILD
@@ -0,0 +1,34 @@
+# $Id$
+# Maintainer: Evangelos Foutras <evangelos@foutrelis.com>
+# Contributor: Armin K. <krejzi at email dot com>
+
+pkgname=ocaml-ctypes
+pkgver=0.4.1
+pkgrel=3
+pkgdesc="Library for binding to C libraries using pure OCaml"
+arch=('i686' 'x86_64')
+url="https://github.com/ocamllabs/ocaml-ctypes"
+license=('MIT')
+depends=('ocaml' 'libffi')
+makedepends=('ocaml-findlib')
+options=('!strip' '!makeflags')
+source=($pkgname-$pkgver::https://github.com/ocamllabs/ocaml-ctypes/archive/$pkgver.tar.gz)
+sha256sums=('74564e049de5d3c0e76ea284c225cb658ac1a2b483345be1efb9be4b3c1702f5')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ local _destdir="$pkgdir$(ocamlfind printconf destdir)"
+ install -d "$_destdir/stublibs"
+
+ make OCAMLFIND_DESTDIR="$_destdir" install
+
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: