summaryrefslogtreecommitdiffstats
path: root/abs/extra/ocaml-findlib
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2017-02-08 16:23:59 (GMT)
committerBritney Fransen <brfransen@gmail.com>2017-02-08 16:23:59 (GMT)
commit7ba73be58ccc257a1ddacdd18fe32e90f3b59f2a (patch)
treede03d3b01c2fb56c5bbc5af674ee25de69c1fe81 /abs/extra/ocaml-findlib
parent4d46b966edeae4b57a897922261cc0e9cbb700b3 (diff)
downloadlinhes_pkgbuild-7ba73be58ccc257a1ddacdd18fe32e90f3b59f2a.zip
linhes_pkgbuild-7ba73be58ccc257a1ddacdd18fe32e90f3b59f2a.tar.gz
linhes_pkgbuild-7ba73be58ccc257a1ddacdd18fe32e90f3b59f2a.tar.bz2
ocaml-findlib: update to 1.7.1
Diffstat (limited to 'abs/extra/ocaml-findlib')
-rw-r--r--abs/extra/ocaml-findlib/PKGBUILD47
-rw-r--r--abs/extra/ocaml-findlib/makefile.patch13
2 files changed, 41 insertions, 19 deletions
diff --git a/abs/extra/ocaml-findlib/PKGBUILD b/abs/extra/ocaml-findlib/PKGBUILD
index ce5bdff..efe122f 100644
--- a/abs/extra/ocaml-findlib/PKGBUILD
+++ b/abs/extra/ocaml-findlib/PKGBUILD
@@ -1,37 +1,46 @@
-# Maintainer: Lukas Fleischer <lfleischer@archlinux.org>
-# Contributor: Thomas S Hatch <thatch45 at gmail dot com>
-# Contributor: Sebastian Wiesner <lunaryorn googlemail com>
-# Contributor: Benjamin Andresen <benny(at)klapmuetz(dot)org>
-# Contributor: scj <scj archlinux us>
+# $Id$
+# Maintainer: Alexander F Rødseth <xyproto@archlinux.org>
+# Contributor: Lukas Fleischer <lfleischer@archlinux.org>
+# Contributor: Thomas S Hatch <thatch45@gmail.com>
+# Contributor: Sebastian Wiesner <lunaryorn@googlemail.com>
+# Contributor: Benjamin Andresen <benny@klapmuetz.org>
+# Contributor: scj <scj@archlinux.us>
+# Contributor: Alif <alive4ever@live.com>
pkgname=ocaml-findlib
-pkgver=1.5.5
-pkgrel=3
-license=('MIT')
-arch=('i686' 'x86_64')
-pkgdesc='Objective Caml (OCaml) package manager'
+pkgver=1.7.1
+pkgrel=1
+pkgdesc='OCaml package manager'
+arch=('x86_64' 'i686')
url='http://projects.camlcity.org/projects/findlib.html'
+license=('MIT')
depends=('ocaml')
+makedepends=('setconf')
source=("http://download.camlcity.org/download/findlib-$pkgver.tar.gz")
-md5sums=('703eae112f9e912507c3a2f8d8c48498')
-options=('staticlibs' '!strip' 'zipman' '!makeflags') # otherwise the bytecode gets broken
+sha256sums=('5d4b9a79e9abf8be0b509f6b8cf5696221cbe14fa2fbb2bb352342755fd15eef')
+options=('staticlibs' '!strip' 'zipman' '!makeflags')
build() {
- cd "$srcdir/findlib-$pkgver"
+ cd "findlib-$pkgver"
+
+ ./configure \
+ -sitelib /usr/lib/ocaml \
+ -config /etc/findlib.conf \
+ -mandir /usr/share/man
- ./configure -config /etc/findlib.conf -sitelib /usr/lib/ocaml -mandir /usr/share/man
make all opt
}
package () {
- cd "$srcdir/findlib-$pkgver"
+ cd "findlib-$pkgver"
- make prefix="$pkgdir" install
+ make prefix="$pkgdir" install
- # add the old site-lib to the path to maintain compatibility with old style packages
- sed -i 's/path=\"\/usr\/lib\/ocaml\"/path="\/usr\/lib\/ocaml:\/usr\/lib\/ocaml\/site-lib"/' \
- "${pkgdir}/etc/findlib.conf"
+ # Add a directory to the path for compatibility with old-style packages
+ #setconf "$pkgdir/etc/findlib.conf" path='"/usr/lib/ocaml:/usr/lib/ocaml-site-lib"'
install -m755 src/findlib/ocamlfind_opt "$pkgdir/usr/bin/"
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
+
+# vim:set ts=2 sw=2 et:
diff --git a/abs/extra/ocaml-findlib/makefile.patch b/abs/extra/ocaml-findlib/makefile.patch
new file mode 100644
index 0000000..0e21a2d
--- /dev/null
+++ b/abs/extra/ocaml-findlib/makefile.patch
@@ -0,0 +1,13 @@
+Index: b/Makefile
+===================================================================
+--- a/Makefile
++++ b/Makefile
+@@ -71,7 +71,7 @@ findlib.conf: findlib.conf.in
+
+ .PHONY: install-doc
+ install-doc:
+- mkdir -p "$(prefix)$(OCAMLFIND_MAN)/man1" "$(prefix)$(OCAMLFIND_MAN)/man3 $(prefix)$(OCAMLFIND_MAN)/man5"
++ mkdir -p "$(prefix)$(OCAMLFIND_MAN)/man1" "$(prefix)$(OCAMLFIND_MAN)/man3" "$(prefix)$(OCAMLFIND_MAN)/man5"
+ -cp doc/ref-man/ocamlfind.1 "$(prefix)$(OCAMLFIND_MAN)/man1"
+ -cp doc/ref-man/META.5 doc/ref-man/site-lib.5 doc/ref-man/findlib.conf.5 "$(prefix)$(OCAMLFIND_MAN)/man5"
+