summaryrefslogtreecommitdiffstats
path: root/abs/extra/openmpi
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2014-11-24 23:12:04 (GMT)
committerBritney Fransen <brfransen@gmail.com>2014-11-24 23:12:04 (GMT)
commit5a39dbc3e9bc8f5acc4d353de37026250415ae74 (patch)
tree04f5ba6ec7f1e3b67882fb19840fba4d557478ca /abs/extra/openmpi
parent83095c8c2cac262fd7dd2f2b0bf5b70c40e1982e (diff)
downloadlinhes_pkgbuild-5a39dbc3e9bc8f5acc4d353de37026250415ae74.zip
linhes_pkgbuild-5a39dbc3e9bc8f5acc4d353de37026250415ae74.tar.gz
linhes_pkgbuild-5a39dbc3e9bc8f5acc4d353de37026250415ae74.tar.bz2
openmpi: update to 1.8.3
Diffstat (limited to 'abs/extra/openmpi')
-rw-r--r--abs/extra/openmpi/PKGBUILD79
-rw-r--r--abs/extra/openmpi/openmpi-hostfile.patch12
-rw-r--r--abs/extra/openmpi/system_ltdl.patch66
3 files changed, 109 insertions, 48 deletions
diff --git a/abs/extra/openmpi/PKGBUILD b/abs/extra/openmpi/PKGBUILD
index 3e57dde..9c8828c 100644
--- a/abs/extra/openmpi/PKGBUILD
+++ b/abs/extra/openmpi/PKGBUILD
@@ -1,39 +1,43 @@
-# $Id: PKGBUILD 159287 2012-05-20 22:11:21Z stephane $
-# Maintainer: Stéphane Gaudreault <stephane@archlinux.org>
+# $Id$
+# Maintainer: Anatol Pomozov <anatol dot pomozov at gmail>
+# Contributor: Stéphane Gaudreault <stephane@archlinux.org>
+
pkgname=openmpi
-pkgver=1.6
-pkgrel=2
-pkgdesc="High performance message passing library (MPI)"
-arch=('i686' 'x86_64')
-url="http://www.open-mpi.org"
-license=('custom')
-depends=('gcc-fortran' 'openssh' 'valgrind' 'libltdl' 'hwloc')
-makedepends=('inetutils')
-options=(!libtool)
-source=(http://www.open-mpi.org/software/ompi/v1.6/downloads/${pkgname}-${pkgver}.tar.bz2
- openmpi-hostfile.patch)
-sha1sums=('8b81eea712bb8f8120468003b5f29baecedf2367'
- 'a76da03418a106d57cfd020d0f8d887d7ec9225b')
+pkgver=1.8.3
+pkgrel=1
+pkgdesc='High performance message passing library (MPI)'
+arch=(i686 x86_64)
+url='http://www.open-mpi.org'
+license=(custom)
+depends=(libltdl hwloc)
+makedepends=(inetutils valgrind gcc-fortran)
+optdepends=('gcc-fortran: fortran support')
+options=(staticlibs)
+source=(http://www.open-mpi.org/software/ompi/v1.8/downloads/${pkgname}-${pkgver}.tar.bz2
+ system_ltdl.patch)
+sha1sums=('4be9c5d2a8baee6a80bde94c6485931979a428fe'
+ 'd5f8a3d463f1a1f29ca4725d6fb3b9f8c40799dc')
-build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+prepare() {
+ cd $pkgname-$pkgver
- # Make sure we use the system ltdl librariry rather than the ones in the tarball
+ # Make sure we use the system ltdl library rather than the ones in the tarball
rm -r opal/libltdl
+ patch -p1 < ../system_ltdl.patch
+ ./autogen.pl
+}
- # Search for openmpi-default-hostfile in /etc/openmpi
- patch -Np1 -i ../openmpi-hostfile.patch
+build() {
+ cd $pkgname-$pkgver
./configure --prefix=/usr \
--sysconfdir=/etc/${pkgname} \
- --mandir=/usr/share/man \
- --enable-mpi-f90 \
+ --enable-mpi-fortran=all \
--libdir=/usr/lib/${pkgname} \
--with-threads=posix \
--enable-smp-locks \
--with-valgrind \
--enable-memchecker \
- --enable-debug \
--enable-pretty-print-stacktrace \
--without-slurm \
--with-hwloc=/usr \
@@ -44,27 +48,30 @@ build() {
make
}
+check() {
+ cd $pkgname-$pkgver
+
+ make check
+}
+
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- make DESTDIR="${pkgdir}" install
+ cd $pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
# FS#28583
- install -d -m 755 "${pkgdir}"/usr/lib/pkgconfig
+ install -d -m 755 "$pkgdir"/usr/lib/pkgconfig
for i in ompi-c.pc ompi-cxx.pc ompi-f77.pc ompi-f90.pc ompi.pc; do
- ln -sf /usr/lib/openmpi/pkgconfig/${i} "${pkgdir}"/usr/lib/pkgconfig/
+ ln -sf /usr/lib/openmpi/pkgconfig/$i "$pkgdir"/usr/lib/pkgconfig/
done
# Openmpi's otfinfo conflicts with the one from texlive
- mv "${pkgdir}"/usr/bin/otfinfo{,mpi}
-
- # Openmpi's otfdump conflicts with the one from libotf
- mv "${pkgdir}"/usr/bin/otfdump{,ompi}
+ mv "$pkgdir"/usr/bin/otfinfo{,mpi}
- # Remove dangling symlink
- rm "${pkgdir}"/usr/share/man/man1/orteCC.1
+ # Remove dangling symlink and useless file
+ rm "$pkgdir"/usr/share/vampirtrace/config.log
- install -d -m 755 "${pkgdir}"/etc/ld.so.conf.d
- echo "/usr/lib/${pkgname}" > "${pkgdir}"/etc/ld.so.conf.d/${pkgname}.conf
+ install -d -m 755 "$pkgdir"/etc/ld.so.conf.d
+ echo "/usr/lib/$pkgname" > "$pkgdir"/etc/ld.so.conf.d/$pkgname.conf
- install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}
diff --git a/abs/extra/openmpi/openmpi-hostfile.patch b/abs/extra/openmpi/openmpi-hostfile.patch
deleted file mode 100644
index f637767..0000000
--- a/abs/extra/openmpi/openmpi-hostfile.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -up openmpi-1.6/orte/runtime/orte_mca_params.c.hostfile openmpi-1.6/orte/runtime/orte_mca_params.c
---- openmpi-1.6/orte/runtime/orte_mca_params.c.hostfile 2012-04-24 13:18:21.000000000 -0600
-+++ openmpi-1.6/orte/runtime/orte_mca_params.c 2012-05-15 16:35:24.769565442 -0600
-@@ -225,7 +225,7 @@ int orte_register_params(void)
- false, false, 1000, &orte_timeout_usec_per_proc);
-
- /* default hostfile */
-- asprintf(&orte_default_hostfile, "%s/etc/openmpi-default-hostfile", opal_install_dirs.prefix);
-+ asprintf(&orte_default_hostfile, "%s/openmpi-default-hostfile", opal_install_dirs.sysconfdir);
- mca_base_param_reg_string_name("orte", "default_hostfile",
- "Name of the default hostfile (relative or absolute path, \"none\" to ignore environmental or default MCA param setting)",
- false, false, orte_default_hostfile, &orte_default_hostfile);
diff --git a/abs/extra/openmpi/system_ltdl.patch b/abs/extra/openmpi/system_ltdl.patch
new file mode 100644
index 0000000..300da38
--- /dev/null
+++ b/abs/extra/openmpi/system_ltdl.patch
@@ -0,0 +1,66 @@
+diff --git a/config/ltdl.m4 b/config/ltdl.m4
+index ea76f4d..2f1cbfe 100644
+--- a/config/ltdl.m4
++++ b/config/ltdl.m4
+@@ -162,6 +162,8 @@ m4_defun([_LTDL_INSTALLABLE],
+ fi
+ fi
+
++enable_ltdl_install=no
++
+ # If configure.ac declared an installable ltdl, and the user didn't override
+ # with --disable-ltdl-install, we will install the shipped libltdl.
+ case $enable_ltdl_install in
+diff --git a/ompi/debuggers/Makefile.am b/ompi/debuggers/Makefile.am
+index 2adf3fd..5b22a91 100644
+--- a/ompi/debuggers/Makefile.am
++++ b/ompi/debuggers/Makefile.am
+@@ -46,8 +46,7 @@ headers = \
+ # Simple checks to ensure that the DSOs are functional
+
+ dlopen_test_SOURCES = dlopen_test.c
+-dlopen_test_CPPFLAGS = -I$(top_srcdir)/opal/libltdl
+-dlopen_test_LDADD = $(top_builddir)/opal/libltdl/libltdlc.la
++dlopen_test_LDADD = -lltdl
+
+ predefined_gap_test_SOURCES = predefined_gap_test.c
+ predefined_gap_test_LDFLAGS = $(WRAPPER_EXTRA_LDFLAGS)
+diff --git a/ompi/debuggers/dlopen_test.c b/ompi/debuggers/dlopen_test.c
+index 029a4ee..023afb8 100644
+--- a/ompi/debuggers/dlopen_test.c
++++ b/ompi/debuggers/dlopen_test.c
+@@ -13,7 +13,7 @@
+ #include <string.h>
+ #include <stdlib.h>
+
+-#include "opal/libltdl/ltdl.h"
++#include "ltdl.h"
+
+ static int do_test(void);
+
+diff --git a/test/support/components.c b/test/support/components.c
+index 41c4345..6b4b464 100644
+--- a/test/support/components.c
++++ b/test/support/components.c
+@@ -24,7 +24,7 @@
+
+ #include "opal/constants.h"
+ #include "opal/mca/mca.h"
+-#include "opal/libltdl/ltdl.h"
++#include "ltdl.h"
+
+ #include "components.h"
+
+diff --git a/test/support/components.h b/test/support/components.h
+index 6db1f0d..fc8dfc5 100644
+--- a/test/support/components.h
++++ b/test/support/components.h
+@@ -20,7 +20,7 @@
+ #ifndef OMPI_SUPPORT_COMPONENTS_H
+ #define OMPI_SUPPORT_COMPONENTS_H
+
+-#include "opal/libltdl/ltdl.h"
++#include "ltdl.h"
+ #include "opal/mca/mca.h"
+
+ BEGIN_C_DECLS