summaryrefslogtreecommitdiffstats
path: root/abs/extra/opus
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2013-08-16 22:53:46 (GMT)
committerBritney Fransen <brfransen@gmail.com>2013-08-16 22:53:46 (GMT)
commit6a2d18798baf78a3c2e4540741369852eb764cf6 (patch)
tree7970ab34ce41bdab52894ced7a00fdf193ad31ac /abs/extra/opus
parent9eb7f90551c6926ccc68ad03f708e52ca4f99f08 (diff)
downloadlinhes_pkgbuild-6a2d18798baf78a3c2e4540741369852eb764cf6.zip
linhes_pkgbuild-6a2d18798baf78a3c2e4540741369852eb764cf6.tar.gz
linhes_pkgbuild-6a2d18798baf78a3c2e4540741369852eb764cf6.tar.bz2
opus: inital inclusion. dep of chromium 28
Diffstat (limited to 'abs/extra/opus')
-rw-r--r--abs/extra/opus/PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/abs/extra/opus/PKGBUILD b/abs/extra/opus/PKGBUILD
new file mode 100644
index 0000000..9236886
--- /dev/null
+++ b/abs/extra/opus/PKGBUILD
@@ -0,0 +1,34 @@
+# $Id$
+# Maintainer: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
+# Contributor: Jan de Groot <jgc@archlinux.org>
+# Contributor: DrZaius <lou[at]fakeoutdoorsman[dot]com>
+# Contributor: pumbur
+
+pkgname=opus
+pkgver=1.0.3
+pkgrel=1
+pkgdesc="Codec designed for interactive speech and audio transmission over the Internet"
+arch=(i686 x86_64)
+url="http://www.opus-codec.org/"
+license=(BSD)
+depends=(glibc)
+options=('!libtool')
+source=(http://downloads.us.xiph.org/releases/$pkgname/$pkgname-$pkgver.tar.gz)
+md5sums=('86eedbd3c5a0171d2437850435e6edff')
+
+build() {
+ cd $pkgname-$pkgver
+ ./configure --prefix=/usr --enable-custom-modes
+ make
+}
+
+check() {
+ cd $pkgname-$pkgver
+ make check
+}
+
+package() {
+ cd $pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}