summaryrefslogtreecommitdiffstats
path: root/abs/extra/p7zip
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2017-01-26 15:59:27 (GMT)
committerBritney Fransen <brfransen@gmail.com>2017-01-26 15:59:27 (GMT)
commit16a18d2f23f66b1f4bfdac8ba9a6c8d1b4033d28 (patch)
treebd5e8ddade5ac3b1b2e0ed2d2ac738d0c2251a52 /abs/extra/p7zip
parent61403468c91adfdb5287b56d864b34ae1725b97c (diff)
downloadlinhes_pkgbuild-16a18d2f23f66b1f4bfdac8ba9a6c8d1b4033d28.zip
linhes_pkgbuild-16a18d2f23f66b1f4bfdac8ba9a6c8d1b4033d28.tar.gz
linhes_pkgbuild-16a18d2f23f66b1f4bfdac8ba9a6c8d1b4033d28.tar.bz2
p7zip: update to 16.02
Diffstat (limited to 'abs/extra/p7zip')
-rw-r--r--abs/extra/p7zip/7zFM.desktop9
-rw-r--r--abs/extra/p7zip/PKGBUILD91
-rw-r--r--abs/extra/p7zip/install13
-rw-r--r--abs/extra/p7zip/p7zip.install9
4 files changed, 51 insertions, 71 deletions
diff --git a/abs/extra/p7zip/7zFM.desktop b/abs/extra/p7zip/7zFM.desktop
deleted file mode 100644
index 62b8e85..0000000
--- a/abs/extra/p7zip/7zFM.desktop
+++ /dev/null
@@ -1,9 +0,0 @@
-[Desktop Entry]
-Encoding=UTF-8
-Name=7-Zip FM
-GenericName=7-Zip File Manager
-Type=Application
-Categories=GTK;Utility;Archiving;Compression;
-Terminal=false
-Icon=p7zip
-Exec=7zFM
diff --git a/abs/extra/p7zip/PKGBUILD b/abs/extra/p7zip/PKGBUILD
index 4bb2bb4..434bbeb 100644
--- a/abs/extra/p7zip/PKGBUILD
+++ b/abs/extra/p7zip/PKGBUILD
@@ -1,62 +1,55 @@
-# $Id: PKGBUILD 143961 2011-11-30 22:27:42Z andrea $
+# $Id$
+# Maintainer: Evangelos Foutras <evangelos@foutrelis.com>
+# Contributor: Gaetan Bisson <bisson@archlinux.org>
# Contributor: Thayer Williams <thayer@archlinux.org>
# Contributor: Hugo Doria <hugo@archlinux.org>
# Contributor: TuxSpirit<tuxspirit@archlinux.fr> 2007/11/17 21:22:36 UTC
# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
-# Maintainer: Gaetan Bisson <bisson@archlinux.org>
pkgname=p7zip
-pkgver=9.20.1
-pkgrel=6
-pkgdesc='Command-line version of the 7zip compressed file archiver'
-url='http://p7zip.sourceforge.net/'
-license=('GPL' 'custom')
+pkgver=16.02
+pkgrel=2
+pkgdesc="Command-line file archiver with high compression ratio"
arch=('i686' 'x86_64')
-depends=('gcc-libs' 'bash')
-optdepends=('wxgtk: GUI'
- 'desktop-file-utils: desktop entries')
-makedepends=('yasm' 'nasm' 'wxgtk')
-options=('!makeflags')
-source=("http://downloads.sourceforge.net/project/${pkgname}/${pkgname}/${pkgver}/${pkgname}_${pkgver}_src_all.tar.bz2"
- '7zFM.desktop')
-sha1sums=('1cd567e043ee054bf08244ce15f32cb3258306b7'
- 'f2c370d6f1b286b7ce9a2804e22541b755616a40')
-
-install=install
+url="http://p7zip.sourceforge.net/"
+license=('LGPL' 'custom:unRAR')
+depends=('gcc-libs' 'sh')
+makedepends_i686=('nasm')
+makedepends_x86_64=('yasm')
+install=$pkgname.install
+source=(https://downloads.sourceforge.net/project/$pkgname/$pkgname/$pkgver/${pkgname}_${pkgver}_src_all.tar.bz2)
+sha256sums=('5eb20ac0e2944f6cb9c2d51dd6c4518941c185347d4089ea89087ffdd6e2341f')
+
+prepare() {
+ cd "$srcdir/${pkgname}_$pkgver"
+
+ if [[ $CARCH = x86_64 ]]; then
+ cp makefile.linux_amd64_asm makefile.machine
+ else
+ cp makefile.linux_x86_asm_gcc_4.X makefile.machine
+ fi
+}
build() {
- cd "${srcdir}/${pkgname}_${pkgver}"
-
- [[ $CARCH = x86_64 ]] \
- && cp makefile.linux_amd64_asm makefile.machine \
- || cp makefile.linux_x86_asm_gcc_4.X makefile.machine
-
- make all4 OPTFLAGS="${CXXFLAGS}"
+ cd "$srcdir/${pkgname}_$pkgver"
+ make all3 OPTFLAGS="$CFLAGS"
}
package() {
- cd "${srcdir}/${pkgname}_${pkgver}"
-
- make install \
- DEST_DIR="${pkgdir}" \
- DEST_HOME="/usr" \
- DEST_MAN="/usr/share/man"
-
- # Licenses
- install -d "${pkgdir}"/usr/share/licenses/p7zip
- ln -s -t "${pkgdir}"/usr/share/licenses/p7zip \
- /usr/share/doc/p7zip/DOCS/License.txt \
- /usr/share/doc/p7zip/DOCS/unRarLicense.txt
-
- # Integration with stuff...
- install -D GUI/p7zip_32.png "${pkgdir}"/usr/share/icons/hicolor/32x32/apps/p7zip.png
- install -d "${pkgdir}"/usr/share/{applications,kde4/services/ServiceMenus}
- cp GUI/kde4/* "${pkgdir}"/usr/share/kde4/services/ServiceMenus/
- cp ../7zFM.desktop "${pkgdir}"/usr/share/applications/
- ln -s 7zCon.sfx "${pkgdir}"/usr/lib/p7zip/7z.sfx
-
- find GUI/help -type d -exec chmod 755 {} \;
- cp -r GUI/help "${pkgdir}"/usr/lib/p7zip/
-
- chmod -R u+w "${pkgdir}/usr"
+ cd "$srcdir/${pkgname}_$pkgver"
+
+ make install \
+ DEST_DIR="$pkgdir" \
+ DEST_HOME=/usr \
+ DEST_MAN=/usr/share/man
+
+ # Remove documentation for the GUI file manager
+ rm -r "$pkgdir/usr/share/doc/p7zip/DOC/MANUAL/fm"
+
+ install -d "${pkgdir}"/usr/share/licenses/p7zip
+ ln -s -t "$pkgdir/usr/share/licenses/p7zip/" \
+ /usr/share/doc/p7zip/DOC/License.txt \
+ /usr/share/doc/p7zip/DOC/unRarLicense.txt
}
+
+# vim:set ts=2 sw=2 et:
diff --git a/abs/extra/p7zip/install b/abs/extra/p7zip/install
deleted file mode 100644
index 7f3cc43..0000000
--- a/abs/extra/p7zip/install
+++ /dev/null
@@ -1,13 +0,0 @@
-post_install() {
- [[ -x usr/bin/update-desktop-database ]] && update-desktop-database -q || true
- [[ -x usr/bin/gtk-update-icon-cache ]] && gtk-update-icon-cache -q -t -f usr/share/icons/hicolor || true
-}
-
-post_upgrade() {
- post_install
-}
-
-
-post_remove() {
- post_install
-}
diff --git a/abs/extra/p7zip/p7zip.install b/abs/extra/p7zip/p7zip.install
new file mode 100644
index 0000000..4c3bb82
--- /dev/null
+++ b/abs/extra/p7zip/p7zip.install
@@ -0,0 +1,9 @@
+post_upgrade() {
+ if (($(vercmp $2 9.38.1-3) < 0)); then
+ echo ':: The 7zFM graphical frontend is no longer included in this package.'
+ echo ' If you used it, consider installing one of the following packages:'
+ echo ' 1) file-roller, 2) engrampa, 3) kdeutils-ark.'
+ fi
+}
+
+# vim:set ts=2 sw=2 et: