summaryrefslogtreecommitdiffstats
path: root/abs/extra/p7zip
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2010-08-30 22:26:00 (GMT)
committerJames Meyer <james.meyer@operamail.com>2010-08-30 22:26:00 (GMT)
commit1f175a7b07b9553ce98d0546ac04dbb925ec0bc9 (patch)
treec969070115611a8a75f23d468aa5e0cf86a08121 /abs/extra/p7zip
parentc4bd4457b5d640e1c8f5afbca7cd54c53691e5fc (diff)
downloadlinhes_pkgbuild-1f175a7b07b9553ce98d0546ac04dbb925ec0bc9.zip
linhes_pkgbuild-1f175a7b07b9553ce98d0546ac04dbb925ec0bc9.tar.gz
linhes_pkgbuild-1f175a7b07b9553ce98d0546ac04dbb925ec0bc9.tar.bz2
RESYNC EXTRA:
synced extra-testing -> extra repo Signed-off-by: James Meyer <james.meyer@operamail.com>
Diffstat (limited to 'abs/extra/p7zip')
-rw-r--r--abs/extra/p7zip/PKGBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/abs/extra/p7zip/PKGBUILD b/abs/extra/p7zip/PKGBUILD
new file mode 100644
index 0000000..9ae5122
--- /dev/null
+++ b/abs/extra/p7zip/PKGBUILD
@@ -0,0 +1,45 @@
+# $Id: PKGBUILD 70413 2010-02-26 18:54:59Z thayer $
+# Maintainer: Thayer Williams <thayer@archlinux.org>
+# Contributor: Hugo Doria <hugo@archlinux.org>
+# Contributor: TuxSpirit<tuxspirit@archlinux.fr> 2007/11/17 21:22:36 UTC
+
+pkgname=p7zip
+pkgver=9.04
+pkgrel=2
+pkgdesc="A command-line port of the 7zip compression utility"
+arch=('i686' 'x86_64')
+license=('GPL')
+url="http://p7zip.sourceforge.net"
+depends=('gcc-libs' 'bash')
+source=(http://downloads.sourceforge.net/sourceforge/$pkgname/${pkgname}_${pkgver}_src_all.tar.bz2)
+options=(!emptydirs)
+
+build() {
+ cd ${srcdir}/${pkgname}_${pkgver}
+
+ #Arch64 fix
+ if [ "$CARCH" == "x86_64" ]; then
+ cp makefile.linux_amd64 makefile.machine
+ else
+ cp makefile.linux_x86_ppc_alpha_gcc_4.X makefile.machine
+ fi
+
+ sed -i "s|usr/local|usr|g" makefile
+
+ make all3 OPTFLAGS="${CXXFLAGS}" || return 1
+ make install DEST_HOME="${pkgdir}/usr" \
+ DEST_MAN="${pkgdir}/usr/share/man" \
+ DEST_SHARE_DOC="http://www.bugaco.com/7zip"
+
+ mkdir -p ${pkgdir}/usr/share/doc/p7zip/DOCS
+ install -m555 bin/7z.so ${pkgdir}/usr/lib/p7zip/
+
+ sed -i "s|${pkgdir}/usr|/usr|g" ${pkgdir}/usr/bin/7z
+ sed -i "s|${pkgdir}/usr|/usr|g" ${pkgdir}/usr/bin/7za
+ sed -i "s|${pkgdir}/usr|/usr|g" ${pkgdir}/usr/bin/7zr
+
+ # Install mc's virtual filesystem
+ install -m755 -D contrib/VirtualFileSystemForMidnightCommander/u7z \
+ ${pkgdir}/usr/share/mc/extfs/u7z
+}
+md5sums=('9194ebf9a2b3735d236aed001de5f6f8')