summaryrefslogtreecommitdiffstats
path: root/abs/extra/perl-net-smtp-ssl
diff options
context:
space:
mode:
authorMichael Hanson <hansonorders@verizon.net>2010-11-06 03:48:03 (GMT)
committerMichael Hanson <hansonorders@verizon.net>2010-11-06 03:48:03 (GMT)
commit0a3fe43e82f3632a0af35ed44a020b1444d46c5a (patch)
treea21398fdf911e86c933d958cb4f5a9662b63cd75 /abs/extra/perl-net-smtp-ssl
parent939317a53e3cba331040f54d3600c8aa72ff7a11 (diff)
downloadlinhes_pkgbuild-0a3fe43e82f3632a0af35ed44a020b1444d46c5a.zip
linhes_pkgbuild-0a3fe43e82f3632a0af35ed44a020b1444d46c5a.tar.gz
linhes_pkgbuild-0a3fe43e82f3632a0af35ed44a020b1444d46c5a.tar.bz2
perl-net-smtp-ssl: initial include
Diffstat (limited to 'abs/extra/perl-net-smtp-ssl')
-rw-r--r--abs/extra/perl-net-smtp-ssl/PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/abs/extra/perl-net-smtp-ssl/PKGBUILD b/abs/extra/perl-net-smtp-ssl/PKGBUILD
new file mode 100644
index 0000000..e4b24bb
--- /dev/null
+++ b/abs/extra/perl-net-smtp-ssl/PKGBUILD
@@ -0,0 +1,28 @@
+# $Id: PKGBUILD 17474 2010-05-24 13:41:50Z cbrannon $
+# Maintainer: Chris Brannon <cmbrannon79@gmail.com>
+# Contributor: Abhishek Dasgupta <abhidg@gmail.com>
+
+pkgname=perl-net-smtp-ssl
+pkgver=1.01
+pkgrel=2
+pkgdesc="SSL support for Net::SMTP"
+arch=(any)
+url="http://search.cpan.org/dist/Net-SMTP-SSL/"
+license=('GPL' 'PerlArtistic')
+depends=('perl-io-socket-ssl')
+source=("http://www.cpan.org/authors/id/C/CW/CWEST/Net-SMTP-SSL-${pkgver}.tar.gz")
+options=(!emptydirs)
+
+build() {
+ cd "${srcdir}/Net-SMTP-SSL-${pkgver}"
+ # Install module into the vendor directories.
+ perl Makefile.PL INSTALLDIRS=vendor || return 1
+ make || return 1
+ make DESTDIR="$pkgdir" install || return 1
+
+ # Remove .packlist and perllocal.pod files.
+ find "$pkgdir" -name '.packlist' -delete
+ find "$pkgdir" -name 'perllocal.pod' -delete
+}
+md5sums=('ba039288ebf7a343feecacd374da8c1a')
+