summaryrefslogtreecommitdiffstats
path: root/abs/extra/polkit/PKGBUILD
diff options
context:
space:
mode:
authorMichael Hanson <hansonorders@verizon.net>2011-08-05 00:02:11 (GMT)
committerMichael Hanson <hansonorders@verizon.net>2011-08-05 00:02:11 (GMT)
commit3ed82dcc25c9d293ad135854cdc3244ed063b15d (patch)
treeff731aa846fcf5809e9a5bfd4dfd61f01d18ae1a /abs/extra/polkit/PKGBUILD
parent2f3f600f377fbc7ed2d641afcc8bf3fd16376470 (diff)
parenta17f74ee89c3c3120613ae61db77333f366970dc (diff)
downloadlinhes_pkgbuild-3ed82dcc25c9d293ad135854cdc3244ed063b15d.zip
linhes_pkgbuild-3ed82dcc25c9d293ad135854cdc3244ed063b15d.tar.gz
linhes_pkgbuild-3ed82dcc25c9d293ad135854cdc3244ed063b15d.tar.bz2
Merge branch 'testing' of knoppmyth.net:linhes_pkgbuild into testing
Diffstat (limited to 'abs/extra/polkit/PKGBUILD')
-rw-r--r--abs/extra/polkit/PKGBUILD20
1 files changed, 9 insertions, 11 deletions
diff --git a/abs/extra/polkit/PKGBUILD b/abs/extra/polkit/PKGBUILD
index 62f3f8b..3a55ddc 100644
--- a/abs/extra/polkit/PKGBUILD
+++ b/abs/extra/polkit/PKGBUILD
@@ -1,29 +1,27 @@
-# $Id: PKGBUILD 90717 2010-09-15 14:26:53Z jgc $
+# $Id$
# Maintainer: Jan de Groot <jgc@archlinux.org>
pkgname=polkit
-pkgver=0.98
-pkgrel=1
+pkgver=0.101
+pkgrel=2
pkgdesc="Application development toolkit for controlling system-wide privileges"
arch=(i686 x86_64)
license=('LGPL')
url="http://www.freedesktop.org/wiki/Software/PolicyKit"
-depends=('glib2>=2.25.15' 'pam' 'expat>=2.0.1')
-makedepends=('intltool>=0.41.1' 'gtk-doc>=1.15' 'gobject-introspection>=0.9.5')
+depends=('glib2' 'pam' 'expat')
+makedepends=('intltool' 'gtk-doc' 'gobject-introspection')
replaces=('policykit')
options=('!libtool')
source=(http://hal.freedesktop.org/releases/${pkgname}-${pkgver}.tar.gz
- polkit-git-fixes.patch
+ CVE-2011-1485.patch
polkit.pam)
-md5sums=('96e583a1177ba5436f034a2fee55f5fa'
- 'c5aaa13d6eeda5cec224b273acba9420'
+md5sums=('f925ac93aba3c072977370c1e27feb7f'
+ '4d858b8ab602614d7db2bc8574f6fd29'
'6564f95878297b954f0572bc1610dd15')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
- patch -Np1 -i "${srcdir}/polkit-git-fixes.patch"
- libtoolize --force
- autoreconf
+ patch -Np1 -i "${srcdir}/CVE-2011-1485.patch"
./configure --prefix=/usr --sysconfdir=/etc \
--localstatedir=/var --libexecdir=/usr/lib/polkit-1 \
--disable-static --enable-gtk-doc