summaryrefslogtreecommitdiffstats
path: root/abs/extra/polkit
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2018-04-27 15:29:29 (GMT)
committerBritney Fransen <brfransen@gmail.com>2018-04-27 15:29:29 (GMT)
commit51f4bfc579814abea2f90404a434017dca5a3e22 (patch)
tree13fd761d30bda3f07f0649076047413fd997f82f /abs/extra/polkit
parentef0a21c1b5b942595b706064f4122ed16fc4a0a9 (diff)
downloadlinhes_pkgbuild-51f4bfc579814abea2f90404a434017dca5a3e22.zip
linhes_pkgbuild-51f4bfc579814abea2f90404a434017dca5a3e22.tar.gz
linhes_pkgbuild-51f4bfc579814abea2f90404a434017dca5a3e22.tar.bz2
polkit: update to 0.114
Diffstat (limited to 'abs/extra/polkit')
-rw-r--r--abs/extra/polkit/PKGBUILD59
-rw-r--r--abs/extra/polkit/__changelog1
-rw-r--r--abs/extra/polkit/polkit.install18
-rw-r--r--abs/extra/polkit/polkit.pam7
4 files changed, 40 insertions, 45 deletions
diff --git a/abs/extra/polkit/PKGBUILD b/abs/extra/polkit/PKGBUILD
index b120d65..30eaa69 100644
--- a/abs/extra/polkit/PKGBUILD
+++ b/abs/extra/polkit/PKGBUILD
@@ -2,36 +2,57 @@
# Maintainer: Jan de Groot <jgc@archlinux.org>
pkgname=polkit
-pkgver=0.112
-pkgrel=2
+pkgver=0.114
+pkgrel=1
pkgdesc="Application development toolkit for controlling system-wide privileges"
-arch=(i686 x86_64)
+arch=(x86_64)
license=(LGPL)
-url="http://www.freedesktop.org/wiki/Software/polkit"
-depends=(glib2 pam expat systemd js17)
-makedepends=(intltool gtk-doc gobject-introspection)
-install=polkit.install
-source=(http://www.freedesktop.org/software/polkit/releases/$pkgname-$pkgver.tar.gz
- polkit.pam)
+url="https://www.freedesktop.org/wiki/Software/polkit/"
+depends=(glib2 pam expat systemd js52)
+makedepends=(intltool gtk-doc gobject-introspection git autoconf-archive)
+_commit=ed06baed179166389d536420a6fc532781d48178 # tags/0.114^0
+source=("git+https://anongit.freedesktop.org/git/polkit#commit=$_commit")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ git describe --tags | sed 's/-/+/g'
+}
+
+prepare() {
+ cd $pkgname
+ git cherry-pick -n 373705b35e7f6c7dc83de5e0a3ce11ecd15d0409
+ NOCONFIGURE=1 ./autogen.sh
+}
build() {
- cd $pkgname-$pkgver
+ cd $pkgname
./configure --prefix=/usr --sysconfdir=/etc \
- --localstatedir=/var --libexecdir=/usr/lib/polkit-1 \
- --enable-libsystemd-login=no --disable-static \
- --enable-gtk-doc
+ --localstatedir=/var --libexecdir=/usr/lib \
+ --enable-libsystemd-login=yes --disable-static \
+ --enable-gtk-doc --with-os-type=redhat
+
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
+
make
}
+check() {
+ cd $pkgname
+ make -k check || :
+}
+
package() {
- cd $pkgname-$pkgver
+ cd $pkgname
make DESTDIR="$pkgdir" install
- chown 102 "$pkgdir/etc/polkit-1/rules.d"
- chown 102 "$pkgdir/usr/share/polkit-1/rules.d"
+ install -d -o root -g 102 -m 750 "$pkgdir"/{etc,usr/share}/polkit-1/rules.d
- install -m644 "$srcdir/polkit.pam" "$pkgdir/etc/pam.d/polkit-1"
+ install -Dm644 /dev/stdin "$pkgdir/usr/lib/sysusers.d/$pkgname.conf" <<END
+u polkitd 102 "PolicyKit daemon"
+m polkitd proc
+END
}
-md5sums=('b0f2fa00a55f47c6a5d88e9b73f80127'
- '6564f95878297b954f0572bc1610dd15')
+
+# vim: ts=2 sw=2 et:
diff --git a/abs/extra/polkit/__changelog b/abs/extra/polkit/__changelog
deleted file mode 100644
index 8a7d752..0000000
--- a/abs/extra/polkit/__changelog
+++ /dev/null
@@ -1 +0,0 @@
-PKGBUILD: change --enable-libsystemd-login=yes to --enable-libsystemd-login=no
diff --git a/abs/extra/polkit/polkit.install b/abs/extra/polkit/polkit.install
deleted file mode 100644
index fbb9891..0000000
--- a/abs/extra/polkit/polkit.install
+++ /dev/null
@@ -1,18 +0,0 @@
-post_install() {
- getent group polkitd >/dev/null || groupadd -g 102 polkitd
- getent passwd polkitd >/dev/null || useradd -c 'Policy Kit Daemon' -u 102 -g polkitd -d '/' -s /bin/false polkitd
- passwd -l polkitd &>/dev/null
-}
-
-post_upgrade() {
- post_install
-}
-
-post_remove() {
- if getent passwd polkitd >/dev/null; then
- userdel polkitd
- fi
- if getent group polkitd >/dev/null; then
- groupdel polkitd
- fi
-}
diff --git a/abs/extra/polkit/polkit.pam b/abs/extra/polkit/polkit.pam
deleted file mode 100644
index 04f53e0..0000000
--- a/abs/extra/polkit/polkit.pam
+++ /dev/null
@@ -1,7 +0,0 @@
-auth requisite pam_nologin.so
-auth required pam_env.so
-auth required pam_unix.so
-account required pam_unix.so
-session required pam_limits.so
-session required pam_unix.so
-password required pam_unix.so