summaryrefslogtreecommitdiffstats
path: root/abs/extra/portaudio
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2016-05-16 16:24:28 (GMT)
committerBritney Fransen <brfransen@gmail.com>2016-05-16 16:24:28 (GMT)
commitfff4c50d3a1d94c807604d6c21355993dfb95c85 (patch)
tree390f0eb0781b2599449edbdafbeb6aaba34200dc /abs/extra/portaudio
parent8de064f6e96f960cdbfe6868d9957a4613f704df (diff)
parent6f7a84649ef75069cc4fa06fabeb63e762e049d1 (diff)
downloadlinhes_pkgbuild-fff4c50d3a1d94c807604d6c21355993dfb95c85.zip
linhes_pkgbuild-fff4c50d3a1d94c807604d6c21355993dfb95c85.tar.gz
linhes_pkgbuild-fff4c50d3a1d94c807604d6c21355993dfb95c85.tar.bz2
Merge branch 'testing'
Diffstat (limited to 'abs/extra/portaudio')
-rw-r--r--abs/extra/portaudio/PKGBUILD34
-rw-r--r--abs/extra/portaudio/__changelog2
2 files changed, 36 insertions, 0 deletions
diff --git a/abs/extra/portaudio/PKGBUILD b/abs/extra/portaudio/PKGBUILD
new file mode 100644
index 0000000..91903f5
--- /dev/null
+++ b/abs/extra/portaudio/PKGBUILD
@@ -0,0 +1,34 @@
+# $Id$
+# Maintainer: Lukas Fleischer <lfleischer@archlinux.org>
+# Contributor: Eric Belanger <eric@archlinux.org>
+# Contributor: Darwin Bautista <djclue917@gmail.com>
+# Contributor: Bob Finch <w9ya@qrparci.net>
+
+pkgname=portaudio
+pkgver=19_20140130
+pkgrel=3
+pkgdesc='A free, cross-platform, open source, audio I/O library.'
+arch=('i686' 'x86_64')
+url='http://www.portaudio.com/'
+license=('custom')
+depends=('gcc-libs')
+conflicts=('portaudio_cpp')
+provides=('portaudio_cpp')
+replaces=('portaudio_cpp')
+options=('!makeflags')
+source=("http://www.portaudio.com/archives/pa_stable_v$pkgver.tgz")
+md5sums=('7f220406902af9dca009668e198cbd23')
+
+build() {
+ cd "$srcdir/$pkgname"
+
+ ./configure --prefix=/usr --enable-cxx
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+
+ make DESTDIR="$pkgdir" install
+ install -Dm0644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE.txt"
+}
diff --git a/abs/extra/portaudio/__changelog b/abs/extra/portaudio/__changelog
new file mode 100644
index 0000000..f2d307a
--- /dev/null
+++ b/abs/extra/portaudio/__changelog
@@ -0,0 +1,2 @@
+PKGBUILD:
+- remove dep jack