summaryrefslogtreecommitdiffstats
path: root/abs/extra/postgresql
diff options
context:
space:
mode:
authorMichael Hanson <hansonorders@verizon.net>2010-11-05 02:52:52 (GMT)
committerMichael Hanson <hansonorders@verizon.net>2010-11-05 02:52:52 (GMT)
commit52a6d8af182cc82db86bda098fa8be52c82245c6 (patch)
treecdceccd4b251c3c85230510de263cf65a74a3a26 /abs/extra/postgresql
parent5c5b14ceb6f68a046184b4219a0d74e5d2811269 (diff)
downloadlinhes_pkgbuild-52a6d8af182cc82db86bda098fa8be52c82245c6.zip
linhes_pkgbuild-52a6d8af182cc82db86bda098fa8be52c82245c6.tar.gz
linhes_pkgbuild-52a6d8af182cc82db86bda098fa8be52c82245c6.tar.bz2
postgresql: update to 9.0
Diffstat (limited to 'abs/extra/postgresql')
-rw-r--r--abs/extra/postgresql/PKGBUILD165
-rwxr-xr-xabs/extra/postgresql/postgresql4
-rw-r--r--abs/extra/postgresql/postgresql.confd3
-rw-r--r--abs/extra/postgresql/postgresql.logrotate4
4 files changed, 119 insertions, 57 deletions
diff --git a/abs/extra/postgresql/PKGBUILD b/abs/extra/postgresql/PKGBUILD
index 1fda9a4..14ba9f8 100644
--- a/abs/extra/postgresql/PKGBUILD
+++ b/abs/extra/postgresql/PKGBUILD
@@ -1,79 +1,136 @@
-# $Id: PKGBUILD 27762 2009-02-25 16:29:49Z douglas $
-# Maintainer: Paul Mattal <paul@archlinux.org>
-
-pkgname=postgresql
-pkgver=8.3.6
-pkgrel=1
-pkgdesc="A sophisticated object-relational DBMS"
-arch=(i686 x86_64)
+# $Id: PKGBUILD 98184 2010-11-04 14:55:39Z dan $
+# Maintainer: Douglas Soares de Andrade <douglas@archlinux.org>
+
+pkgbase=postgresql
+pkgname=('postgresql-libs' 'postgresql-docs' 'postgresql')
+pkgver=9.0.1
+pkgrel=2.1
+arch=('i686' 'x86_64')
+url="http://www.postgresql.org"
license=('BSD')
-backup=('etc/conf.d/postgresql' '/etc/pam.d/postgresql')
-url="http://www.postgresql.org/"
-depends=("postgresql-libs>=$pkgver" "libxml2")
-options=('!makeflags')
+makedepends=('libxml2' 'python2' 'perl')
source=(ftp://ftp.postgresql.org/pub/source/v${pkgver}/postgresql-${pkgver}.tar.bz2 \
- postgresql postgresql.confd build.patch postgresql.pam)
+ postgresql postgresql.confd build.patch postgresql.pam postgresql.logrotate)
build() {
- cd ${startdir}/src/$pkgname-$pkgver || return 1
+ cd "${srcdir}/${pkgbase}-${pkgver}"
# patch to remove regress/test make target (won't build with it present)
- patch -Np1 -i ../build.patch || return 1
+ patch -Np1 -i ../build.patch
# configure
- ./configure --prefix=/usr --mandir=/usr/share/man \
- --with-docdir=/usr/share/doc --with-openssl \
- --datadir=/usr/share/postgresql --with-pam --with-libxml || return 1
+ ./configure --prefix=/usr --mandir=/usr/share/man --with-libxml \
+ --with-openssl --with-perl \
+ --with-python PYTHON=/usr/bin/python2 --with-pam \
+ --with-system-tzdata=/usr/share/zoneinfo --enable-nls \
+ --datadir=/usr/share/postgresql --enable-thread-safety
- sed -i -e '/interfaces/d' src/Makefile || return 1
+ sed -i -e '/interfaces/d' src/Makefile
# build
- make || return 1
+ make world
+
+ # build libs
+ for dir in src/interfaces src/bin/pg_config; do
+ pushd ${dir}
+ make
+ popd
+ done
+}
- # install
- make DESTDIR=${startdir}/pkg install || return 1
+package_postgresql-libs() {
+ pkgdesc="Libraries for use with PostgreSQL"
+ depends=('openssl>=1.0.0')
- (
- cd contrib/adminpack;
- make || return 1;
- make DESTDIR=${startdir}/pkg install || return 1;
- );
+ cd "${srcdir}/${pkgbase}-${pkgver}"
+ # install license
+ install -D -m644 COPYRIGHT "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- # clean up unneeded installed items
- rm -rf $startdir/pkg/usr/include/postgresql/internal || return 1
- rm -rf $startdir/pkg/usr/include/libpq || return 1
- # the below line is expected to produce an error; fix this one day
- rm -f $startdir/pkg/usr/include/*
- rm -f $startdir/pkg/usr/bin/pg_config || return 1
-
- # Maintaining the lib below because of qt
- #rm -f $startdir/pkg/usr/lib/libpgport.a || return 1
+ # install libs
+ for dir in src/interfaces src/bin/pg_config; do
+ pushd ${dir}
+ make DESTDIR="${pkgdir}" install
+ popd
+ done
- # install launch script
- install -D -m755 ../postgresql $startdir/pkg/etc/rc.d/postgresql \
- || return 1
+ install -D -m644 doc/src/sgml/man1/pg_config.1 "${pkgdir}/usr/share/man/man1/pg_config.1"
+
+ cd src/include
+
+ mkdir -p "${pkgdir}"/usr/include/{libpq,postgresql/internal/libpq}
+
+ # these headers are needed by the public headers of the interfaces
+ install -m644 pg_config.h "${pkgdir}/usr/include/"
+ install -m644 pg_config_os.h "${pkgdir}/usr/include/"
+ install -m644 postgres_ext.h "${pkgdir}/usr/include/"
+ install -m644 libpq/libpq-fs.h "${pkgdir}/usr/include/libpq/"
+ install -m644 pg_config_manual.h "${pkgdir}/usr/include/"
+
+ # these headers are needed by the not-so-public headers of the interfaces
+ install -m644 c.h "${pkgdir}/usr/include/postgresql/internal/"
+ install -m644 port.h "${pkgdir}/usr/include/postgresql/internal/"
+ install -m644 postgres_fe.h "${pkgdir}/usr/include/postgresql/internal/"
+ install -m644 libpq/pqcomm.h "${pkgdir}/usr/include/postgresql/internal/libpq/"
+}
+
+package_postgresql-docs() {
+ pkgdesc="HTML documentation for PostgreSQL"
+ options=(docs)
+
+ cd "${srcdir}/${pkgbase}-${pkgver}"
# install license
- install -D -m644 COPYRIGHT $startdir/pkg/usr/share/licenses/$pkgname/LICENSE || return 1
+ install -D -m644 COPYRIGHT "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+ make -C doc/src/sgml DESTDIR="${pkgdir}" install-html
+ chown -R root:root "${pkgdir}/usr/share/doc/postgresql/html/"
+}
+
+package_postgresql() {
+ pkgdesc="A sophisticated object-relational DBMS"
+ backup=('etc/conf.d/postgresql' 'etc/pam.d/postgresql' 'etc/logrotate.d/postgresql')
+ depends=("postgresql-libs>=${pkgver}" 'libxml2' 'readline>=6.0')
+ optdepends=('python2: for PL/Python support'
+ 'perl: for PL/Perl support')
+ provides=('postgresql-client')
+ conflicts=('postgresql-client')
+
+ cd "${srcdir}/${pkgbase}-${pkgver}"
+
+ # install
+ make DESTDIR="${pkgdir}" install
+ make -C contrib DESTDIR="${pkgdir}" install
+ make -C doc/src/sgml DESTDIR="${pkgdir}" install-man
+ # we don't want this, it is in the -libs package
+ make -C src/bin/pg_config DESTDIR="${pkgdir}" uninstall
+ rm "${pkgdir}/usr/share/man/man1/pg_config.1"
+
+ # install license
+ install -D -m644 COPYRIGHT "${pkgdir}/usr/share/licenses/${pkgbase}/LICENSE"
+
+ # clean up unneeded installed items
+ rm -rf "${pkgdir}/usr/include/postgresql/internal"
+ rm -rf "${pkgdir}/usr/include/libpq"
+ find "${pkgdir}/usr/include" -maxdepth 1 -type f -execdir rm {} +
+
+ # install launch script
+ install -D -m755 "${srcdir}/postgresql" "${pkgdir}/etc/rc.d/postgresql"
# install conf file
- install -D -m644 $startdir/src/postgresql.confd \
- $startdir/pkg/etc/conf.d/postgresql || return 1
+ install -D -m644 ${srcdir}/postgresql.confd \
+ "${pkgdir}/etc/conf.d/postgresql"
- install -D -m644 $startdir/src/postgresql.pam \
- $startdir/pkg/etc/pam.d/postgresql
+ install -D -m644 ${srcdir}/postgresql.pam \
+ "${pkgdir}/etc/pam.d/postgresql"
- chown root:root $startdir/pkg/usr/share/doc/postgresql/html/*
+ install -D -m644 ${srcdir}/postgresql.logrotate \
+ "${pkgdir}/etc/logrotate.d/postgresql"
}
-md5sums=('4f8c67d802bd03b5b844e268bba7d44a'
- '7d8ea2abb6a8cdacf35604bda659a34a'
- 'df6ddf9e2ab4700a3415f17c0f4f4172'
- '4d74f4227dc5e12bf95b3490758d86c9'
- '96f82c38f3f540b53f3e5144900acf17')
-md5sums=('4f8c67d802bd03b5b844e268bba7d44a'
- '7d8ea2abb6a8cdacf35604bda659a34a'
- 'df6ddf9e2ab4700a3415f17c0f4f4172'
+md5sums=('57ba57e43cfe29e16dacbf5789be98d1'
+ '4153ac0ef4a77e709385b0a13e1c0fad'
+ 'd63a05943cf0a2726aa2070f3033c569'
'4d74f4227dc5e12bf95b3490758d86c9'
- '96f82c38f3f540b53f3e5144900acf17')
+ '96f82c38f3f540b53f3e5144900acf17'
+ 'd28e443f9f65a5712c52018b84e27137')
diff --git a/abs/extra/postgresql/postgresql b/abs/extra/postgresql/postgresql
index c6aedfb..b00289e 100755
--- a/abs/extra/postgresql/postgresql
+++ b/abs/extra/postgresql/postgresql
@@ -20,8 +20,8 @@ case "$1" in
stat_done
fi
if [ ! -d $PGROOT ]; then
- mkdir -p $PGROOT/data && chown postgres.postgres $PGROOT/data
- su - postgres -c "/usr/bin/initdb -D $PGROOT/data"
+ mkdir -p $PGROOT/data && chown -R postgres.postgres $PGROOT
+ su - postgres -c "/usr/bin/initdb $INITOPTS -D $PGROOT/data"
fi
if [ ! -e /var/log/postgresql.log ]; then
touch /var/log/postgresql.log
diff --git a/abs/extra/postgresql/postgresql.confd b/abs/extra/postgresql/postgresql.confd
index 7bbf016..5f8fa03 100644
--- a/abs/extra/postgresql/postgresql.confd
+++ b/abs/extra/postgresql/postgresql.confd
@@ -1,4 +1,5 @@
#
# Parameters to be passed to postgresql
#
-PGROOT="/var/lib/postgres" \ No newline at end of file
+PGROOT="/var/lib/postgres"
+INITOPTS="--locale $LANG"
diff --git a/abs/extra/postgresql/postgresql.logrotate b/abs/extra/postgresql/postgresql.logrotate
new file mode 100644
index 0000000..9c36918
--- /dev/null
+++ b/abs/extra/postgresql/postgresql.logrotate
@@ -0,0 +1,4 @@
+/var/log/postgresql.log {
+ copytruncate
+ missingok
+}