summaryrefslogtreecommitdiffstats
path: root/abs/extra/postgresql
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2018-03-02 23:35:59 (GMT)
committerBritney Fransen <brfransen@gmail.com>2018-03-02 23:35:59 (GMT)
commitfd8405efa6e0c17c9e666f5ea8584039f31a5168 (patch)
tree641cafbb31cb0387ac10b0641427d850d15a4b93 /abs/extra/postgresql
parent1577770bf29c22dd1a2e14c055b5af2f1408eb39 (diff)
downloadlinhes_pkgbuild-fd8405efa6e0c17c9e666f5ea8584039f31a5168.zip
linhes_pkgbuild-fd8405efa6e0c17c9e666f5ea8584039f31a5168.tar.gz
linhes_pkgbuild-fd8405efa6e0c17c9e666f5ea8584039f31a5168.tar.bz2
postgresql: update to 10.2
Diffstat (limited to 'abs/extra/postgresql')
-rw-r--r--abs/extra/postgresql/PKGBUILD162
-rwxr-xr-xabs/extra/postgresql/postgresql-check-db-dir49
-rw-r--r--abs/extra/postgresql/postgresql-run-socket.patch12
-rw-r--r--abs/extra/postgresql/postgresql.confd11
-rw-r--r--abs/extra/postgresql/postgresql.install23
-rw-r--r--abs/extra/postgresql/postgresql.logrotate4
-rwxr-xr-xabs/extra/postgresql/postgresql.rcd79
-rw-r--r--abs/extra/postgresql/postgresql.service34
8 files changed, 197 insertions, 177 deletions
diff --git a/abs/extra/postgresql/PKGBUILD b/abs/extra/postgresql/PKGBUILD
index a00160c..c1a35dc 100644
--- a/abs/extra/postgresql/PKGBUILD
+++ b/abs/extra/postgresql/PKGBUILD
@@ -1,86 +1,111 @@
-# $Id: PKGBUILD 160730 2012-06-04 17:58:05Z dan $
+# Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
# Maintainer: Dan McGee <dan@archlinux.org>
pkgbase=postgresql
pkgname=('postgresql-libs' 'postgresql-docs' 'postgresql')
-pkgver=9.1.4
+pkgver=10.2
_majorver=${pkgver%.*}
pkgrel=1
-arch=('i686' 'x86_64')
-url="http://www.postgresql.org/"
+pkgdesc='Sophisticated object-relational DBMS'
+url='https://www.postgresql.org/'
+arch=('x86_64')
license=('custom:PostgreSQL')
-makedepends=('krb5' 'libxml2' 'python2' 'perl' 'tcl' 'openssl>=1.0.0')
-source=(ftp://ftp.postgresql.org/pub/source/v${pkgver}/postgresql-${pkgver}.tar.bz2
- postgresql.rcd postgresql.confd postgresql.pam postgresql.logrotate)
+makedepends=('krb5' 'libxml2' 'python2' 'perl' 'tcl>=8.6.0' 'openssl>=1.0.0' 'pam' 'zlib')
+source=(https://ftp.postgresql.org/pub/source/v${pkgver}/postgresql-${pkgver}.tar.bz2
+ postgresql-run-socket.patch
+ postgresql.pam
+ postgresql.logrotate
+ postgresql.service
+ postgresql-check-db-dir)
+sha256sums=('fe32009b62ddb97f7f014307ce9d0edb6972f5a698e63cb531088e147d145bad'
+ '8538619cb8bea51078b605ad64fe22abd6050373c7ae3ad6595178da52f6a7d9'
+ '57dfd072fd7ef0018c6b0a798367aac1abb5979060ff3f9df22d1048bb71c0d5'
+ '6abb842764bbed74ea4a269d24f1e73d1c0b1d8ecd6e2e6fb5fb10590298605e'
+ 'b48fe97f8e43ed0d2041d519119a4dafb70fcae72870951bf4fb7350fe169ac8'
+ '888a1d44f03fccfa4bf344ee45824fefb846ae3c1c0c40113ad6020b4be3b0cf')
+sha512sums=('bac61644c12c31e2dce97ec0134902a2a7141e922619015425961b963961b21210ca840f59ba585d3d75c7e34cb640f2ebeaa2b25c4a866db68f5e73a8f8a448'
+ '031efe12d18ce386989062327cdbbe611c5ef1f94e4e1bead502304cb3e2d410af533d3c7f1109d24f9da9708214fe32f9a10ba373a3ca8d507bdb521fbb75f7'
+ '1e6183ab0eb812b3ef687ac2c26ce78f7cb30540f606d20023669ac00ba04075487fb72e4dc89cc05dab0269ff6aca98fc1167cc75669c225b88b592482fbf67'
+ '9ab4da01337ffbab8faec0e220aaa2a642dbfeccf7232ef2645bdc2177a953f17ee3cc14a4d8f8ebd064e1dae8b3dba6029adbffb8afaabea383963213941ba8'
+ 'ec2625c3ccfb6c142ea12ef4392b00f3d4cb0a5411d603b98157d55cd162ed3b422dbbd42e8b13211063db94a42f6d1f3febd4acaadde69ea17bfd8eccae3539'
+ '56974ef34a8d94596068413154b1a7ed5a71f5a3942bd79427f05e6f6b7853036874dedd8d988bb94306023f2a675996d500b075eaf8a192ef5c24026eb28eb0')
+
+prepare() {
+ cd postgresql-${pkgver}
+ patch -p1 < ../postgresql-run-socket.patch
+}
build() {
- cd "${srcdir}/postgresql-${pkgver}"
-
- ./configure --prefix=/usr \
- --mandir=/usr/share/man \
- --datadir=/usr/share/postgresql \
- --with-krb5 \
- --with-libxml \
- --with-openssl \
- --with-perl \
- --with-python PYTHON=/usr/bin/python2 \
- --with-tcl \
- --with-pam \
- --with-system-tzdata=/usr/share/zoneinfo \
- --enable-nls \
- --enable-thread-safety
-
+ cd postgresql-${pkgver}
+ ./configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --datadir=/usr/share/postgresql \
+ --sysconfdir=/etc \
+ --with-gssapi \
+ --with-libxml \
+ --with-openssl \
+ --with-perl \
+ --with-python PYTHON=/usr/bin/python2 \
+ --with-tcl \
+ --with-pam \
+ --with-system-tzdata=/usr/share/zoneinfo \
+ --with-uuid=e2fs \
+ --enable-nls \
+ --enable-thread-safety
make world
}
package_postgresql-libs() {
pkgdesc="Libraries for use with PostgreSQL"
- depends=('krb5' 'openssl>=1.0.0' 'readline>=6.0')
+ depends=('krb5' 'openssl>=1.0.0' 'readline>=6.0' 'zlib')
provides=('postgresql-client')
conflicts=('postgresql-client')
- cd "${srcdir}/postgresql-${pkgver}"
+ cd postgresql-${pkgver}
# install license
- install -D -m644 COPYRIGHT "${pkgdir}/usr/share/licenses/postgresql-libs/LICENSE"
+ install -Dm 644 COPYRIGHT -t "${pkgdir}/usr/share/licenses/${pkgname}"
- # install libs
- for dir in src/interfaces src/bin/pg_config src/bin/psql; do
+ # install libs and non-server binaries
+ for dir in src/interfaces src/bin/pg_config src/bin/pg_dump src/bin/psql src/bin/scripts; do
make -C ${dir} DESTDIR="${pkgdir}" install
done
- install -D -m644 doc/src/sgml/man1/pg_config.1 "${pkgdir}/usr/share/man/man1/pg_config.1"
- install -D -m644 doc/src/sgml/man1/psql.1 "${pkgdir}/usr/share/man/man1/psql.1"
+ for util in pg_config pg_dump pg_dumpall pg_restore psql \
+ clusterdb createdb createuser dropdb dropuser pg_isready reindexdb vacuumdb; do
+ install -Dm 644 doc/src/sgml/man1/${util}.1 "${pkgdir}"/usr/share/man/man1/${util}.1
+ done
cd src/include
mkdir -p "${pkgdir}"/usr/include/{libpq,postgresql/internal/libpq}
# these headers are needed by the public headers of the interfaces
- install -m644 pg_config.h "${pkgdir}/usr/include/"
- install -m644 pg_config_os.h "${pkgdir}/usr/include/"
- install -m644 postgres_ext.h "${pkgdir}/usr/include/"
- install -m644 libpq/libpq-fs.h "${pkgdir}/usr/include/libpq/"
- install -m644 pg_config_manual.h "${pkgdir}/usr/include/"
-
- # these headers are needed by the not-so-public headers of the interfaces
- install -m644 c.h "${pkgdir}/usr/include/postgresql/internal/"
- install -m644 port.h "${pkgdir}/usr/include/postgresql/internal/"
- install -m644 postgres_fe.h "${pkgdir}/usr/include/postgresql/internal/"
- install -m644 libpq/pqcomm.h "${pkgdir}/usr/include/postgresql/internal/libpq/"
+ install -m 644 pg_config.h "${pkgdir}/usr/include"
+ install -m 644 pg_config_os.h "${pkgdir}/usr/include"
+ install -m 644 pg_config_ext.h "${pkgdir}/usr/include"
+ install -m 644 postgres_ext.h "${pkgdir}/usr/include"
+ install -m 644 libpq/libpq-fs.h "${pkgdir}/usr/include/libpq"
+ install -m 644 pg_config_manual.h "${pkgdir}/usr/include"
+
+ # these he aders are needed by the not-so-public headers of the interfaces
+ install -m 644 c.h "${pkgdir}/usr/include/postgresql/internal"
+ install -m 644 port.h "${pkgdir}/usr/include/postgresql/internal"
+ install -m 644 postgres_fe.h "${pkgdir}/usr/include/postgresql/internal"
+ install -m 644 libpq/pqcomm.h "${pkgdir}/usr/include/postgresql/internal/libpq"
}
package_postgresql-docs() {
pkgdesc="HTML documentation for PostgreSQL"
- options=(docs)
+ options=('docs')
- cd "${srcdir}/postgresql-${pkgver}"
+ cd postgresql-${pkgver}
- # install license
- install -D -m644 COPYRIGHT "${pkgdir}/usr/share/licenses/postgresql-docs/LICENSE"
+ install -Dm 644 COPYRIGHT -t "${pkgdir}/usr/share/licenses/${pkgname}"
make -C doc/src/sgml DESTDIR="${pkgdir}" install-html
- chown -R root:root "${pkgdir}/usr/share/doc/postgresql/html/"
+ chown -R root:root "${pkgdir}/usr/share/doc/postgresql/html"
# clean up
rmdir "${pkgdir}"/usr/share/man/man{1,3,7}
@@ -88,16 +113,17 @@ package_postgresql-docs() {
}
package_postgresql() {
- pkgdesc="A sophisticated object-relational DBMS"
- backup=('etc/conf.d/postgresql' 'etc/pam.d/postgresql' 'etc/logrotate.d/postgresql')
- depends=("postgresql-libs>=${pkgver}" 'krb5' 'libxml2' 'readline>=6.0' 'openssl>=1.0.0')
+ pkgdesc='Sophisticated object-relational DBMS'
+ backup=('etc/pam.d/postgresql' 'etc/logrotate.d/postgresql')
+ depends=("postgresql-libs>=${pkgver}" 'krb5' 'libxml2' 'readline>=6.0' 'openssl>=1.0.0' 'pam')
optdepends=('python2: for PL/Python support'
'perl: for PL/Perl support'
'tcl: for PL/Tcl support'
'postgresql-old-upgrade: upgrade from previous major version using pg_upgrade')
+ options=('staticlibs')
install=postgresql.install
- cd "${srcdir}/postgresql-${pkgver}"
+ cd postgresql-${pkgver}
# install
make DESTDIR="${pkgdir}" install
@@ -105,14 +131,16 @@ package_postgresql() {
make -C doc/src/sgml DESTDIR="${pkgdir}" install-man
# we don't want these, they are in the -libs package
- for dir in src/interfaces src/bin/pg_config src/bin/psql; do
+ for dir in src/interfaces src/bin/pg_config src/bin/pg_dump src/bin/psql src/bin/scripts; do
make -C ${dir} DESTDIR="${pkgdir}" uninstall
done
- rm "${pkgdir}/usr/share/man/man1/pg_config.1"
- rm "${pkgdir}/usr/share/man/man1/psql.1"
+ for util in pg_config pg_dump pg_dumpall pg_restore psql \
+ clusterdb createdb createuser dropdb dropuser pg_isready reindexdb vacuumdb; do
+ rm "${pkgdir}"/usr/share/man/man1/${util}.1
+ done
# install license
- install -D -m644 COPYRIGHT "${pkgdir}/usr/share/licenses/${pkgbase}/LICENSE"
+ install -Dm 644 COPYRIGHT -t "${pkgdir}/usr/share/licenses/${pkgname}"
# clean up unneeded installed items
rm -rf "${pkgdir}/usr/include/postgresql/internal"
@@ -120,27 +148,11 @@ package_postgresql() {
find "${pkgdir}/usr/include" -maxdepth 1 -type f -execdir rm {} +
rmdir "${pkgdir}/usr/share/doc/postgresql/html"
- # install launch script
- install -D -m755 "${srcdir}/postgresql.rcd" "${pkgdir}/etc/rc.d/postgresql"
-
- # install conf file
- install -D -m644 ${srcdir}/postgresql.confd \
- "${pkgdir}/etc/conf.d/postgresql"
+ install -Dm 644 "${srcdir}/postgresql.service" -t "${pkgdir}/usr/lib/systemd/system"
+ install -Dm 755 "${srcdir}/postgresql-check-db-dir" -t "${pkgdir}/usr/bin"
- install -D -m644 ${srcdir}/postgresql.pam \
- "${pkgdir}/etc/pam.d/postgresql"
-
- install -D -m644 ${srcdir}/postgresql.logrotate \
- "${pkgdir}/etc/logrotate.d/postgresql"
+ install -Dm 644 "${srcdir}/postgresql.pam" "${pkgdir}/etc/pam.d/postgresql"
+ install -Dm 644 "${srcdir}/postgresql.logrotate" "${pkgdir}/etc/logrotate.d/postgresql"
}
-md5sums=('a8035688dba988b782725ac1aec60186'
- '1ddd1df8010549f237e7983bb326025e'
- 'a54d09a20ab1672adf08f037df188d53'
- '96f82c38f3f540b53f3e5144900acf17'
- 'd28e443f9f65a5712c52018b84e27137')
-sha256sums=('a0795a8eb3ae2d1a2914b63bf143d20182835d90699915ff43567c041d3c9712'
- '9f6307b1358892e304f9474a456f0cb9160cfb8812a9da0430abe647f8a9cf45'
- '3de5c059eead8816db15c2c5588e6196d6c4b0d704faf1a20912796cf589ba81'
- '57dfd072fd7ef0018c6b0a798367aac1abb5979060ff3f9df22d1048bb71c0d5'
- '6abb842764bbed74ea4a269d24f1e73d1c0b1d8ecd6e2e6fb5fb10590298605e')
+# vim: ts=2 sw=2 et:
diff --git a/abs/extra/postgresql/postgresql-check-db-dir b/abs/extra/postgresql/postgresql-check-db-dir
new file mode 100755
index 0000000..acf73eb
--- /dev/null
+++ b/abs/extra/postgresql/postgresql-check-db-dir
@@ -0,0 +1,49 @@
+#!/bin/sh
+
+# This script verifies that the postgresql data directory has been correctly
+# initialized. We do not want to automatically initdb it, because that has
+# a risk of catastrophic failure (ie, overwriting a valuable database) in
+# corner cases, such as a remotely mounted database on a volume that's a
+# bit slow to mount. But we can at least emit a message advising newbies
+# what to do.
+
+PGDATA="$1"
+
+if [ -z "$PGDATA" ]
+then
+ echo "Usage: $0 database-path"
+ exit 1
+fi
+
+# PGMAJORVERSION is major version
+PGMAJORVERSION=10
+# PREVMAJORVERSION is the previous major version
+PREVMAJORVERSION=9.6
+
+# Check for the PGDATA structure
+if [ -f "$PGDATA/PG_VERSION" ] && [ -d "$PGDATA/base" ]
+then
+ # Check version of existing PGDATA
+ if [ x`cat "$PGDATA/PG_VERSION"` = x"$PGMAJORVERSION" ]
+ then
+ : A-OK
+ elif [ x`cat "$PGDATA/PG_VERSION"` = x"$PREVMAJORVERSION" ]
+ then
+ echo $"An old version of the database format was found."
+ echo $"See https://wiki.archlinux.org/index.php/PostgreSQL#Upgrading_PostgreSQL"
+ exit 1
+ else
+ echo $"An old version of the database format was found."
+ echo $"You need to dump and reload before using PostgreSQL $PGMAJORVERSION."
+ echo $"See http://www.postgresql.org/docs/$PGMAJORVERSION/static/upgrading.html"
+ exit 1
+ fi
+else
+ # No existing PGDATA! Warn the user to initdb it.
+ echo $"\"$PGDATA\" is missing or empty. Use a command like"
+ echo $" su - postgres -c \"initdb --locale en_US.UTF-8 -D '$PGDATA'\""
+ echo $"with relevant options, to initialize the database cluster."
+ exit 1
+fi
+
+exit 0
diff --git a/abs/extra/postgresql/postgresql-run-socket.patch b/abs/extra/postgresql/postgresql-run-socket.patch
new file mode 100644
index 0000000..b558c7b
--- /dev/null
+++ b/abs/extra/postgresql/postgresql-run-socket.patch
@@ -0,0 +1,12 @@
+diff -Naur postgresql-9.2.0.sockets/src/include/pg_config_manual.h postgresql-9.2.0/src/include/pg_config_manual.h
+--- postgresql-9.2.0.sockets/src/include/pg_config_manual.h 2012-09-06 17:26:17.000000000 -0400
++++ postgresql-9.2.0/src/include/pg_config_manual.h 2012-09-06 18:13:18.183092471 -0400
+@@ -144,7 +144,7 @@
+ * here's where to twiddle it. You can also override this at runtime
+ * with the postmaster's -k switch.
+ */
+-#define DEFAULT_PGSOCKET_DIR "/tmp"
++#define DEFAULT_PGSOCKET_DIR "/run/postgresql"
+
+ /*
+ * The random() function is expected to yield values between 0 and
diff --git a/abs/extra/postgresql/postgresql.confd b/abs/extra/postgresql/postgresql.confd
deleted file mode 100644
index 6001c16..0000000
--- a/abs/extra/postgresql/postgresql.confd
+++ /dev/null
@@ -1,11 +0,0 @@
-##
-## Parameters to be passed to postgresql
-##
-## Default data directory location
-#PGROOT="/var/lib/postgres"
-## Passed to initdb if necessary
-INITOPTS="--locale en_US.UTF-8"
-## Default log file location
-#PGLOG="/var/log/postgresql.log"
-## Additional options to pass via pg_ctl's '-o' option
-#PGOPTS=""
diff --git a/abs/extra/postgresql/postgresql.install b/abs/extra/postgresql/postgresql.install
index c524322..0d23d47 100644
--- a/abs/extra/postgresql/postgresql.install
+++ b/abs/extra/postgresql/postgresql.install
@@ -2,9 +2,17 @@ post_install() {
if [ ! -d '/var/lib/postgres' ]; then
mkdir -p '/var/lib/postgres'
fi
- getent group postgres >/dev/null || groupadd -g 88 postgres
- getent passwd postgres >/dev/null || useradd -c 'PostgreSQL user' -u 88 -g postgres -d '/var/lib/postgres' -s /bin/bash postgres
- passwd -l postgres >/dev/null
+ if ! getent group postgres >/dev/null; then
+ groupadd -g 88 postgres
+ fi
+ if ! getent passwd postgres >/dev/null; then
+ useradd -c 'PostgreSQL user' -u 88 -g postgres -d '/var/lib/postgres' -s /bin/bash postgres
+ passwd -l postgres >/dev/null
+ fi
+ if [ ! -d '/var/lib/postgres/data' ]; then
+ mkdir -p '/var/lib/postgres/data'
+ chown postgres:postgres '/var/lib/postgres/data'
+ fi
}
post_upgrade() {
@@ -15,12 +23,3 @@ post_upgrade() {
chsh -s /bin/bash postgres
fi
}
-
-post_remove() {
- if getent passwd postgres >/dev/null; then
- userdel postgres
- fi
- if getent group postgres >/dev/null; then
- groupdel postgres
- fi
-}
diff --git a/abs/extra/postgresql/postgresql.logrotate b/abs/extra/postgresql/postgresql.logrotate
new file mode 100644
index 0000000..9c36918
--- /dev/null
+++ b/abs/extra/postgresql/postgresql.logrotate
@@ -0,0 +1,4 @@
+/var/log/postgresql.log {
+ copytruncate
+ missingok
+}
diff --git a/abs/extra/postgresql/postgresql.rcd b/abs/extra/postgresql/postgresql.rcd
deleted file mode 100755
index f3600b3..0000000
--- a/abs/extra/postgresql/postgresql.rcd
+++ /dev/null
@@ -1,79 +0,0 @@
-#!/bin/bash
-
-. /etc/rc.conf
-. /etc/rc.d/functions
-. /etc/conf.d/postgresql
-
-# Default PGROOT if it wasn't defined in the conf.d file
-PGROOT=${PGROOT:-/var/lib/postgres}
-PGLOG=${PGLOG:-/var/log/postgresql.log}
-PGCTL_BIN=/usr/bin/pg_ctl
-PGCTL_ARGS=(-D "$PGROOT/data" -l "$PGLOG" -s -w)
-[[ $PGOPTS ]] && PGCTL_ARGS+=(-o "$PGOPTS")
-
-postgres_init() {
- # initialization
- if [[ ! -d "$PGROOT/data" ]]; then
- mkdir -p "$PGROOT/data" && chown -R postgres:postgres "$PGROOT"
- su - postgres -c "/usr/bin/initdb $INITOPTS -D '$PGROOT/data'"
- fi
- if [[ ! -e "$PGLOG" ]]; then
- touch "$PGLOG"
- chown postgres "$PGLOG"
- fi
-}
-
-do_postgres() {
- su - postgres -c "'$PGCTL_BIN' $(printf '%q ' "${PGCTL_ARGS[@]}" "$@")"
-}
-
-case $1 in
- start)
- postgres_init
- stat_busy "Starting PostgreSQL"
- if do_postgres start; then
- add_daemon postgresql
- stat_done
- else
- stat_fail
- exit 1
- fi
- ;;
- stop)
- stat_busy "Stopping PostgreSQL"
- if do_postgres stop -m fast; then
- rm_daemon postgresql
- stat_done
- else
- stat_fail
- exit 1
- fi
- ;;
- reload)
- stat_busy "Reloading PostgreSQL"
- if do_postgres reload; then
- stat_done
- else
- stat_fail
- exit 1
- fi
- ;;
- restart)
- postgres_init
- stat_busy "Restarting PostgreSQL"
- if do_postgres restart -m fast; then
- add_daemon postgresql
- stat_done
- else
- stat_fail
- exit 1
- fi
- ;;
- status)
- stat_busy "Checking PostgreSQL status";
- ck_status postgresql
- ;;
- *)
- echo "usage: $0 {start|stop|reload|restart|status}"
- exit 1
-esac
diff --git a/abs/extra/postgresql/postgresql.service b/abs/extra/postgresql/postgresql.service
new file mode 100644
index 0000000..37fcae9
--- /dev/null
+++ b/abs/extra/postgresql/postgresql.service
@@ -0,0 +1,34 @@
+[Unit]
+Description=PostgreSQL database server
+After=network.target
+
+[Service]
+Type=forking
+TimeoutSec=120
+User=postgres
+Group=postgres
+
+Environment=PGROOT=/var/lib/postgres
+
+SyslogIdentifier=postgres
+PIDFile=/var/lib/postgres/data/postmaster.pid
+RuntimeDirectory=postgresql
+RuntimeDirectoryMode=755
+
+ExecStartPre=/usr/bin/postgresql-check-db-dir ${PGROOT}/data
+ExecStart= /usr/bin/pg_ctl -s -D ${PGROOT}/data start -w -t 120
+ExecReload=/usr/bin/pg_ctl -s -D ${PGROOT}/data reload
+ExecStop= /usr/bin/pg_ctl -s -D ${PGROOT}/data stop -m fast
+
+# Due to PostgreSQL's use of shared memory, OOM killer is often overzealous in
+# killing Postgres, so adjust it downward
+OOMScoreAdjust=-200
+
+# Additional security-related features
+PrivateTmp=true
+ProtectHome=true
+ProtectSystem=full
+NoNewPrivileges=true
+
+[Install]
+WantedBy=multi-user.target