summaryrefslogtreecommitdiffstats
path: root/abs/extra/presentproto
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2014-04-06 00:24:29 (GMT)
committerBritney Fransen <brfransen@gmail.com>2014-04-06 00:24:29 (GMT)
commitf27f10c676f4e212ce4001959b240551203502c9 (patch)
tree5227f2e86127d537571e11657de1295beb4d95c4 /abs/extra/presentproto
parent666d9ffbfd0244bfda3fddd9841a2749f26a979b (diff)
downloadlinhes_pkgbuild-f27f10c676f4e212ce4001959b240551203502c9.zip
linhes_pkgbuild-f27f10c676f4e212ce4001959b240551203502c9.tar.gz
linhes_pkgbuild-f27f10c676f4e212ce4001959b240551203502c9.tar.bz2
presentproto: initial inclusion. dep of mesa. refs #964
Diffstat (limited to 'abs/extra/presentproto')
-rw-r--r--abs/extra/presentproto/COPYING21
-rw-r--r--abs/extra/presentproto/PKGBUILD30
2 files changed, 51 insertions, 0 deletions
diff --git a/abs/extra/presentproto/COPYING b/abs/extra/presentproto/COPYING
new file mode 100644
index 0000000..313c8f1
--- /dev/null
+++ b/abs/extra/presentproto/COPYING
@@ -0,0 +1,21 @@
+/*
+ * Copyright © 2013 Keith Packard
+ *
+ * Permission to use, copy, modify, distribute, and sell this software and its
+ * documentation for any purpose is hereby granted without fee, provided that
+ * the above copyright notice appear in all copies and that both that copyright
+ * notice and this permission notice appear in supporting documentation, and
+ * that the name of the copyright holders not be used in advertising or
+ * publicity pertaining to distribution of the software without specific,
+ * written prior permission. The copyright holders make no representations
+ * about the suitability of this software for any purpose. It is provided "as
+ * is" without express or implied warranty.
+ *
+ * THE COPYRIGHT HOLDERS DISCLAIM ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
+ * INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO
+ * EVENT SHALL THE COPYRIGHT HOLDERS BE LIABLE FOR ANY SPECIAL, INDIRECT OR
+ * CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE,
+ * DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER
+ * TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE
+ * OF THIS SOFTWARE.
+ */
diff --git a/abs/extra/presentproto/PKGBUILD b/abs/extra/presentproto/PKGBUILD
new file mode 100644
index 0000000..53597f8
--- /dev/null
+++ b/abs/extra/presentproto/PKGBUILD
@@ -0,0 +1,30 @@
+# $Id$
+# Maintainer: AndyRTR <andyrtr@archlinux.org>
+
+pkgname=presentproto
+pkgver=1.0
+pkgrel=1
+pkgdesc="X11 Present protocol specification"
+arch=('any')
+url="http://xorg.freedesktop.org/"
+license=('custom')
+source=(${url}/releases/individual/proto/${pkgname}-${pkgver}.tar.bz2
+ COPYING)
+sha256sums=('812c7d48721f909a0f7a2cb1e91f6eead76159a36c4712f4579ca587552839ce'
+ '5e46864ede2fda46c3cb7cfe3a7b9f9e4bd36d8d21d8010a284caa64b81d465a')
+
+build() {
+ cd $pkgname-$pkgver
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd $pkgname-$pkgver
+ make DESTDIR="$pkgdir/" install
+
+ # license is still missing
+ # COPYING is taken from top of /usr/include/X11/extensions/presentproto.h
+ install -m755 -d "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -m644 ${srcdir}/COPYING "${pkgdir}/usr/share/licenses/${pkgname}/"
+}