summaryrefslogtreecommitdiffstats
path: root/abs/extra/psutils/PKGBUILD
diff options
context:
space:
mode:
authorMichael Hanson <hansonorders@verizon.net>2010-11-30 23:36:05 (GMT)
committerMichael Hanson <hansonorders@verizon.net>2010-11-30 23:36:05 (GMT)
commit470bbda731faf409041f07225bd6fb02aa0ce21c (patch)
tree02a13aac33a8ecb7ddfe70ec60a5caff1302ee1b /abs/extra/psutils/PKGBUILD
parent7329cbbfcc175fd295e9713e866259f4b7bd4fdf (diff)
downloadlinhes_pkgbuild-470bbda731faf409041f07225bd6fb02aa0ce21c.zip
linhes_pkgbuild-470bbda731faf409041f07225bd6fb02aa0ce21c.tar.gz
linhes_pkgbuild-470bbda731faf409041f07225bd6fb02aa0ce21c.tar.bz2
psutils: dep for groff
Diffstat (limited to 'abs/extra/psutils/PKGBUILD')
-rw-r--r--abs/extra/psutils/PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/abs/extra/psutils/PKGBUILD b/abs/extra/psutils/PKGBUILD
new file mode 100644
index 0000000..b8dab78
--- /dev/null
+++ b/abs/extra/psutils/PKGBUILD
@@ -0,0 +1,33 @@
+# $Id: PKGBUILD 49744 2009-08-15 14:42:41Z jgc $
+# Maintainer: eric <eric@archlinux.org>
+# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
+
+pkgname=psutils
+pkgver=1.17
+pkgrel=2
+pkgdesc="A set of postscript utilities"
+arch=('i686' 'x86_64')
+license=('custom')
+depends=('glibc' 'ghostscript')
+provides=('psutils-lprng')
+replaces=('psutils-lprng')
+url="http://www.tardis.ed.ac.uk/~ajcd/psutils/index.html"
+source=(ftp://ftp.enst.fr/pub/unix/a2ps/${pkgname}-${pkgver}.tar.gz
+ psutils-1.17.diff)
+md5sums=('b161522f3bd1507655326afa7db4a0ad'
+ '2b49e9e796000b42f42804d4b50a2be1')
+
+build() {
+ cd "${srcdir}/${pkgname}"
+ patch -Np1 -i "${srcdir}/psutils-1.17.diff" || return 1
+ install -d -m755 "${pkgdir}/usr/include"
+ install -d -m755 "${pkgdir}/usr/share/man"
+ make -j1 -f Makefile.unix BINDIR="${pkgdir}/usr/bin" \
+ INCLUDEDIR="${pkgdir}/usr/include/psutils" PERL=/usr/bin/perl \
+ MANDIR="${pkgdir}/usr/share/man/man1" || return 1
+ make -j1 -f Makefile.unix BINDIR="${pkgdir}/usr/bin" \
+ INCLUDEDIR="${pkgdir}/usr/include/psutils" PERL=/usr/bin/perl \
+ MANDIR="${pkgdir}/usr/share/man/man1" install || return 1
+ install -m755 -d "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/" || return 1
+}