summaryrefslogtreecommitdiffstats
path: root/abs/extra/pyqt/PKGBUILD
diff options
context:
space:
mode:
authorMichael Hanson <hansonorders@verizon.net>2010-12-10 00:19:00 (GMT)
committerMichael Hanson <hansonorders@verizon.net>2010-12-10 00:19:00 (GMT)
commit5ab2c2d585290fb77dfc8d3670361df2fdc11c62 (patch)
tree58fc24f3a355bff701d6e93ba8011e9d1764f7b9 /abs/extra/pyqt/PKGBUILD
parent4592612b015ff899ef52f33d96b52b5c60587ebb (diff)
downloadlinhes_pkgbuild-5ab2c2d585290fb77dfc8d3670361df2fdc11c62.zip
linhes_pkgbuild-5ab2c2d585290fb77dfc8d3670361df2fdc11c62.tar.gz
linhes_pkgbuild-5ab2c2d585290fb77dfc8d3670361df2fdc11c62.tar.bz2
A whole lotta housekeeping
Diffstat (limited to 'abs/extra/pyqt/PKGBUILD')
-rw-r--r--abs/extra/pyqt/PKGBUILD44
1 files changed, 0 insertions, 44 deletions
diff --git a/abs/extra/pyqt/PKGBUILD b/abs/extra/pyqt/PKGBUILD
deleted file mode 100644
index af3667c..0000000
--- a/abs/extra/pyqt/PKGBUILD
+++ /dev/null
@@ -1,44 +0,0 @@
-# $Id: PKGBUILD 97705 2010-11-01 13:35:29Z andrea $
-# Maintainer: Andrea Scarpino <andrea@archlinux.org>
-# Contributor: Douglas Soares de Andrade <douglas@archlinux.org>
-# Contributor: riai <riai@bigfoot.com> Ben <ben@benmazer.net>
-
-pkgname=pyqt
-pkgver=4.8.1
-pkgrel=1
-pkgdesc="A set of Python bindings for the Qt toolkit"
-arch=('i686' 'x86_64')
-url="http://riverbankcomputing.co.uk/software/pyqt/intro"
-license=('GPL')
-depends=('sip' 'qt' 'dbus-python')
-makedepends=('phonon' 'python-opengl' 'qt-assistant-compat')
-optdepends=('phonon: enable audio and video in PyQt applications'
- 'python-opengl: enable OpenGL 3D graphics in PyQt applications'
- 'qscintilla: QScintilla API'
- 'qt-assistant-compat: add PyQt online help in Qt Assistant')
-provides=('pyqt4')
-replaces=('pyqt4')
-conflicts=('pyqt4')
-source=("http://riverbankcomputing.co.uk/static/Downloads/PyQt4/PyQt-x11-gpl-${pkgver}.tar.gz")
-md5sums=('1cac8f5d715c414f9cb2751b0e84cc07')
-
-build() {
- cd ${srcdir}/PyQt-x11-gpl-${pkgver}
-
- python2 configure.py \
- --confirm-license \
- -v /usr/share/sip \
- --qsci-api
-
- # Thanks Gerardo for the rpath fix
- find -name 'Makefile' | xargs sed -i 's|-Wl,-rpath,/usr/lib||g;s|-Wl,-rpath,.* ||g'
-
- make
-}
-
-package(){
- cd ${srcdir}/PyQt-x11-gpl-${pkgver}
- # INSTALL_ROOT is needed for the QtDesigner module, the other Makefiles use DESTDIR
- make DESTDIR="${pkgdir}" INSTALL_ROOT="${pkgdir}" install
-}
-