summaryrefslogtreecommitdiffstats
path: root/abs/extra/pyqt
diff options
context:
space:
mode:
authorMichael Hanson <hansonorders@verizon.net>2010-11-18 03:29:06 (GMT)
committerMichael Hanson <hansonorders@verizon.net>2010-11-18 03:29:06 (GMT)
commit9b76695227d83746d43f6db6b0a84c7b439faa17 (patch)
tree7678daec58c290791d6f7f5165255f532c7dc43b /abs/extra/pyqt
parent2fd95b3811f60fec980cdadd52b5cbeeb15687a2 (diff)
downloadlinhes_pkgbuild-9b76695227d83746d43f6db6b0a84c7b439faa17.zip
linhes_pkgbuild-9b76695227d83746d43f6db6b0a84c7b439faa17.tar.gz
linhes_pkgbuild-9b76695227d83746d43f6db6b0a84c7b439faa17.tar.bz2
pyqt: update
Diffstat (limited to 'abs/extra/pyqt')
-rw-r--r--abs/extra/pyqt/PKGBUILD40
1 files changed, 27 insertions, 13 deletions
diff --git a/abs/extra/pyqt/PKGBUILD b/abs/extra/pyqt/PKGBUILD
index f6645c7..af3667c 100644
--- a/abs/extra/pyqt/PKGBUILD
+++ b/abs/extra/pyqt/PKGBUILD
@@ -1,30 +1,44 @@
-# $Id: PKGBUILD 47994 2009-07-30 10:33:54Z pierre $
-# Maintainer: Douglas Soares de Andrade <douglas@archlinux.org>
+# $Id: PKGBUILD 97705 2010-11-01 13:35:29Z andrea $
+# Maintainer: Andrea Scarpino <andrea@archlinux.org>
+# Contributor: Douglas Soares de Andrade <douglas@archlinux.org>
# Contributor: riai <riai@bigfoot.com> Ben <ben@benmazer.net>
pkgname=pyqt
-pkgver=4.6
+pkgver=4.8.1
pkgrel=1
-pkgdesc="A set of Python bindings for the Qt toolkit."
-arch=(i686 x86_64)
+pkgdesc="A set of Python bindings for the Qt toolkit"
+arch=('i686' 'x86_64')
url="http://riverbankcomputing.co.uk/software/pyqt/intro"
-depends=('sip>=4.8.2' 'qscintilla>=2.4.0' 'qt>=4.5.2' 'dbus-python' 'openssl')
license=('GPL')
+depends=('sip' 'qt' 'dbus-python')
+makedepends=('phonon' 'python-opengl' 'qt-assistant-compat')
+optdepends=('phonon: enable audio and video in PyQt applications'
+ 'python-opengl: enable OpenGL 3D graphics in PyQt applications'
+ 'qscintilla: QScintilla API'
+ 'qt-assistant-compat: add PyQt online help in Qt Assistant')
provides=('pyqt4')
replaces=('pyqt4')
conflicts=('pyqt4')
-source=(http://riverbankcomputing.com/static/Downloads/PyQt4/PyQt-x11-gpl-$pkgver.tar.gz)
+source=("http://riverbankcomputing.co.uk/static/Downloads/PyQt4/PyQt-x11-gpl-${pkgver}.tar.gz")
+md5sums=('1cac8f5d715c414f9cb2751b0e84cc07')
build() {
cd ${srcdir}/PyQt-x11-gpl-${pkgver}
- python configure.py --confirm-license -b /usr/bin \
- -d /usr/lib/python2.6/site-packages \
- -v /usr/share/sip
+ python2 configure.py \
+ --confirm-license \
+ -v /usr/share/sip \
+ --qsci-api
# Thanks Gerardo for the rpath fix
find -name 'Makefile' | xargs sed -i 's|-Wl,-rpath,/usr/lib||g;s|-Wl,-rpath,.* ||g'
- make || return 1
- make DESTDIR=${pkgdir} install
-}
+ make
+}
+
+package(){
+ cd ${srcdir}/PyQt-x11-gpl-${pkgver}
+ # INSTALL_ROOT is needed for the QtDesigner module, the other Makefiles use DESTDIR
+ make DESTDIR="${pkgdir}" INSTALL_ROOT="${pkgdir}" install
+}
+