summaryrefslogtreecommitdiffstats
path: root/abs/extra/python-oauth
diff options
context:
space:
mode:
authorMichael Hanson <hansonorders@verizon.net>2010-11-06 03:46:33 (GMT)
committerMichael Hanson <hansonorders@verizon.net>2010-11-06 03:46:33 (GMT)
commitebe6272e2542b76f6cf1ba5e0277642b617001c9 (patch)
treec5e3861f702cd2dccf44ef881540dc4cf7cdd22a /abs/extra/python-oauth
parent30885cc82957847909bd79855763cccf4c5b9f42 (diff)
downloadlinhes_pkgbuild-ebe6272e2542b76f6cf1ba5e0277642b617001c9.zip
linhes_pkgbuild-ebe6272e2542b76f6cf1ba5e0277642b617001c9.tar.gz
linhes_pkgbuild-ebe6272e2542b76f6cf1ba5e0277642b617001c9.tar.bz2
python-oauth: initial include
Diffstat (limited to 'abs/extra/python-oauth')
-rw-r--r--abs/extra/python-oauth/PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/abs/extra/python-oauth/PKGBUILD b/abs/extra/python-oauth/PKGBUILD
new file mode 100644
index 0000000..ca5493a
--- /dev/null
+++ b/abs/extra/python-oauth/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Snowknight (hopkinsth@gmail.com)
+pkgname=python-oauth
+pkgver=1.0.1
+pkgrel=3
+pkgdesc="An open protocol to allow API authentication in a simple and standard method from desktop and web applications."
+arch=('any')
+url="http://code.google.com/p/oauth/"
+license=('MIT')
+depends=('python2')
+makedepends=('python2-distribute')
+source=(http://pypi.python.org/packages/source/o/oauth/oauth-${pkgver}.tar.gz)
+md5sums=('30ed3cc8c11d7841a89feab437aabf81')
+sha1sums=('b2d7609e4852b33d0d33f0bc6ae5cab8fadca014')
+
+build() {
+ cd ${srcdir}/oauth-${pkgver}
+
+ python2 setup.py build || return 1
+ python2 setup.py install --root=${pkgdir} || return 1
+
+ install -Dm644 LICENSE.txt ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+}