summaryrefslogtreecommitdiffstats
path: root/abs/extra/qt-assistant-compat
diff options
context:
space:
mode:
authorMichael Hanson <hansonorders@verizon.net>2010-11-18 03:33:09 (GMT)
committerMichael Hanson <hansonorders@verizon.net>2010-11-18 03:33:09 (GMT)
commit7a9fb7bc25551e42858c320a58b719ab3be4df9e (patch)
tree079351640a3e2e6ff2f73181289aea0a741e1ae9 /abs/extra/qt-assistant-compat
parent0ef3e56b5e65fbaf28650b3ab6c35ae9d08dd24a (diff)
downloadlinhes_pkgbuild-7a9fb7bc25551e42858c320a58b719ab3be4df9e.zip
linhes_pkgbuild-7a9fb7bc25551e42858c320a58b719ab3be4df9e.tar.gz
linhes_pkgbuild-7a9fb7bc25551e42858c320a58b719ab3be4df9e.tar.bz2
qt-assistant-compat: initial import 4 pyqt
Diffstat (limited to 'abs/extra/qt-assistant-compat')
-rw-r--r--abs/extra/qt-assistant-compat/PKGBUILD55
-rw-r--r--abs/extra/qt-assistant-compat/debian_patches_01_build_system.diff48
2 files changed, 103 insertions, 0 deletions
diff --git a/abs/extra/qt-assistant-compat/PKGBUILD b/abs/extra/qt-assistant-compat/PKGBUILD
new file mode 100644
index 0000000..49fa9f0
--- /dev/null
+++ b/abs/extra/qt-assistant-compat/PKGBUILD
@@ -0,0 +1,55 @@
+# $Id: PKGBUILD 92392 2010-09-29 14:51:01Z ronald $
+# Maintainer: Ronald van Haren <ronald.archlinux.org>
+
+pkgname=qt-assistant-compat
+pkgver=4.6.3
+pkgrel=1
+pkgdesk="compat version of Qt Assistant"
+url="http://qt.nokia.com/"
+arch=('i686' 'x86_64')
+license=('GPL3' 'LGPL')
+depends=('qt')
+source=('ftp://ftp.qt.nokia.com/qt/source/qt-assistant-qassistantclient-library-compat-src-4.6.3.tar.gz'
+ 'debian_patches_01_build_system.diff')
+md5sums=('a20148e0488d5c12ab35ccc107dcc64d'
+ '1b55290dc9fab0c035797e9301d2fa61')
+
+# separate package function does not really work here due to broken build files
+build() {
+ cd ${srcdir}/qt-assistant-qassistantclient-library-compat-version-${pkgver}
+
+ patch -Np1 -i ${srcdir}/debian_patches_01_build_system.diff
+
+ cd lib; if [ -e Makefile ]; then $(MAKE) distclean; fi
+ rm -f translations/assistant_adp_*.qm
+
+ qmake CONFIG+=create_prl
+ make
+ cd ../translations; lrelease assistant_adp_*.ts
+ cd ..
+ qmake CONFIG+=create_prl
+ make
+}
+
+package(){
+ cd ${srcdir}/qt-assistant-qassistantclient-library-compat-version-${pkgver}
+
+ make install INSTALL_ROOT=${pkgdir}
+ cd lib
+ make install INSTALL_ROOT=${pkgdir}
+ cd ..
+
+ # Fix wrong path in prl file
+ sed -i -e "/^QMAKE_PRL_BUILD_DIR/d" \
+ ${pkgdir}/usr/lib/libQtAssistantClient.prl
+
+ # Install translations
+ install -d ${pkgdir}/usr/share/qt/translations/
+ install -p -m0644 translations/assistant_adp_*.qm \
+ ${pkgdir}/usr/share/qt/translations/
+
+ # Install prf file
+ install -D -p -m0644 features/assistant.prf \
+ ${pkgdir}/usr/share/qt/mkspecs/features/assistant.prf
+
+}
diff --git a/abs/extra/qt-assistant-compat/debian_patches_01_build_system.diff b/abs/extra/qt-assistant-compat/debian_patches_01_build_system.diff
new file mode 100644
index 0000000..3266ced
--- /dev/null
+++ b/abs/extra/qt-assistant-compat/debian_patches_01_build_system.diff
@@ -0,0 +1,48 @@
+Description: several workarounds for the build system which is completely broken
+Author: Fathi Boudra <fabo@debian.org>
+
+--- a/compat.pro
++++ b/compat.pro
+@@ -66,8 +66,6 @@ TRANSLATIONS = translations/assistant_ad
+ translations/assistant_adp_zh_CN.ts \
+ translations/assistant_adp_zh_TW.ts
+
+-unix:!contains(QT_CONFIG, zlib):LIBS += -lz
+-
+ contains(CONFIG, static): {
+ win32 {
+ exists($$[QT_INSTALL_PLUGINS]/imageformats/qjpeg.lib) {
+@@ -81,3 +79,7 @@ contains(CONFIG, static): {
+ }
+ }
+ }
++
++target.path = $$[QT_INSTALL_BINS]
++INSTALLS += target
++
+--- a/lib/lib.pro
++++ b/lib/lib.pro
+@@ -16,8 +16,8 @@ HEADERS = qassistantclient.h \
+ qassistantclient_global.h
+ SOURCES = qassistantclient.cpp
+
+-DESTDIR = ../../../../lib
+-DLLDESTDIR = ../../../../bin
++DESTDIR = lib
++DLLDESTDIR = bin
+
+ unix {
+ QMAKE_CFLAGS += $$QMAKE_CFLAGS_SHLIB
+@@ -62,7 +62,7 @@ win32 {
+ }
+
+ qt_install_headers {
+- assistant_headers.files = $$SYNCQT.HEADER_FILES $$SYNCQT.HEADER_CLASSES
++ assistant_headers.files = qassistantclient.h qassistantclient_global.h
+ assistant_headers.path = $$[QT_INSTALL_HEADERS]/QtAssistant
+ INSTALLS += assistant_headers
+ }
+--- /dev/null
++++ b/lib/QtAssistant/qassistantclient_global.h
+@@ -0,0 +1 @@
++#include "../qassistantclient_global.h"