summaryrefslogtreecommitdiffstats
path: root/abs/extra/rrdtool/PKGBUILD
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2014-12-05 19:45:29 (GMT)
committerBritney Fransen <brfransen@gmail.com>2014-12-05 19:45:29 (GMT)
commit067b6a8f9d44f008b93d92eda8f05cc35c1de62e (patch)
treed352601dddcb9ccdf1439e2587d133487cdd31b1 /abs/extra/rrdtool/PKGBUILD
parentc204f789f51f7ea34418df66071f78dc99be448d (diff)
downloadlinhes_pkgbuild-067b6a8f9d44f008b93d92eda8f05cc35c1de62e.zip
linhes_pkgbuild-067b6a8f9d44f008b93d92eda8f05cc35c1de62e.tar.gz
linhes_pkgbuild-067b6a8f9d44f008b93d92eda8f05cc35c1de62e.tar.bz2
rrdtool: update to 1.4.8
Diffstat (limited to 'abs/extra/rrdtool/PKGBUILD')
-rw-r--r--abs/extra/rrdtool/PKGBUILD53
1 files changed, 31 insertions, 22 deletions
diff --git a/abs/extra/rrdtool/PKGBUILD b/abs/extra/rrdtool/PKGBUILD
index d22d133..fb5a6fe 100644
--- a/abs/extra/rrdtool/PKGBUILD
+++ b/abs/extra/rrdtool/PKGBUILD
@@ -1,39 +1,48 @@
-# $Id: PKGBUILD 88191 2010-08-21 01:59:03Z eric $
-# Maintainer: Eric Belanger <eric@archlinux.org>
-# Contributor: Tom K <tom@archlinux.org>
+# $Id$
+# Maintainer: Eric BĂ©langer <eric@archlinux.org>
pkgname=rrdtool
-pkgver=1.4.4
-pkgrel=2
+pkgver=1.4.8
+pkgrel=4
pkgdesc="Data logging and graphing application"
arch=('i686' 'x86_64')
url="http://www.rrdtool.org"
license=('GPL' 'custom')
-depends=('libpng' 'libxml2' 'pango')
-makedepends=('intltool' 'ruby' 'python2' 'tcl' 'lua')
+depends=('libxml2' 'pango' 'ttf-dejavu')
+makedepends=('intltool' 'ruby' 'python2' 'tcl' 'lua51')
optdepends=('tcl: to use corresponding binding' \
'python2: to use corresponding binding' \
'ruby: to use corresponding binding' \
- 'lua: to use corresponding binding')
-options=('!libtool' '!emptydirs' '!makeflags')
-changelog=ChangeLog
-source=(http://oss.oetiker.ch/rrdtool/pub/rrdtool-${pkgver}.tar.gz)
-md5sums=('93ad2fc2e9ddcd7d99c611fe30284a54')
-sha1sums=('e4715c13f2a6fd077c54911d396eb573788377b0')
+ 'lua51: to use corresponding binding')
+options=('!emptydirs' '!makeflags')
+source=(http://oss.oetiker.ch/rrdtool/pub/rrdtool-${pkgver}.tar.gz
+ rrdtool-pangofont.patch rrdtool-systemd.patch)
+sha1sums=('56d68857f39e70bfa32360947614d8220702ed02'
+ '8c600285bdab7776c1d5301df7cf486d69eae048'
+ '963b600f8056d85305b6ff4554fa1e7b9b5a4ae1')
+
+prepare() {
+ cd ${pkgname}-${pkgver}
+ # fix FS#28521 make ruby install to vendor_ruby instead of site_ruby
+ sed -e 's/$(RUBY) extconf.rb/& --vendor/' -i bindings/Makefile.am
+ patch -p1 -i "${srcdir}/rrdtool-pangofont.patch"
+ patch -p1 -i "${srcdir}/rrdtool-systemd.patch"
+}
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- ./configure --prefix=/usr --localstatedir=/var --disable-rpath --enable-perl \
- --enable-perl-site-install --with-perl-options='INSTALLDIRS=vendor' \
+ cd ${pkgname}-${pkgver}
+ autoreconf
+ PYTHON=python2 LUA=/usr/bin/lua5.1 \
+ LUA_CFLAGS="-I/usr/include/lua5.1 -llua5.1" LUA_INSTALL_CMOD="/usr/lib/lua/5.1" \
+ ./configure --prefix=/usr --localstatedir=/var --disable-rpath \
+ --enable-perl --enable-perl-site-install --with-perl-options='INSTALLDIRS=vendor' \
--enable-ruby --enable-ruby-site-install --enable-python \
- --enable-lua --enable-lua-site-install \
- --enable-tcl
- make
+ --enable-lua --enable-lua-site-install --enable-tcl --disable-libwrap
+ make LIBS+="-lglib-2.0"
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- make DESTDIR="${pkgdir}" LIBRUBYARG_SHARED="-Wl,-L/usr/lib -lruby" \
- LIBPATH="-L. -L/usr/lib -L../../src/.libs" install
+ cd ${pkgname}-${pkgver}
+ make DESTDIR="${pkgdir}" includedir=/usr/include install
install -D -m644 COPYRIGHT "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}