summaryrefslogtreecommitdiffstats
path: root/abs/extra/rrdtool/PKGBUILD
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2009-09-26 01:57:08 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2009-09-26 01:57:08 (GMT)
commit7b29169fff9e7c624890c5edffe85def8a293136 (patch)
tree47753889faa3a2063b66d1c7e7681e703eb1b39a /abs/extra/rrdtool/PKGBUILD
parentc491dea779dac29afff3578bf8245943817c2339 (diff)
downloadlinhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.zip
linhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.tar.gz
linhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.tar.bz2
LinHES 6.01.00
Diffstat (limited to 'abs/extra/rrdtool/PKGBUILD')
-rw-r--r--abs/extra/rrdtool/PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/abs/extra/rrdtool/PKGBUILD b/abs/extra/rrdtool/PKGBUILD
new file mode 100644
index 0000000..9d67224
--- /dev/null
+++ b/abs/extra/rrdtool/PKGBUILD
@@ -0,0 +1,29 @@
+# $Id: PKGBUILD 24808 2009-01-21 07:19:42Z eric $
+# Maintainer: Eric Belanger <eric@archlinux.org>
+# Contributor: Tom K <tom@archlinux.org>
+
+pkgname=rrdtool
+pkgver=1.3.6
+pkgrel=7
+pkgdesc="Data logging and graphing application"
+arch=('i686' 'x86_64')
+url="http://www.rrdtool.org"
+license=('GPL')
+depends=('libart-lgpl' 'libpng' 'freetype2' 'libxml2' 'pango' )
+makedepends=('python' 'tcl' 'ruby')
+optdepends=('tcl, python and/or ruby: to use corresponding binding')
+options=('!libtool' '!emptydirs')
+source=(http://oss.oetiker.ch/rrdtool/pub/rrdtool-${pkgver}.tar.gz)
+md5sums=('afaabd5a60115581e866efbac796d307')
+sha1sums=('4a8499ab58dfd37419bf1cb2429a29da9bc782c3')
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ ./configure --prefix=/usr --enable-perl-site-install \
+ --with-perl-options='INSTALLDIRS=vendor' --enable-ruby-site-install || return 1
+ make || return 1
+ make DESTDIR=${pkgdir} install || return 1
+
+ find ${pkgdir} -name '.packlist' -delete
+ find ${pkgdir} -name 'perllocal.pod' -delete
+}