summaryrefslogtreecommitdiffstats
path: root/abs/extra/rsync/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-08-07 20:47:16 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-08-07 20:47:16 (GMT)
commit86c8c6ce49e4d7e19e372655f8ba34463a6971d1 (patch)
treef7545c086530d733f64215d3af374f17fcdcf132 /abs/extra/rsync/PKGBUILD
parent4fb8f045fa01f28e5b31c3b821145365f5710e36 (diff)
downloadlinhes_pkgbuild-86c8c6ce49e4d7e19e372655f8ba34463a6971d1.zip
linhes_pkgbuild-86c8c6ce49e4d7e19e372655f8ba34463a6971d1.tar.gz
linhes_pkgbuild-86c8c6ce49e4d7e19e372655f8ba34463a6971d1.tar.bz2
rysnc 3.0.9
Diffstat (limited to 'abs/extra/rsync/PKGBUILD')
-rw-r--r--abs/extra/rsync/PKGBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/abs/extra/rsync/PKGBUILD b/abs/extra/rsync/PKGBUILD
new file mode 100644
index 0000000..1224537
--- /dev/null
+++ b/abs/extra/rsync/PKGBUILD
@@ -0,0 +1,39 @@
+# $Id: PKGBUILD 160933 2012-06-07 05:56:33Z pierre $
+
+pkgname=rsync
+pkgver=3.0.9
+pkgrel=3
+pkgdesc="A file transfer program to keep remote files in sync"
+arch=('i686' 'x86_64')
+url="http://samba.anu.edu.au/rsync/"
+license=('GPL3')
+depends=('perl')
+backup=('etc/rsyncd.conf' 'etc/xinetd.d/rsync')
+source=("http://rsync.samba.org/ftp/rsync/$pkgname-$pkgver.tar.gz"
+ 'rsyncd.conf' 'rsyncd' 'rsync.xinetd' 'rsyncd.service')
+md5sums=('5ee72266fe2c1822333c407e1761b92b'
+ 'bce64d122a8e0f86872a4a21a03bc7f3'
+ 'ba413da4ebca05c57860151fda21efbc'
+ 'ea3e9277dc908bc51f9eddc0f6b935c1'
+ 'ec96f9089d71109557cdcaa3f0633ed6')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ ./configure --prefix=/usr --with-included-popt
+ make
+}
+
+check() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make test
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+ install -Dm755 ../rsyncd "$pkgdir/etc/rc.d/rsyncd"
+ install -Dm644 ../rsyncd.conf "$pkgdir/etc/rsyncd.conf"
+ install -Dm644 ../rsync.xinetd "$pkgdir/etc/xinetd.d/rsync"
+ install -Dm644 ../rsyncd.service "$pkgdir/usr/lib/systemd/system/rsyncd.service"
+ install -Dm755 support/rrsync "$pkgdir/usr/lib/rsync/rrsync"
+}