summaryrefslogtreecommitdiffstats
path: root/abs/extra/rsync
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2015-08-11 16:34:05 (GMT)
committerBritney Fransen <brfransen@gmail.com>2015-08-11 16:34:05 (GMT)
commitb5429bc5fdf0f1d7f94ed75e309b5031eed55a59 (patch)
treec8e771c532f6a3d0ae157f4b127c229f0cc4836e /abs/extra/rsync
parentd612093c2babb2bc4cfb072c67b5e66339ec9817 (diff)
downloadlinhes_pkgbuild-b5429bc5fdf0f1d7f94ed75e309b5031eed55a59.zip
linhes_pkgbuild-b5429bc5fdf0f1d7f94ed75e309b5031eed55a59.tar.gz
linhes_pkgbuild-b5429bc5fdf0f1d7f94ed75e309b5031eed55a59.tar.bz2
rsync: udpate to 3.1.1
Diffstat (limited to 'abs/extra/rsync')
-rw-r--r--abs/extra/rsync/PKGBUILD16
-rw-r--r--abs/extra/rsync/rsyncd.service1
-rw-r--r--abs/extra/rsync/rsyncd@.service2
3 files changed, 9 insertions, 10 deletions
diff --git a/abs/extra/rsync/PKGBUILD b/abs/extra/rsync/PKGBUILD
index ab83127..d94f712 100644
--- a/abs/extra/rsync/PKGBUILD
+++ b/abs/extra/rsync/PKGBUILD
@@ -1,31 +1,31 @@
# $Id$
pkgname=rsync
-pkgver=3.1.0
-pkgrel=1
+pkgver=3.1.1
+pkgrel=4
pkgdesc="A file transfer program to keep remote files in sync"
arch=('i686' 'x86_64')
-url="http://samba.anu.edu.au/rsync/"
+url="http://rsync.samba.org/"
license=('GPL3')
-depends=('perl' 'popt')
+depends=('perl' 'popt' 'acl' 'zlib')
backup=('etc/rsyncd.conf' 'etc/xinetd.d/rsync')
source=("http://rsync.samba.org/ftp/rsync/$pkgname-$pkgver.tar.gz"
"http://rsync.samba.org/ftp/rsync/$pkgname-$pkgver.tar.gz.asc"
'rsyncd.conf' 'rsync.xinetd' 'rsyncd.service'
'rsyncd.socket' 'rsyncd@.service')
-md5sums=('3be148772a33224771a8d4d2a028b132'
+md5sums=('43bd6676f0b404326eee2d63be3cdcfe'
'SKIP'
'bce64d122a8e0f86872a4a21a03bc7f3'
'ea3e9277dc908bc51f9eddc0f6b935c1'
- '084140868d38cf3e937a2db716d47c0f'
+ 'f90ba7f3717028769d6f230a2402b5aa'
'ae4c381e0c02d6132c7f6ded3f473041'
- '53f94e613e0bc502d38dd61bd2cd7636')
+ 'ceab0b656e5e8239df594040b3b31d3c')
+validpgpkeys=('0048C8B026D4C96F0E589C2F6C859FB14B96A8C5')
build() {
cd "$srcdir/$pkgname-$pkgver"
./configure --prefix=/usr \
--with-included-popt=no \
- --with-included-zlib=no \
--disable-debug
make
}
diff --git a/abs/extra/rsync/rsyncd.service b/abs/extra/rsync/rsyncd.service
index 8502c08..cd45687 100644
--- a/abs/extra/rsync/rsyncd.service
+++ b/abs/extra/rsync/rsyncd.service
@@ -1,5 +1,6 @@
[Unit]
Description=A file transfer program to keep remote files in sync
+After=network.target
[Service]
ExecStart=/usr/bin/rsync --daemon --no-detach
diff --git a/abs/extra/rsync/rsyncd@.service b/abs/extra/rsync/rsyncd@.service
index 33db95c..f52dc76 100644
--- a/abs/extra/rsync/rsyncd@.service
+++ b/abs/extra/rsync/rsyncd@.service
@@ -7,5 +7,3 @@ ExecStart=-/usr/bin/rsync --daemon
StandardInput=socket
StandardOutput=inherit
StandardError=journal
-User=nobody
-Group=nobody